Optical Calibration Standard targets seem out of sequence - vision probe calibration

  • Filter
  • Time
  • Show
Clear All
new posts

  • Optical Calibration Standard targets seem out of sequence - vision probe calibration

    I'm not sure what details are really relevant here, because I'm pretty new to this. Let me start with what I think are the relevant details behind the error message, and then later fill in what may not be useful
    Machine: Tesa Visio 300 DCC
    PCDMIS Version 2010 R2 Pro )(Cad seems really nice!)
    Other Symptoms: PCDMIS says it cannot zoom, that I need to recalibrate
    Calibration Slide: Just bought the quite expensive calibration slide direct from hexagon PN 25-1234-02
    FrameGrabber: IDS Falcon
    Windows 10 x64

    So here's what I tried. I went into the probe setup, clicked measure. I tried calibrate optical center, but when I click the ++ button PCDMIS happily gives me the message "Attempted to move outside calibrated range- Ple re-calibrate optics." … Well, I thought that's what I was trying to do!
    Fine, I manually moved the zoom....maybe not the best thing for accuracy....and did the center calibration. It was fairly close.
    I then go to calibrate optics. The only option for calibration standard not disabled is "Hexagon Metrology slide", which, as far as I know, is what I bought.
    Under the calibrate group I selected "Pixel Size" only (KISS to begin with)
    Under settings Illumination is "Bottom Light"
    Focus Lens N.A. is 0.00 and Range is 1.856 (Not really sure what those are for, so I didn't touch them)
    I hit calibrate
    The light level changes a bit, and it goes through the 3 popups about being aligned, cleaned, etc. I read the model number for the slide off the video of the machine, so I'm fairly confident its face up
    I let it do its focus. I've tried this step all around the slide. Nothing seems to make a difference there...
    It then asks to center the rectangular targets. I assume this is the rectangles in rectangles...so I do....
    It then adjusts light again, and draws some autoline boxes around the outermost rectangle. Then it complains with the message in the topic. I'll include a screenshot from the calibration to make sure I'm not doing something incredibly stupid. Also including the part number in the view in case I'm not supposed to be able to read it normally

    I suspect I have more than one problem....

  • #2
    Other likely irrelevant details:
    I bought the machine used, and "broken". I suspected it took a surge, and being a software engineer with a strong background in electronics, I gambled that I could repair the machine. So far the gable paid off. It had an x axis issue where it wouldn't home. It ended up needing a new glass scale encoder and a new servo amp (along with fixing the software settings that someone messed with trying to "fix" it. All axes home, and I can take measurements....just with the zoom fixed. Why suspect a surge? They said they had already replaced the power supply, and motherboard. By power supply they meant both the computer's supply and the CMM's power supply. seems like a surge was quite likely.
    The Computer this is running on is a new core i5 9th gen on windows 10 x64. (Yup, you can still get motherboards with 2 pci slots!) I'm using the IDS Falcon video capture since the matrox card ridiculously doesn't support x64.
    I'm about to try switching back to the original computer/capture card just to factor that out, but I strongly suspect software configuration.


    • #3

      From ftp :
      IDS_45100.exe What is it? PC-DMIS Framegrabber standard Device Driver Installation Utility for PC-DMIS 2010 and later.
      for IDS Falcon and Eagle.
      Install the software before installing the framegrabber board.
      NOTE: The IDS framegrabbers must not be used on a PC with a TV card driver (such as WinTV from Hauppauge) or other drivers for multimedia cards using a Bt848 or Bt878 chip.
      These drivers may overwrite the IDS EEPROM (error code 14) and make the board unusable.
      After running IDS_34`00.exe additional information can be found in Program Files\IDs\Falcon\Help\Falcon_Eagle_ENU.pdf.
      Support in PCDMIS requires a WAI_FrameGrabber_IDS dll (the initial version will be posted here on the FTP site) and that the HKEY_LOHKEY_LOCAL_MACHINE\Software\WAI\PC-DMIS\MSI\FrameGrabber_Type registry value be set to 201 for Falcon and 202 for Eagle.
      How to use? Standard Install. Run IDS_45100.exe


      Hope this helps...


      • #4
        Well, as usual, I don't seem to have been clear. I'm running PC-DMIS 2010r2, so I'm good there, and without the registry setting and the DLL, I wouldn't have been able to get the screenshots I posted. (trust me, I know for a fact what happens when you get it wrong )

        What I fear is that perhaps the calibration standard has been updated somehow since PC-DMIS 2010, and I either need an old standard, or new software.


        • #5
          Could it be an issue with PCD 2010 and Windows 10?
          Whatever a man sows, he shall reap.


          • #6
            It has the same issue on XP.

            I think though that with some research, I'm onto the problem, but can't seem to get to the solution yet. The computer that came with this has only fixed probe/calibration files. So I have .75 or 1x. The machine however, is actually a .7 to 4.5 motorized zoom. So .75 and 1.0 calibrated probe files means everything "looks" wrong. Honestly, I;ve been testing with the file marked 1.0, so its probably really bad. I may try the .75 and see if it makes a difference.

            So, any ideas on this? Does anyone in here have a visio 300 dcc with motorized zoom who wants to send me the as-shipped prb/ocf/whatever else I need files that allows zooming? Do you think Hexagon who now owns tesa might have it? I'm so close to having this thing working exactly as I want/need it to after 4 weeks of non-stop working on it. Granted, I probably spent waaaaaay too much time getting PC-DMIS 2010 to work on Windows 10 x64! If anyone wants the "magic formula" to make this work I'm more than willing to post. It was pretty easy, though slightly hackish


            • #7
              So I went through all the CD's I have that came with the machine. Sees the only place I have Tesa items defined were on the PC-DMIS DVDs, and none of the probe definitions use motorized zoom????? What gives? Is this a special extra money option? Nothing I see will allow me to use the zoom, but the joystick pendant has + and - zoom buttons, so it clearly supports it.

              Anyone have any ideas?! (Beyond calling hexagon....service/tech support seems much less willing to talk/help without a big payment up front...and I really just want the config files....not a ton of support)


              • #8
                You can look at the vision manual here, there are many informations about calibration, machine option tabs... :


                • #9
                  So, the manual didn't really help with the issue, but it did get me thinking about the error message. It says out of sequence, as if it thinks it moved, despite seeing no motion. What motion? Its gotta be zoom. PC-DMIS won't let me test zoom though. I do have a program from the QC5000 controller card. Well, that program also won't zoom, which means I'm likely on to something.

                  I see that for zoom in the qc5000 program, it has options for "Legacy", "Open Loop Stepper", "Closed Loop Servo", and "Closed Loop Stepper". Looking at the zoom mechanism on the machine itself, it sure looks like there is some sort of position encoder, though I couldn't tell you what sort (so I assume closed loop), and I'm not removing it to find out! (Don't need to have to calibrate that too!) Seeing that stepper is an option, I decided to have a closer look at the motor. At first, when I moved it manually, I didn't feel any cogging, so I discounted it being a stepper motor, however, this time, I noticed the sound. It sounds like a stepper through a gearbox. So, what the heck, I try setting it to stepper. Suddenly, its holding position. In the open loop mode it will try to home, though it doesn't seem to do a good job.

                  So I'm fairly certain this is a stepper motor. Unfortunately, that's where my progress ends. I don't have a clue what the settings are supposed to be. I double checked the Tesa Directory in the Program Files and the cnc.ini file still shows servo for the zoom axis. I verified axis 4 was zoom by setting it to stepper in the PC-DMIS directory, and fired up PC-DMIS, which then powered the stepper. Regardless of that, none of the axes were marked as stepper. So I'm fairly certain someone at the company who owned this machine when it got the suspected surge, or the used machinery dealer overwrote the original settings. Worse, I found tools to open the ghost image dell distributed as a restore disk (let me tell you, finding ghostexplorer from a site that isn't sketchy is impossible! virustotal said the one I found was clean). No Tesa directory there. No other discs I received have it either, so I suspect I'm missing a disc. So unless someone has a Visio 300 dcc they're willing to send me some settings from, I think I'm out of luck without some help from hexagon. If anyone wants to help without responding publicly, an email address I check sometimes (not my main one, not going to post that here) is corrysjunk at gmail dot com (Still don't want that one to be picked up by basic web scrapers, though that pattern is probably programmed in most bots as well...)

                  Otherwise, I guess I'll see what I can get from Hexagon tomorrow. Who knows, maybe there is another CD that I can order as a "part"
                  Last edited by Corry; 10-15-2019, 11:11 PM.


                  • #10
                    So, I think I was definitely on to something....couldn’t get settings, so I figured it must be that it should be that simple. Running the zoom several times suddenly caused the stepper driver to fry, short circuit, and kill the fpga on the pci card (or well I was pretty sure). After getting a ludicrous quote to replace the card, no repair options, etc, I decided to buy a bga rework machine and replace the fpga myself. The short answer is success! I also replaced the stepper driver, and I can hear pcdmis home it now, so I think it’s all working. I have another issue now though before I can test the calibration, but I’ll post that separately. I think it’s a much easier issue


                    • #11
                      Well, I'm back. I actually replaced the FPGA and board driver, repaired the PCB, the whole shebang. Still no zoom. I checked the encoder off the zoom motor, nothing. So I called up faulhaber, and they got me a replacement! Tested it in a test harness, and it worked. Plugged it in, no worky. Turns out the ground wire in the harness was broken. No continuity end to end. So, I replace that, anmd magically I have encoder pulses, FINALLY! Trial and error in the qc5k program led me to settings for the zoom of "Legacy", max counts 58. My motor wires may be backwards, because this wasn't the original harness, so I had to hit the reversed, limits reversed, and all, but then, it would move in the qc5k program. So I transferred the settings to PCDMIS's CNC.INI file, and...….

                      let down.

                      PCDMIS still refuses to zoom. Still get the "Attempted to move outside of calibrated range. Please re-calibrate optics" when I try to zoom manually, and the auto calibration with the calibration slide behaves the exact same way.

                      Any techs troll this place? Come on, I have to be close. I have all the hardware functional. Its gotta be some stupid setting somewhere in PCDMIS!


                      • #12
                        Hmmm...maybe see if there is something in the Settings Editor. Might have to search for "zoom".
                        Whatever a man sows, he shall reap.


                        • #13
                          I somehow suspect its in the registry. There are zoom settings there, and it like it wants to treat it as an "external servo" rather than using the servo drive on the QC5000 card. Whoever had this machine before me (And I know who that is because they left their info all over the computer ) really fouled up the settings here! I really don't want to have to cry uncle and call a tech when I'm this close....in truth, I had tried before, and it was hard to get them to even talk to me! Crazy how all the hardware guys in this are super cool, super helpful, etc, but the software side of Hexagon?! Its as if t hey're saying we need a retainer...


                          • #14
                            Ok, something I wrote there worked like rubber duck debugging....so I appreciate your help

                            I said it seems to be trying to treat the zoom like another axis....I assumed that would be the "Q Axis" the card supports, and doesn't help me one bit.
                            Well, I figured what they heck, I already burned this card out 2 different ways, and I repaired them both myself for (relatively) cheap. (The BGA rework machine wasn't cheap, but far cheaper than a new card!!!, and the FPGA was $50 in quanity 1, so not too bad) So whats the worse that could happen? I gave axis 4 settings that seemed reasonable for zoom, and said "Stepper=1" figuringit would then use the "stepper" settings (which are actually servo settings....lazy software engineers!! or ignorant ones....being a software engineer myself...) Anyhow, I told it to enable the limits and all the rest, and PCDMIS actually used the zoom! Its still not right as once it had homed, I got a motion controller initialization failure....so something is wrong with the zoom still, but I'm close!


                            Related Topics