Profile does not take the whole curve of CAD

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Profile does not take the whole curve of CAD

    Hi, I have selected a curve to measure a 2D-profile. The strange thing is that PC-DMIS does not recognize the CAD curve entirely. It goes ok, untill one curve.. Then it goes out of screen. I understood that this is some setting you have to set in settings editor.. But which one??

    Briefly, there should be some settings in settings editor which control the CAD curves and helps PC-DMIS to read these curves better. Does anyone knows more about these settings??

  • #2
    See picture attached for the problem I have. You can see that PC-DMIS does not take the curve in this are for measuring the profile
    Attached Files

    Comment


    • #3
      Anyone an idea??

      I think it should be an option somehwere in the settings editor. Then scan path contains only straight lines and needs to follow the polyline.

      Comment


      • #4
        Could it be the CAD is having the wrong surface vectors, so PC-DMIS is evaluating to the other side?
        AndersI
        SW support - Hexagon Metrology Nordic AB

        Comment


        • #5
          Hi, the CAD file vectors are good, because the CAD was tested on another pc with pcdmis and the curve was good on that pc

          Comment


          • #6
            Which version are you running? I believe it was sealevel that confirmed it's working properly now in the 2018R2 SP2. Previously wasn't working correctly, exactly what you are seeing. Not snapping to CAD. I don't use the feature for many things.

            Comment


            • #7
              I still get 'off the CAD' but on the amount of .0001 to .0002 when OFFline. (the 2D profile application still not acceptable to me!) Very strange. And.... that is only when using Optics. If I recreate the profile with a tip/analog scan (the same profile as Optics, it is dead-on.

              Comment


              • InspectorJester
                InspectorJester commented
                Editing a comment
                Interesting.. Then what's the best way to get a vision profile?

            • #8
              Originally posted by MihaelR View Post
              Anyone an idea??

              I think it should be an option somehwere in the settings editor. Then scan path contains only straight lines and needs to follow the polyline.
              Could you confirm if you are using the Legacy Profile 2D or the updated Profile 2D. If you go to F5 Settings, there will be a tick box with the option of "Use Legacy 2D Profile" Please ensure this is un checked as the legacy 2D profile only supported lines and arcs. If you are still having issues, you can contact me directly at neil.ryan@hexagon.com

              Comment


              • #9
                OTE=sealevel;n447989]I still get 'off the CAD' but on the amount of .0001 to .0002 when OFFline. (the 2D profile application still not acceptable to me!) Very strange. And.... that is only when using Optics. If I recreate the profile with a tip/analog scan (the same profile as Optics, it is dead-on.[/QUOTE]

                sealevel What you are seeing when using 2D profile offline is due to the following:
                the nominal form of the 2D profile is a series of line segment, not the exact curve, when you execute offline, it returns the points on the nominal form as the measured points, but the points' theo data is from cad, therefore there are some difference. Online and offline both compare to cad(theo), the difference is the measure data, it is from nominal form for offline vs from parts for online.

                Comment

                Related Topics

                Collapse

                Working...
                X