Programs running out of order

  • Filter
  • Time
  • Show
Clear All
new posts

  • Programs running out of order


    We have had our Absolute Arm for about 4 months now and every so often I run into a situation where the program will tell me to measure features in a different order than I have programed them.

    The inspection team has never used a manual CMM before, so it is critical during demonstrations with the team, that there is no programming errors. It is a tough piece of equipment to get adjusted to already, I can't have errors making it more difficult. Recently, when running programs, they have been running out of order a lot.

    The issue never happens previous to the alignment (And I verify the alignment was performed right by taking the probe and putting it to a feature and comparing it to the visuals on the screen before proceeding), but I'm curious if the machine is trying to optimize the order in which we measure features automatically? It is happening across multiple P/Ns and codes so I don't want to post sample code, but has anyone had this happen to their machine before, or familiar with this?

    Thanks for your time in advance.

  • #2
    there's a setting called "Any order of execution" or something like that.

    Do a search for that and turn it off if it's on.


    • #3
      Its under preferences/ set up/ its a little check box in the general section.

      it only engages after an alignment that looks like a final alignment with a lot of blocks after it.
      Then if your wildly swinging the Z mast around, you get close enough to some other hole, then Pc-Dmis thinks your doing that one and tries to help you, by jumping to it wherever it is in the program.

      Its awesome after you tie into a part, then just start beeping features, and then think about redheads, harley's, a raise...


      • tking
        tking commented
        Editing a comment
        Haven't seen you around but good to see you back!

      • Zeros
        Zeros commented
        Editing a comment
        I am happy to see that I am not the only one who daydreams at work.

    • #4
      F5, General tab, far down: "Any order execute tolerance", set it to zero to turn off the function (AFAIK).
      SW support - Hexagon Metrology Nordic AB


      • #5
        Thanks everyone!


        Related Topics