Reference Dimension How To

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reference Dimension How To

    How can I add a reference dimension to the report without having a plus or minus tolerance? What I mean is, I don't want to see +0.0000 and -0.0000 all I want to see on the report is the actual measured dimension, the nominal and how far it deviates. and no matter how far the measured value is from the nominal that the report shows it as acceptable (GREEN) even if its off by a mile.

    Would I have to change the report and not show the +TOL, -TOL, and OUTTOL for reference dimensions every time or is there something simpler? Turning these on and off each time I have a reference dimension is like work. Even when I remove the extra stuff it still shows as red in color, Engineers do not like the red color, how do I change it to green, would I have to put a +/- 1,000 inches?

    When using Calypso it is as simple as not putting a checkmark in the +TOL and -TOL sections. Does PC-DMIS have something as simple as that?
    Last edited by Zeros; 06-11-2019, 06:46 PM.

  • #2
    Go to the spot in your program just before the dimension that you do not want to show the tolerance or if it is out of tolerance and place your curser there in the edit window and press the F10 button ( or from the top menu press Edit then Preferences and the go to parameters) and bring up the Parameters utility window Then in the new window under the dimension tab You can change how the dimension gets reported on your report window by UN-selecting the check mark in the tolerance and the out of tol columns then press apply and OK and it will enter a command into your program changing the dimension format but this will change it for all of t he dimensions to follow as well so if you do not want those that way you will have to change it back in the same procedure as I explained.See Attachments
    Attached Files
    Michael A Wildschutz Sr

    Comment


    • Zeros
      Zeros commented
      Editing a comment
      Yeah that's what I was afraid of, thanks for the how to information.

  • #3
    Give the tolerances mile wide values, then turn off the plus and minus tolerance . Nominal will then print but they won't be red.

    Comment


    • #4
      Other alternative is to extract the actual value from a non printing dimension and put it in a report comment.

      Comment


      • Zeros
        Zeros commented
        Editing a comment
        How would I do this? I am not very savvy with PC-DMIS so you may have to spell it out for me with a step by step instructions.

    • #5
      An alternative approach is to design a report label for this - make a copy of LEGACY_DIMENSION.LBL, remove the tolerances and graph from the label, save as REFERENCE_DIMENSION.LBL.

      Then you just right click on the dim in the report window, select "Change template..." and select your REFERENCE_DIMENSION.LBL. You still have to set a large tolerance to avoid red-coloring of the text (that can also be fixed, but I don't know exactly how).

      Edit: I see now that I forgot to remove the OUTTOL column, but you get it anyway, right?)

      REF_LABEL.PNG
      Last edited by AndersI; 06-13-2019, 03:10 AM.
      AndersI
      SW support - Hexagon Metrology Nordic AB

      Comment


      • Zeros
        Zeros commented
        Editing a comment
        Understood, too bad it must be so complicated. Calypso has a better grasp on things like this, but I cannot check everything on the Zeiss.

      • AndersI
        AndersI commented
        Editing a comment
        It's not really complicated. Creating the label is a one-time job. After that, the actual work to use it is a right click in the report window...

    • #6
      DIM D18= 2D DISTANCE FROM PLANE PLN5 TO POINT PNT7 PAR TO YAXIS,NO_RADIUS UNITS=MM,$
      GRAPH=OFF TEXT=OFF MULT=10.00 OUTPUT=NONE
      AX NOMINAL +TOL -TOL MEAS DEV OUTTOL
      M 13.000 0.800 0.800 13.000 0.000 0.000 -#-

      ASSIGN/V1=D18.MEAS

      COMMENT/REPT,
      "Reference Dimension 1 : " + V1



      NOTE that output is set to NONE in the dimension. This keeps the dimension from printing or saving to Datapage. If you want it save to datapage then output would need to be set to Stats.

      To get the Comment command to work the quotation marks and the plus sign are required. A space before and after the plus sign is also required. You can have any text that you want between the quotation marks.

      Comment


      • Zeros
        Zeros commented
        Editing a comment
        Thanks again, I will just change the Parameters Utility Window settings over and over and over again. This other stuff is too complicated for me for a simple reference dimension.

    Related Topics

    Collapse

    Working...
    X