HASP - Failed to start the Aladdin Device Driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • HASP - Failed to start the Aladdin Device Driver

    I tried running Hinstall and received the error:
    Failed to start the Aladdin Device Driver
    Failed to start a service in the Service Control Manager Database

    I also downloaded the latest HASP drivers and it looked like it installed correctly - but then when I went to run PC DMIS it still could not locate the lock.

    This is a PC that recently had drive formatted and XP re-installed and upgrade to SP2. PCDmis and lock working fine on other PC which is same model, etc....

    Any Suggestions???

  • #2
    What version of PC-DMIS?

    I believe that when XP came out, it was trouble for existing HASP drivers that worked fine in previous OS (2000, etc.). Are you sure the HASP driver you have is for XP?


    • #3
      PC DMIS 3.24.... I ran the Hinstall that came with that... to no avail.

      then downloaded latest version from Aladin & ran - it appeared to install but then as soon as I tried to re-install pcdmis or run it - I still had the errors....?


      • #4
        Yes, 3.24 definitely has the wrong driver.

        As far as the driver from Aladdin, its generally a good practice to throw in a few reboots.

        Un install the old driver (hinstall -r)


        install the new driver (hinstall -i)


        Then try PC-DMIS install


        • #5
          It finally worked! I uninstalled driver - removed key - reboot. then shutdown, add key, startup and re-install driver - seems to work so far....