HASP - Failed to start the Aladdin Device Driver

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HASP - Failed to start the Aladdin Device Driver

    I tried running Hinstall and received the error:
    Failed to start the Aladdin Device Driver
    Failed to start a service in the Service Control Manager Database

    I also downloaded the latest HASP drivers and it looked like it installed correctly - but then when I went to run PC DMIS it still could not locate the lock.

    This is a PC that recently had drive formatted and XP re-installed and upgrade to SP2. PCDmis and lock working fine on other PC which is same model, etc....

    Any Suggestions???

  • #2
    What version of PC-DMIS?

    I believe that when XP came out, it was trouble for existing HASP drivers that worked fine in previous OS (2000, etc.). Are you sure the HASP driver you have is for XP?

    Comment


    • #3
      PC DMIS 3.24.... I ran the Hinstall that came with that... to no avail.

      then downloaded latest version from Aladin & ran - it appeared to install but then as soon as I tried to re-install pcdmis or run it - I still had the errors....?

      Comment


      • #4
        Yes, 3.24 definitely has the wrong driver.

        As far as the driver from Aladdin, its generally a good practice to throw in a few reboots.

        Un install the old driver (hinstall -r)

        reboot

        install the new driver (hinstall -i)

        reboot

        Then try PC-DMIS install

        Comment


        • #5
          It finally worked! I uninstalled driver - removed key - reboot. then shutdown, add key, startup and re-install driver - seems to work so far....

          Comment

          Related Topics

          Collapse

          • METALMASTER
            HASP drivers won't install
            by METALMASTER
            I am re-installing an old version on a PC that was re-formatted. However, at end of install I receive a message saying it was unable to install the HASP...
            12-13-2007, 10:13 AM
          • JohnCTB
            Hasp driver question
            by JohnCTB
            I'm going to install v.4.3 from a disc. I have been running v.3.7mr3. I have Matt's instructions for installing a new version. Everything is backed up...
            01-14-2009, 09:58 AM
          • nhutnguyen
            EMERGENCY Help help
            by nhutnguyen
            My PC-Dims version3.5 was running fine with windows xp with SP1
            But when I upgrade to Windows XP SP3
            I got this message ‘HASP Device Driver...
            08-06-2010, 01:08 PM
          • John Kingston
            Hasp Driver
            by John Kingston
            Hey guys,
            Just got a new PC for the CMM. Copied my folders over, but it is giving us an error. "Lock missing - cannot proceed" . When...
            07-11-2006, 11:04 AM
          • davidb247
            Hasp Drivers
            by davidb247
            I am trying to move PCdmis from an NT4 machine to an XP machine.
            PCdmis is version 3.0864, after reading thru many of the threads here, it seems...
            07-19-2012, 08:45 AM
          Working...
          X