Is it possible to not print cal. results

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is it possible to not print cal. results

    V 3.5 MR2

    my print outs have the results from the AutoCalibrate of the probe. I was wondering if this could be turned off?

    Cheers

  • #2
    Originally posted by MFCguy View Post
    V 3.5 MR2

    my print outs have the results from the AutoCalibrate of the probe. I was wondering if this could be turned off?

    Cheers
    Isn't it in the PROBE SETUP window somewhere?
    sigpic
    Originally posted by AndersI
    I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

    Comment


    • #3
      Thats what I thought too. But when I go the Setup in the Probe Utilities, I have the Append results to report box UN-checked.
      I thought that would be what I want.

      Comment


      • #4
        Put your cursor in the line for the autocal.
        Hit F9
        Uncheck "show summary"

        Only problem is that it then doesn't display in the edit window so you can't see if the std. dev. is acceptable.

        Comment


        • #5
          Let me think a bit. I think you can get it to display but not print with a little work.

          Comment


          • #6
            I have show_summary= no,

            Thats why I am confused...

            Thanks for the help

            Comment


            • #7
              Originally posted by MFCguy View Post
              I have show_summary= no,

              Thats why I am confused...

              Thanks for the help
              Have you executed from the beginning since you changed it to no?


              I have show summary turned on. I have mine set up with an if/end_if so that the cal can be skipped. I know that if I run the program and run through the cal it will print. If I run the program and skip the cal, it doesn't print. Maybe something similar would work for you?

              Code:
              STARTUP    =ALIGNMENT/START,RECALL:, LIST= YES
                          ALIGNMENT/END
                          MODE/MANUAL
                          CHECK/ 0.1,1
                          TOUCHSPEED/ 1
              C1         =COMMENT/YESNO,NO,Do you want to view setup photos? 
                                          ,If yes close window when done and click "Continue".
                          IF/C1.INPUT=="YES"
               
                          END_IF/
              C2         =COMMENT/YESNO,NO,Do you want to calibrate tips?
                          IF/C2.INPUT=="YES"
                          LOADPROBE/4X20X30
                          TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
                          AUTOCALIBRATE/PROBE, PARAMETER_SET=806-106 4X20X30, QUALTOOL_MOVED=YES, 
                                        SHOW_SUMMARY=YES, OVERWRITE_RESULTSFILE=YES
              BEGIN AUTOCALIBRATE RESULTS FOR PROBE 4X20X30 USING SET 806-106 4X20X30
              Probe file=4X20X30    Date=12/18/2006    Time=8:56:50 AM
              Top Sphere     CENT X  11.0435 Y  24.2910 Z  -9.7849 D 0.7500
              T1A0B0         THEO X   0.0000 Y   0.0000 Z   7.5402 D 0.1575
              T1A0B0         MEAS X  -0.0047 Y  -0.0411 Z   7.5633 D 0.1564 StdDev 0.0001
              T1A90B0        THEO X   0.0000 Y   6.1622 Z   1.3780 D 0.1575
              T1A90B0        MEAS X  -0.0367 Y   6.1517 Z   1.3891 D 0.1565 StdDev 0.0001
              T1A90B-90      THEO X   6.1622 Y   0.0000 Z   1.3780 D 0.1575
              T1A90B-90      MEAS X   6.1855 Y   0.0027 Z   1.3905 D 0.1566 StdDev 0.0001
              T1A90B90       THEO X  -6.1622 Y   0.0000 Z   1.3780 D 0.1575
              T1A90B90       MEAS X  -6.1837 Y  -0.0697 Z   1.3822 D 0.1565 StdDev 0.0001
              END AUTOCALIBRATE RESULTS FOR PROBE 4X20X30 USING SET 806-106 4X20X30
              C11        =COMMENT/YESNO,NO,Please review the calibration results in the edit window. 
                                          ,Are the standard deviation values acceptable?
                          IF/C11.INPUT=="NO"
                          COMMENT/OPER,NO,Please re-start the program and run the calibration again.
                          PROGRAM/END
                          END_IF/
                          IF/C11.INPUT=="YES"
                          COMMENT/OPER,NO,Please re-start the program and answer No when asked 
              				"Do you want to calibrate tips?"
                          PROGRAM/END
                          END_IF/

              Comment


              • #8
                I get what you're saying, I think...

                Here's what I have...

                C4 =COMMENT/YESNO,HAS THE 2MM PROBE BEEN INSERTED AND CALIBRATED?
                IF/C4.INPUT=="NO"
                LOADPROBE/2MM
                TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
                AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=YES,
                SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
                END/IF



                I am trying to get it where if they haven't put in this probe and calibrated it, it does so automatically after they insert it. But it continues to print out the results when i start from the beginning

                Comment


                • #9
                  Originally posted by MFCguy View Post
                  I get what you're saying, I think...

                  Here's what I have...

                  C4 =COMMENT/YESNO,HAS THE 2MM PROBE BEEN INSERTED AND CALIBRATED?
                  IF/C4.INPUT=="NO"
                  LOADPROBE/2MM
                  TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
                  AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=YES,
                  SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
                  END/IF



                  I am trying to get it where if they haven't put in this probe and calibrated it, it does so automatically after they insert it. But it continues to print out the results when i start from the beginning
                  So if you skip the cal. it doesn't print them?

                  You do the cal and regardless of Show_Summary=No it prints them?

                  Comment


                  • #10
                    Originally posted by Goodluck View Post
                    So if you skip the cal. it doesn't print them?

                    You do the cal and regardless of Show_Summary=No it prints them?
                    if i skip the cal, it prints HAS PROBE BEEN INSERTED AND CALIBRATED? YES

                    and if i click NO to that questions, then it prints the X,Y,Z, and stnd dev.


                    Thanks for your help with this.

                    Comment


                    • #11
                      Originally posted by MFCguy View Post
                      Code:
                      C4         =COMMENT/YESNO,[COLOR="red"]YES[/COLOR],HAS THE 2MM PROBE BEEN INSERTED AND CALIBRATED?
                                  IF/C4.INPUT=="NO"
                                  LOADPROBE/2MM
                                  TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
                                  AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=YES, 
                                                SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
                      END/IF
                      Change YES to NO and it won't print the yes/no comment.

                      I just tried changing summary to No on mine and it still prints. It's the demon I guess.

                      As I was trying to convey earlier...

                      Code:
                      C4         =COMMENT/YESNO,NO,HAS THE 2MM PROBE BEEN INSERTED AND CALIBRATED?
                                  IF/C4.INPUT=="NO"
                                  LOADPROBE/2MM
                                  TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
                                  AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=YES, 
                                                SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
                      [COLOR="red"]COMMENT/OPER,NO,Please re-start the program and skip the calibration.
                                  PROGRAM/END[/COLOR]
                      END/IF
                      Put the red in and it will end the program after the calibration. Then, if they can follow directions, they will start the program again, answer they don't want/need to calibrate the tip. Then when it is done running, the results should not print.
                      Last edited by #2#; 10-02-2007, 02:49 PM.

                      Comment


                      • #12
                        Another questions

                        Loop 3 parts
                        Program
                        Comment/ insert next part
                        Loop/End


                        How do i get it where it skips over the comment on the 3rd part? End/If statement?


                        Thanks

                        Comment


                        • #13
                          I'm not sure, I don't deal with loops (haven't had the need to).

                          Comment


                          • #14
                            C4 =COMMENT/YESNO,NO,HAS THE 2MM PROBE BEEN INSERTED AND CALIBRATED?

                            If I put anything in after the YESNO, _____, It just adds that to my comment when the program is executed.

                            Am I just SOL with an older version?

                            Comment


                            • #15
                              Originally posted by MFCguy View Post
                              C4 =COMMENT/YESNO,NO,HAS THE 2MM PROBE BEEN INSERTED AND CALIBRATED?

                              If I put anything in after the YESNO, _____, It just adds that to my comment when the program is executed.

                              Am I just SOL with an older version?
                              Ah, older version. I missed that. Well, I think you can turn comments off in your report. Of course, it turns off all comments so if you have some that you want to show, you may not want to do this. I'm not 100% sure this is an option on the older version.

                              Edit -> Preferences -> Edit Window Layout

                              On the "Report" tab, uncheck "Show Comments"

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X