Dof : M54

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dof : M54

    I just updated from 3.7 MR2 to 3.7 MR3 and I keep getting an error on the move point after a wrist change. The error is " DOF : M54 invalid machine not in manual mode". Just wondering if anyone else has had the same problem and if the knows a workaround.

  • #2
    Originally posted by Nevets View Post
    I just updated from 3.7 MR2 to 3.7 MR3 and I keep getting an error on the move point after a wrist change. The error is " DOF : M54 invalid machine not in manual mode". Just wondering if anyone else has had the same problem and if the knows a workaround.
    Are you using any of these options for the circle it just measured or is going to measure (Yes, I am pretty sure it is a circle!)?

    FIND HOLE
    RE-MEAASURE
    READ-POS
    ON ERROR

    If so, and IF it is going to measure a hole NEXT, just put in a dummy vector point, like right next to the hole.
    sigpic
    Originally posted by AndersI
    I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

    Comment


    • #3
      No, I am using auto-circles but I am not using any of the items you listed. It only does it when I have a move point directly after a wrist movement.

      Comment


      • #4
        Originally posted by Nevets View Post
        No, I am using auto-circles but I am not using any of the items you listed. It only does it when I have a move point directly after a wrist movement.
        Is it then going to try to measure a hole? If so, put in a simple vector point, on the surface, next to the hole, before the hole, directoy after the move and after the wrist. See if that won't get rid of the error.
        sigpic
        Originally posted by AndersI
        I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

        Comment


        • #5
          (sorry for the late reply, lunch break)

          In the case of the short program I just wrote, the feature it is going to measure after the wrist change and move point is an Auto vector point. I tried adding a false construction point before and after move point and still came up with the error.

          I have hundreds of production programs that this error will affect. I have seen it in several programs already.

          Comment


          • #6
            Originally posted by Nevets View Post
            (sorry for the late reply, lunch break)

            In the case of the short program I just wrote, the feature it is going to measure after the wrist change and move point is an Auto vector point. I tried adding a false construction point before and after move point and still came up with the error.

            I have hundreds of production programs that this error will affect. I have seen it in several programs already.
            The ONLY time I get that error is when it is going to measure a circle or slot after the tip change and inserting the vector point fixed it for me. As for the error, all it will do is STOP the program (still sucks), you can click on CONTINUE and it will keep going from there (at least it does for me).
            sigpic
            Originally posted by AndersI
            I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

            Comment


            • #7
              The error is coming up for circles and vector points for me. It never came up in 3.7 MR2.

              Yeah, I have the operators whining about having to hit enter, done button, or continue. They want to have free time while the CMM's are running. (sigh)

              Comment


              • #8
                Turns out it was a bad interfac.dll file. Got with tech support and they said it was common with the downloaded file and Sharpe 32 controller.

                Comment

                Related Topics

                Collapse

                Working...
                X