off set in alignment

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • off set in alignment

    I am trying to move my trihedron with offsets. I have the orignal alignment put in when I try to off set the circle in the x and y I can only move in the x. When I enter the value for the y the trihendron does not move.

    B&S global 3.7 mr2

    STARTUP =ALIGNMENT/START,RECALL:, LIST= YES
    ALIGNMENT/END
    MODE/MANUAL
    LOADPROBE/1BY20 MM
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
    C1 =COMMENT/YESNO,NO,Would you like to do a manual alignment?
    ,If "YES" place part on large mag block
    ,ID end flush to front of block and using the
    ,1 inch starret gage block turn 90 degrees
    ,and place against right rail and part flush
    ,against that.
    ,Take 3 hits on top of part for plane.
    ,Take 2 hits front to back right side of part.
    ,Take 4 hits in ID of part for origin.
    IF/C1.INPUT=="YES"
    PLN1 =FEAT/PLANE,RECT,TRIANGLE
    THEO/403.779,56.838,-501.399,-0.0048943,0.0016688,0.9999866
    ACTL/403.779,56.838,-501.399,-0.0048943,0.0016688,0.9999866
    MEAS/PLANE,3
    HIT/BASIC,NORMAL,401.668,40.949,-501.383,-0.0048943,0.0016688,0.9999866,401.668,40.949,-501.383,USE THEO = YES
    HIT/BASIC,NORMAL,406.063,53.988,-501.383,-0.0048943,0.0016688,0.9999866,406.063,53.988,-501.383,USE THEO = YES
    HIT/BASIC,NORMAL,403.605,75.577,-501.431,-0.0048943,0.0016688,0.9999866,403.605,75.577,-501.431,USE THEO = YES
    ENDMEAS/
    LIN1 =FEAT/LINE,RECT,UNBND
    THEO/408.964,34.777,-504.004,0.0032705,0.9999947,0
    ACTL/408.964,34.777,-504.004,0.0032705,0.9999947,0
    MEAS/LINE,2,WORKPLANE
    HIT/BASIC,NORMAL,408.964,34.777,-504.004,0.9999947,-0.0032705,0,408.964,34.777,-504.004,USE THEO = YES
    HIT/BASIC,NORMAL,409.025,53.245,-504.004,0.9999947,-0.0032705,0,409.025,53.245,-504.004,USE THEO = YES
    ENDMEAS/
    CIR1 =FEAT/CIRCLE,RECT,IN,LEAST_SQR
    THEO/399.21,29.123,-504.535,0,0,1,11.004
    ACTL/399.21,29.123,-504.535,0,0,1,11.004
    MEAS/CIRCLE,4,WORKPLANE
    HIT/BASIC,NORMAL,393.711,28.946,-504.535,0.9994803,0.0322366,0,393.711,28.946,-504.535,USE THEO = YES
    MOVE/CIRCULAR
    HIT/BASIC,NORMAL,399.054,34.623,-504.535,0.0282532,-0.9996008,0,399.054,34.623,-504.535,USE THEO = YES
    MOVE/CIRCULAR
    HIT/BASIC,NORMAL,404.691,28.654,-504.535,-0.9963559,0.0852927,0,404.691,28.654,-504.535,USE THEO = YES
    MOVE/CIRCULAR
    HIT/BASIC,NORMAL,399.469,23.628,-504.535,-0.0470571,0.9988922,0,399.469,23.628,-504.535,USE THEO = YES
    ENDMEAS/
    A0 =ALIGNMENT/START,RECALL:STARTUP, LIST= YES
    ALIGNMENT/LEVEL,ZPLUS,PLN1
    ALIGNMENT/ROTATE,YPLUS,TO,LIN1,ABOUT,ZPLUS
    ALIGNMENT/TRANS,XAXIS,CIR1
    ALIGNMENT/TRANS,YAXIS,CIR1
    ALIGNMENT/TRANS,ZAXIS,CIR1
    ALIGNMENT/END
    END_IF/
    C2 =COMMENT/YESNO,NO,Would you like to do a auto alignment?
    ,If "YES" the CMM will move DCC.
    ,The auto alignment will use the same
    ,features as the manual.
    IF/C2.INPUT=="YES"
    PLN2 =FEAT/PLANE,RECT,TRIANGLE
    THEO/4.697,23.997,3.157,0.003073,-0.0006057,0.9999951
    ACTL/4.697,23.997,3.157,0.003073,-0.0006057,0.9999951
    MEAS/PLANE,4
    HIT/BASIC,NORMAL,0.918,11.04,3.16,0.003073,-0.0006057,0.9999951,0.918,11.04,3.16,USE THEO = YES
    HIT/BASIC,NORMAL,7.7,11.065,3.141,0.003073,-0.0006057,0.9999951,7.7,11.065,3.141,USE THEO = YES
    HIT/BASIC,NORMAL,7.615,36.951,3.154,0.003073,-0.0006057,0.9999951,7.615,36.951,3.154,USE THEO = YES
    HIT/BASIC,NORMAL,2.556,36.932,3.173,0.003073,-0.0006057,0.9999951,2.556,36.932,3.173,USE THEO = YES
    ENDMEAS/
    LIN2 =FEAT/LINE,RECT,UNBND
    THEO/9.736,5.527,0.149,-0.0000336,1,0
    ACTL/9.736,5.527,0.149,-0.0000336,1,0
    MEAS/LINE,3,WORKPLANE
    HIT/BASIC,NORMAL,9.736,5.527,0.149,1,0.0000336,0,9.736 ,5.527,0.149,USE THEO = YES
    HIT/BASIC,NORMAL,9.734,13.2,0.162,1,0.0000336,0,9.734, 13.2,0.162,USE THEO = YES
    HIT/BASIC,NORMAL,9.735,25.34,0.182,1,0.0000336,0,9.735 ,25.34,0.182,USE THEO = YES
    ENDMEAS/
    CIR2 =FEAT/CIRCLE,RECT,IN,LEAST_SQR
    THEO/-0.004,0.001,-0.515,0,0,1,11.004
    ACTL/-0.004,0.001,-0.515,0,0,1,11.004
    MEAS/CIRCLE,6,WORKPLANE
    HIT/BASIC,NORMAL,-5.497,-0.322,-0.493,0.9982677,0.0588361,0,-5.497,-0.322,-0.493,USE THEO = YES
    MOVE/CIRCULAR
    HIT/BASIC,NORMAL,-3.817,3.967,-0.494,0.6930492,-0.7208903,0,-3.817,3.967,-0.494,USE THEO = YES
    MOVE/CIRCULAR
    HIT/BASIC,NORMAL,1.78,5.206,-0.517,-0.3242304,-0.9459781,0,1.78,5.206,-0.517,USE THEO = YES
    MOVE/CIRCULAR
    HIT/BASIC,NORMAL,5.448,0.75,-0.54,-0.9907007,-0.1360593,0,5.448,0.75,-0.54,USE THEO = YES
    MOVE/CIRCULAR
    HIT/BASIC,NORMAL,1.896,-5.161,-0.533,-0.3453107,0.9384884,0,1.896,-5.161,-0.533,USE THEO = YES
    MOVE/CIRCULAR
    HIT/BASIC,NORMAL,-2.43,-4.937,-0.514,0.4409024,0.897555,0,-2.43,-4.937,-0.514,USE THEO = YES
    ENDMEAS/
    A1 =ALIGNMENT/START,RECALL:A0, LIST= YES
    ALIGNMENT/LEVEL,ZPLUS,PLN2
    ALIGNMENT/ROTATE,YPLUS,TO,LIN2,ABOUT,ZPLUS
    ALIGNMENT/TRANS,XAXIS,CIR2
    ALIGNMENT/TRANS,YAXIS,CIR2
    ALIGNMENT/END
    END_IF/
    COMMENT/OPER,NO,When you hit "ok" CMM will measure
    A2 =ALIGNMENT/START,RECALL:A1, LIST= YES
    ALIGNMENT/TRANS,XAXIS,CIR2
    ALIGNMENT/TRANS_OFFSET,XAXIS,-44
    ALIGNMENT/TRANS,YAXIS,CIR2
    ALIGNMENT/TRANS_OFFSET,YAXIS,36.5
    ALIGNMENT/END
    Since I gave up hope I feel much better !!!

  • #2
    Not sure if it is related to your issue but this happens once in a while. Try zooming to extents or refreshing the graphic screen. Also, if you 'run' that section of code all should be well.
    Bill
    Bill Jarrells
    A lie can travel half way around the world while the truth is putting on its shoes. - Mark Twain

    Comment


    • #3
      Originally posted by Ken379128 View Post
      Code:
      STARTUP    =ALIGNMENT/START,RECALL:, LIST= YES
                  ALIGNMENT/END
                  MODE/MANUAL
                  LOADPROBE/1BY20 MM
                  TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
      C1         =COMMENT/YESNO,NO,Would you like to do a manual alignment?
                                  ,If "YES" place part on [COLOR="Red"][SIZE="4"]large mag block[/SIZE][/COLOR]
                                  ,ID end flush to front of block and using the
                                  ,1 inch starret gage block turn 90 degrees
                                  ,and place against right rail and part flush 
                                  ,against that.
                                  ,
      Not related to your problem, but be carefull when using magnetic blocks if you have the garden variety TP20. Get too close to the magnet and it won't register hits. I've actually had results get a little wonky when I was measuring a bore inside a magnetic part. It took the hits fine but they were not 'good' hits.

      Comment


      • #4
        I will try that wingman
        I mentioned the large mag block before :-) but I have a TP200
        Since I gave up hope I feel much better !!!

        Comment


        • #5
          Hello,
          In alignments I have used many different methods of moving or skewing my final alignment in an effort to tighten my datums up, if the tooling spheres or the fixture base is not good enough. You can create an offset point from the circle in the x,y,z amounts and make that your new origin. You can also create offset points from the spheres or points to skew the alignment a little (by using the offset points in the rotation).

          A.Gore
          sigpicA.Gore

          Comment


          • #6
            hahaha I love PC DMIS I just went in to try it again and it worked fine even though I did nothing different. I think it must have been just the graphics window not showing it working. Oh well all is good now, well it was before and it is 40 mintue till quittin time:-D
            Since I gave up hope I feel much better !!!

            Comment


            • #7
              Originally posted by Ken379128 View Post
              hahaha I love PC DMIS I just went in to try it again and it worked fine even though I did nothing different. I think it must have been just the graphics window not showing it working. Oh well all is good now, well it was before and it is 40 mintue till quittin time:-D
              That's what I was trying to explain. Sometimes it just 'happens' and it looks weird but it still works when run etc. Strange thing the Demon - LOL
              Bill Jarrells
              A lie can travel half way around the world while the truth is putting on its shoes. - Mark Twain

              Comment


              • #8
                Don't use Mag Blocks. They are a no..no. At least for me they were. Like posted before, the machine will not register sometimes. Maybe if your utilizing a carbon fiber long shank tip, you can get by with it. I just have learned already to stay away from the mags. Just use conventional fixturing if possible.
                I don't feel tardy!sigpic
                B&S "One" V4.2
                Discovery D-12 V4.2

                Comment

                Related Topics

                Collapse

                • KENNETH BAKER
                  help
                  by KENNETH BAKER
                  I,m trying to write my first program, and not having a easy time of it. I was in Chicago last week for a PC-DMIS cad course. I thought I had a grasp of...
                  09-19-2007, 03:32 PM
                • Ken379128
                  Cad=part
                  by Ken379128
                  Hello all while writing a program with a model I did my manual alignment but the CAD=PART button did not come up. Any one else run into this or could...
                  05-11-2007, 12:11 PM
                • gseith
                  Yes No Comment Problem
                  by gseith
                  I am having a problem when entering a yes/no comment input step into my program.
                  The program runs all the through with no problems when I click...
                  12-28-2010, 12:17 PM
                • mr500
                  Tell me why!
                  by mr500
                  When I execute my program, it always asks me to hit points on the first plane. Even when I DO NOT mark the man align it still asks. AND when I do hit...
                  08-05-2008, 07:58 AM
                • Ken379128
                  Nominals changing
                  by Ken379128
                  Why when I run thru a program do my nominals keep changing. I go in put them to what I want and when it runs it changes it right back????...
                  02-03-2007, 10:29 AM
                Working...
                X