Operator mode shuts computer down..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Operator mode shuts computer down..

    Programmers,

    Due to some accidental additions to and/or deleted features from my programs we have been forced to use the "operator mode" on one of our cmm's.
    Problem is if someone oops and exits or 'x's out the computer shuts down.
    Also, occasionally one would like to look at the edit window, or tweak something and this too requires a shut down and re-log in.

    Currently using 4.2. I have the operator mode on the desk top and the edit mode in an administrators folder.


    Any ideas how to "easily" toggle from edit mode to operator mode?

  • #2
    That's the way it is. I don't think there are any workarounds if you want to use operator mode.

    Comment


    • #3
      It was designed that way so that you could create Icons on the desktop.
      Doesn't make sense to me and I don't use it!
      When in doubt, post code. A second set of eyes might see something you missed.
      sigpic

      Comment


      • #4
        I use it and no, there are no workarounds to my knowledge. In my case though it logs the user out. Or deports him rather.
        <internet bumper sticker goes here>

        Comment


        • #5
          A way around it is to run an SPC software minimized or in the background. This will not shutdown the computer.
          I used to be high on life but I built up a tolerance.

          Brown & Sharpe Global Advantage
          PCDMIS CAD++ v2011mr2
          PH10MQ/SP600M


          sigpic

          Comment


          • #6
            I can see logging off, but why is it shutting down the computer?
            Links to my utilities for PCDMIS

            Comment


            • #7
              Sorry, poor terminology. The computer does not shut off, however everything running closes and a re-log in becomes necessary.

              We do have SPC "infinity" open and when pcdmis is exited this too closes and a re-log in is necessary...??????

              Comment


              • #8
                Strange, I've never seen PCDMIS log off with SPC running in the background.
                I used to be high on life but I built up a tolerance.

                Brown & Sharpe Global Advantage
                PCDMIS CAD++ v2011mr2
                PH10MQ/SP600M


                sigpic

                Comment


                • #9
                  Originally posted by T.Elder View Post
                  Sorry, poor terminology. The computer does not shut off, however everything running closes and a re-log in becomes necessary.

                  We do have SPC "infinity" open and when pcdmis is exited this too closes and a re-log in is necessary...??????
                  can you set the SPC software to prevent the closing of it? Some SPC programs allow that to be set to prevent it from being closed by operators. This would or should block the auto-logoff to continue.
                  Links to my utilities for PCDMIS

                  Comment


                  • #10
                    Well, there's one thing you can do (something I've done in the past when I didn't want to get logged off / restarted completely when testing Operator mode). Keep an open modified yet unsaved text file (or other program file) open. As long as it's unsaved, Windows will ask if you want to save the file during the logoff process. Instead, just click Cancel to shutdown the logoff process.

                    Of course it may close down other items before it gets to the text file... so, it's not a perfect solution.

                    Or better yet, simply close the PC-DMIS process using Task Manager instead of exiting using exiting using PC-DMIS... just some thoughts.
                    Jared Hess - Techwriter @ WAI
                    [View 2008 Reporting Tutorials Here]

                    Comment


                    • #11
                      Originally posted by JaredHess View Post
                      Well, there's one thing you can do (something I've done in the past when I didn't want to get logged off / restarted completely when testing Operator mode). Keep an open modified yet unsaved text file (or other program file) open. As long as it's unsaved, Windows will ask if you want to save the file during the logoff process. Instead, just click Cancel to shutdown the logoff process.

                      Of course it may close down other items before it gets to the text file... so, it's not a perfect solution.

                      Or better yet, simply close the PC-DMIS process using Task Manager instead of exiting using PC-DMIS... just some thoughts.
                      Good ideas but to work they would depend on the operator doing something other than starting pc-dmis.

                      Comment


                      • #12
                        Speaking of operator mode...

                        Have they fixed the calibrate tips option in operator mode yet? Specifically, if you open a program in operator mode in 3.7mr3 and click calibrate tips, it doesn't prompt you to install any tip in particular. The probe toolbox window comes up and displays which tip you should use so you can figure it out. No big deal right? Now, if the program happens to use two different tips it will run through the cal. of the first one and then progress to the second one without prompting the user to change the tip. That is a big problem and the main reason operator mode wasn't/isn't used here.

                        Comment


                        • #13
                          Originally posted by cmmguy View Post
                          can you set the SPC software to prevent the closing of it? Some SPC programs allow that to be set to prevent it from being closed by operators. This would or should block the auto-logoff to continue.
                          My SPC infinity person is looking into this setting for me, thanks for the tip.

                          Comment


                          • #14
                            Originally posted by JaredHess View Post
                            Well, there's one thing you can do (something I've done in the past when I didn't want to get logged off / restarted completely when testing Operator mode). Keep an open modified yet unsaved text file (or other program file) open. As long as it's unsaved, Windows will ask if you want to save the file during the logoff process. Instead, just click Cancel to shutdown the logoff process.

                            Of course it may close down other items before it gets to the text file... so, it's not a perfect solution.

                            Or better yet, simply close the PC-DMIS process using Task Manager instead of exiting using exiting using PC-DMIS... just some thoughts.

                            Using Task Manager to close PC-DMIS produced the same affect. Everything closed, a re-log-in was necessary.

                            Comment


                            • #15
                              I did try Jared's suggestion of leaving an unsaved text file open and in that case, operator mode shut down but I was able to prevent the computer from logging off. I just opened up wordpad and typed some gibberish and didn't save it. Then, when I closed operator mode, a window popped up asking if I wanted to save the text file. It gave me 3 options 'yes', 'no' and 'cancel'. I clicked on cancel and the computer did not log off.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X