Operator Mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Operator Mode

    Here is questions for all you guys,
    I have PC-DMIS 3.5MR2 and 3.7MR3 loaded on my machine. I want to try to run the Operator Mode for 3.5MR2 since most all my program are in this version.
    When I go to Start>PC-DMIS>Operator Mode it pulls up version 3.7MR3. Is there a way to pull up 3.5?
    I am having trouble with my 2nd and 3rd shift people. I want to lock out all the stuff they can do as far as messing with the program. I want them to just open the program and hit Exacute and then have it print out, save to Data Page then they could close that program, open the next program and continue.
    Any help would be great.
    Thanks
    B. Jacobs
    B&S Global 12.15.10
    2014.1

  • #2
    Check the task manager

    You would see this behavior if the PCDLRN.EXE from v3.7 never actually died. In other words, you closed it, but it kept running in the background. Start the task manager and look for PCDLRN.EXE, and if you see it, kill it. Then try Operator mode again for v3.5

    Also, right click on the Operator mode icon for v3.5 and check its properties. Make sure it is pointing to the correct location for the executable.

    Comment


    • #3
      Originally posted by Don Ruggieri View Post
      You would see this behavior if the PCDLRN.EXE from v3.7 never actually died. In other words, you closed it, but it kept running in the background. Start the task manager and look for PCDLRN.EXE, and if you see it, kill it. Then try Operator mode again for v3.5

      Also, right click on the Operator mode icon for v3.5 and check its properties. Make sure it is pointing to the correct location for the executable.
      Do you have seperate 'PC-DMIS' fileders in the start menu? One for each, MR2 and MR3? If not, then those in the start menu will be for the most recent install, in this case, MR3.

      Open the folder where MR2 resides and find the PCDLRN.EXE file, drag a short-cut to the desktop. Then, open it's properties and change the command line. I think you need to add an /o to it for it to operate in OPERATOR mode.
      sigpic
      Originally posted by AndersI
      I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

      Comment


      • #4
        remove everything from your start menu. Go into your pcdmis folder on C:\ and create a shortcut from your v3.5 folder. use "PCDLRN.EXE /O" as the command line to load operator mode.
        I used to be high on life but I built up a tolerance.

        Brown & Sharpe Global Advantage
        PCDMIS CAD++ v2011mr2
        PH10MQ/SP600M


        sigpic

        Comment


        • #5
          OK i got it to work. I created a shortcut on the desktop and went to properties then changed the path . I then opened operator mode and found that program and hit execute. It took off and started running. The only problem is it didn't ask my to save to stats. I have it saving stats to datapage and everytime it has asked me for the number. This time it just started running?
          B. Jacobs
          B&S Global 12.15.10
          2014.1

          Comment


          • #6
            Originally posted by B. Jacobs View Post
            OK i got it to work. I created a shortcut on the desktop and went to properties then changed the path . I then opened operator mode and found that program and hit execute. It took off and started running. The only problem is it didn't ask my to save to stats. I have it saving stats to datapage and everytime it has asked me for the number. This time it just started running?
            I think (I am NOT sure) that you must 'automate' the stats when using command mode.
            sigpic
            Originally posted by AndersI
            I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

            Comment


            • #7
              Originally posted by Matthew D. Hoedeman View Post
              I think (I am NOT sure) that you must 'automate' the stats when using command mode.
              Not sure what you mean by this. I am looking into this to try to figure it out. Any help would be great.
              B. Jacobs
              B&S Global 12.15.10
              2014.1

              Comment


              • #8
                Well, I think all it takes is a STATS UPDATE command at the end of the program. As for the initial count, I think it will always default to what it was when it was last saved in REGULAR mode.

                STATS/ON before the first dimension
                STATS/UPDATE after the last dimension
                sigpic
                Originally posted by AndersI
                I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

                Comment


                • #9
                  I have found something else that isn't working or I am just not doing something right.

                  I have created a marked set for the program so it will load in Operator Mode. I then open operator mode an see the Icon for the marked set along with Calibrate probe, print full report and exit.

                  One question is this, Can I delete the Calibrate Probe icon? I don't need to give them that option because they will for sure try it and screw something up.
                  When I hit the Marked set to execute, It doesn't ask me for the currently loaded probe. I have a tool changer and I need it to ask me so the operator knows what probe is in the head when the program starts.
                  I know when I am in the regular mode(Edit) and open a new program, it asks me what probe is loaded. I have different probes for different programs.

                  I am trying to make this as simple as I can for the operators.
                  Last edited by B. Jacobs; 06-08-2007, 01:47 PM.
                  B. Jacobs
                  B&S Global 12.15.10
                  2014.1

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X