Losing Alignment on Angle Change?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Losing Alignment on Angle Change?

    Alright, here is my code. The first bit here is with A0B0. Just before the last move point it changes to A90B180.

    Code:
     DATUM_B    =AUTO/CYLINDER,SHOWALLPARAMS = NO,SHOWHITS = YES
                THEO/0,0,-0.58,0,0,-1,1.373
                ACTL/0,-0.0002,-0.58,0.0002972,-0.0014226,-0.9999989,1.3732
                TARG/0,0,-0.58,0,0,-1
                MEAS/CYLINDER
                HIT/BASIC,0,0.6865,-0.18,0,-1,0,-0.0001,0.6869,-0.1798
                HIT/BASIC,0.3719,0.577,-0.18,-0.5417,-0.8406,0,0.372,0.5772,-0.1797
                HIT/BASIC,0.6252,0.2836,-0.18,-0.9107,-0.4131,0,0.6253,0.2832,-0.1798
                HIT/BASIC,0.6791,-0.1003,-0.18,-0.9893,0.1461,0,0.6791,-0.0999,-0.1801
                HIT/BASIC,0.5165,-0.4522,-0.18,-0.7524,0.6587,0,0.5165,-0.4519,-0.1801
                HIT/BASIC,0.1892,-0.6599,-0.18,-0.2756,0.9613,0,0.1889,-0.6597,-0.1801
                HIT/BASIC,-0.1984,-0.6572,-0.18,0.289,0.9573,0,-0.1986,-0.657,-0.1803
                HIT/BASIC,-0.5228,-0.4449,-0.18,0.7615,0.6481,0,-0.5231,-0.4444,-0.1802
                HIT/BASIC,-0.6805,-0.0908,-0.18,0.9912,0.1323,0,-0.6806,-0.0904,-0.1799
                HIT/BASIC,-0.6212,0.2923,-0.18,0.9048,-0.4258,0,-0.6217,0.2918,-0.1797
                HIT/BASIC,-0.3638,0.5822,-0.18,0.5299,-0.848,0,-0.3645,0.5824,-0.1797
                HIT/BASIC,-0.3638,0.5822,-0.33,0.5299,-0.848,0,-0.3644,0.5822,-0.3297
                HIT/BASIC,-0.6212,0.2923,-0.33,0.9048,-0.4258,0,-0.6216,0.2917,-0.3297
                HIT/BASIC,-0.6805,-0.0908,-0.33,0.9912,0.1323,0,-0.6806,-0.0905,-0.3301
                HIT/BASIC,-0.5228,-0.4449,-0.33,0.7615,0.6481,0,-0.5231,-0.4447,-0.3301
                HIT/BASIC,-0.1984,-0.6572,-0.33,0.289,0.9573,0,-0.1985,-0.6572,-0.3301
                HIT/BASIC,0.1892,-0.6599,-0.33,-0.2756,0.9613,0,0.1891,-0.6599,-0.3303
                HIT/BASIC,0.5165,-0.4522,-0.33,-0.7524,0.6587,0,0.5167,-0.4519,-0.3302
                HIT/BASIC,0.6791,-0.1003,-0.33,-0.9893,0.1461,0,0.6792,-0.0998,-0.3298
                HIT/BASIC,0.6252,0.2836,-0.33,-0.9107,-0.4131,0,0.6252,0.2834,-0.3297
                HIT/BASIC,0.3719,0.577,-0.33,-0.5417,-0.8406,0,0.3719,0.5771,-0.3297
                HIT/BASIC,0,0.6865,-0.33,0,-1,0,-0.0001,0.6868,-0.3297
                HIT/BASIC,0,0.6865,-0.48,0,-1,0,-0.0001,0.6865,-0.4797
                HIT/BASIC,0.3719,0.577,-0.48,-0.5417,-0.8406,0,0.372,0.577,-0.4795
                HIT/BASIC,0.6252,0.2836,-0.48,-0.9107,-0.4131,0,0.6253,0.2832,-0.4796
                HIT/BASIC,0.6791,-0.1003,-0.48,-0.9893,0.1461,0,0.6793,-0.0999,-0.48
                HIT/BASIC,0.5165,-0.4522,-0.48,-0.7524,0.6587,0,0.5168,-0.452,-0.4801
                HIT/BASIC,0.1892,-0.6599,-0.48,-0.2756,0.9613,0,0.189,-0.6602,-0.4801
                HIT/BASIC,-0.1984,-0.6572,-0.48,0.289,0.9573,0,-0.1987,-0.6574,-0.4804
                HIT/BASIC,-0.5228,-0.4449,-0.48,0.7615,0.6481,0,-0.5233,-0.4446,-0.4803
                HIT/BASIC,-0.6805,-0.0908,-0.48,0.9912,0.1323,0,-0.6807,-0.0904,-0.4798
                HIT/BASIC,-0.6212,0.2923,-0.48,0.9048,-0.4258,0,-0.6215,0.2919,-0.4797
                HIT/BASIC,-0.3638,0.5822,-0.48,0.5299,-0.848,0,-0.3642,0.5821,-0.4796
                ENDMEAS/
    A4         =ALIGNMENT/START,RECALL:A3, LIST= YES
                ALIGNMENT/LEVEL,ZPLUS,PLN2
                ALIGNMENT/ROTATE_CIRCLE,XPLUS,TO,PNT3,AND,PNT4,ABOUT,ZPLUS
                ALIGNMENT/TRANS,XAXIS,DATUM_B
                ALIGNMENT/TRANS,YAXIS,DATUM_B
                ALIGNMENT/TRANS,ZAXIS,PLN2
                ALIGNMENT/END
    CIR5       =AUTO/CIRCLE,SHOWALLPARAMS = NO,SHOWHITS = YES
                THEO/1.6,-1.66,0,0,0,1,0.2
                ACTL/1.6,-1.66,0,0,0,1,0.2
                TARG/1.6,-1.66,0,0,0,1
                MEAS/CIRCLE
                HIT/BASIC,1.6,-1.56,-0.2,0,-1,0,1.6,-1.56,-0.2
                HIT/BASIC,1.5459,-1.5759,-0.1955,0.5406,-0.8413,0,1.5459,-1.5759,-0.1955
                HIT/BASIC,1.509,-1.6185,-0.1909,0.9096,-0.4154,0,1.509,-1.6185,-0.1909
                HIT/BASIC,1.501,-1.6742,-0.1864,0.9898,0.1423,0,1.501,-1.6742,-0.1864
                HIT/BASIC,1.5244,-1.7255,-0.1818,0.7557,0.6549,0,1.5244,-1.7255,-0.1818
                HIT/BASIC,1.5718,-1.7559,-0.1773,0.2817,0.9595,0,1.5718,-1.7559,-0.1773
                HIT/BASIC,1.6282,-1.7559,-0.1727,-0.2817,0.9595,0,1.6282,-1.7559,-0.1727
                HIT/BASIC,1.6756,-1.7255,-0.1682,-0.7557,0.6549,0,1.6756,-1.7255,-0.1682
                HIT/BASIC,1.699,-1.6742,-0.1636,-0.9898,0.1423,0,1.699,-1.6742,-0.1636
                HIT/BASIC,1.691,-1.6185,-0.1591,-0.9096,-0.4154,0,1.691,-1.6185,-0.1591
                HIT/BASIC,1.6541,-1.5759,-0.1545,-0.5406,-0.8413,0,1.6541,-1.5759,-0.1545
                ENDMEAS/
                MOVE/POINT,NORMAL,CIR5.X,CIR5.Y,1
                TIP/T1A90B180, SHANKIJK=0.0025, -0.9998, -0.0177, ANGLE=-179.9726
                MOVE/POINT,NORMAL,1,-2.5,1
    Everything is fine and dandy until that last move point. Instead of moving to 1,-2.5,1 it is moving to something more like 1,-3.5,-.2!

    I recalibrated my tips (std dev of .0001 and .0000), I re-ran the entire program with no change. I am going to try a shutdown/re-boot. Anyone got any ideas?

  • #2
    Did you perhaps put in the movepoint before the tip change and then go back and put the tip change in? Have you tried deleting tip change and movepoint and then recreating them? Just a couple things to try.
    sigpic"Hated by Many, Loved by Few" _ A.B. - Stone brewery

    Comment


    • #3
      Originally posted by Wes Cisco View Post
      Did you perhaps put in the movepoint before the tip change and then go back and put the tip change in? Have you tried deleting tip change and movepoint and then recreating them? Just a couple things to try.
      Yep, I tried deleting both the angle change and the move point following it.

      Comment


      • #4
        Well, shutdown/re-start didn't help either.

        Comment


        • #5
          Well, going back through the program line for line I found the problem. My probe is a 4X20mm. It is supposed to be a 4X20 with a 30mm extension! Problems don't show up until I rotated away from A0B0.

          Boy have I got egg on my face now. I even tried the scroll lock to see if that would fix the problem. TGIT!

          Comment


          • #6
            Originally posted by Goodluck View Post
            Well, going back through the program line for line I found the problem. My probe is a 4X20mm. It is supposed to be a 4X20 with a 30mm extension! Problems don't show up until I rotated away from A0B0.

            Boy have I got egg on my face now. I even tried the scroll lock to see if that would fix the problem. TGIT!
            So this is RESOLVED and I can recommend a nice stiff Friday eve snort of Whiskey!!!
            sigpic"Hated by Many, Loved by Few" _ A.B. - Stone brewery

            Comment


            • #7
              Originally posted by Wes Cisco View Post
              So this is RESOLVED and I can recommend a nice stiff Friday eve snort of Whiskey!!!
              Yes, please do.

              Comment

              Related Topics

              Collapse

              • Wingman
                3.73 Still not right??
                by Wingman
                A while back I posted some weird issues with 3.73. I thought I had it solved by figuring out that 3.73 doesn't really like 3.72. Now it appears the...
                07-26-2007, 09:39 AM
              • #2#
                Constructed Circle Problem
                by #2#
                Can anyone tell me why the Cir8 is way out in space?

                Code:
                CIR7       =AUTO/CIRCLE,SHOWALLPARAMS = NO,SHOWHITS = YES
                            THEO/0,0,-0.3,0,0,1,0.313,0.2
                ...
                05-30-2008, 10:43 AM
              • drako28
                High Point Extraction ?
                by drako28
                I'm trying to find the high point of this scan. I'm using 4.1. Is there something I'm missing? I am only getting the first number out of the scan....
                11-30-2006, 08:56 AM
              • mr500
                Why Is My
                by mr500
                Why is my program stopping in the middle of the run. I have marked where it is stoping in the code. UGHHHHH

                Code:
                PLN2
                ...
                08-18-2008, 02:11 PM
              • Underspec
                Printing Variables!
                by Underspec
                I need to do some calculations and print them out from variables as dimensions or to the report. Never really messed with variables so any help will be...
                08-09-2006, 12:51 PM
              Working...
              X