PC-DMIS Memory Leak?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PC-DMIS Memory Leak?

    Hi Everyone,

    A week or two ago, I got the following error on our Global S Blue running PC-DMIS 2019 R1 CAD++:

    WarningBox.PNG

    I checked Task Manager, and while system resources overall were fine, PC-DMIS was not:

    TaskManager.PNG

    This computer just runs the CMM - I very rarely write programs on it and only every once and a while have more than one open at once. The guys open a program, run it, then close it. Our programs aren't tiny, but most of them aren't ridiculous either - there's no reason for PC-DMIS to be taking 4 gigabytes of RAM.

    But, PC-DMIS locked up and wouldn't do anything until I restarted it. This error has come up 3-4 more times since then, and each time PC-DMIS has needed to be restarted. A couple of times it's happened in the middle of running a routine that then needed to be started from the beginning, which is annoying.

    It seems that PC-DMIS is gradually consuming more and more memory if not restarted every day or two. We could manually do that, but it would be a pain. It's odd to me that this started all of a sudden - I don't think I changed anything with PC-DMIS. There's a chance Windows might have updated itself.

    Have any of you seen anything like this before? What did you need to do to fix it? I'll be starting a support thing about this as well, but you guys usually have a much better response time.

    Thank you,
    Matthew

  • #2
    Sounds like it could be the same as this problem : https://www.pcdmisforum.com/forum/pc...ing#post481848

    There are several recommendations in that post that you could try whilst we continue to try to find the route cause and provide a fix.
    Neil Challinor
    PC-DMIS Product Owner

    T: +44 870 446 2667 (Hexagon UK office)
    E: [email protected]

    Comment


    • #3
      Hi Neil,

      I did see that thread, but what I'm having is not a hard crash - when the message pops up, I can click "Ok" and it goes away, and then PC-DMIS won't let me run the program or do anything else that I've tried (since it's not my programming machine, I haven't tried much more than just running a program). But it doesn't crash, and it does let me close it.

      I'll try to verify this next time it happens, but I haven't seen any evidence that Windows Explorer is affected. Also, 2019 doesn't have the homepage; if it's a related issue, it's manifesting itself in very different ways.

      Tech support case: <https://support.hexagonmi.com/s/detail/5003z00002KUiyXAAT>

      Matthew

      Comment


      • #4
        How frequently do you reboot? How long was the system running since the last reboot? Just sayin . . .

        Comment


        • #5
          I typically have to restart everyday to release the memory.

          Comment


          • #6
            There was a memory leak in one of those versions. I had that issue, I posted in the tech preview forum. search there. It was posted as a bug.
            sigpicTAU ALPHA PI INDIANA DELTA CHAPTER
            "Due to the highly confidential nature of my job, I am not allowed to know what I am doing" - author unknown

            Comment


            • #7
              We don't reboot the PC regularly, which we've gotten away with so far but probably isn't ideal.

              It's weird to me that it seems to have suddenly started leaking memory...

              Comment


              • #8
                Is this computer running 24/7 or is it sporadic measurements?
                PC-DMIS CAD++ 2o19 R1 SP11

                Comment


                • #9
                  I have the same error when the program gets to the print command, for now I told the operators to restart the computer after every long run.
                  strange that this just started happening when it has been running fine for years, I put a ticket in waiting for a reply.

                  Comment


                  • #10
                    sounds like yer 'puters got the 'vid. better take 'em in and get the shot.
                    sigpic
                    Originally posted by AndersI
                    I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

                    Comment


                    • #11
                      Thanks for the responses everyone! Sorry for not replying sooner.

                      vpt.se , the computer is always on but I would say it's running a measurement routine only 30% of the time or thereabouts. The weird thing is that there's been times when we've had it closer to 70% without this issue on the same PC-DMIS install.

                      MikeF , exactly. Why now? I don't think I changed anything.

                      Matthew D. Hoedeman : But I've been staying off all the sketchy Chinese websites! The computer's also been locked all by itself (well, ok, I think the head controller's in there too) in its little cabinet for months. Don't know how that could have happened.

                      neil.challinor , it happened again today and I messed around with Windows Explorer a little, and everything seemed to be fine with it. I don't think the other issue is related.

                      For now I asked our quality guy to restart PC-DMIS when he cleans the tips in the morning. Unless this worsens to the point that it can't last 24 hours, that should be a good workaround. I'd still like to get to the bottom of the issue, though.

                      Comment


                      • #12
                        I have to restart the PC after every long running program

                        Comment


                        • Matthew D. Hoedeman
                          Matthew D. Hoedeman commented
                          Editing a comment
                          I couldn't even tell you when the last time I was that I rebooted the PC on the Global (Win7), maybe even a couple months ago. The PC on the Validator I reboot more often (WinXP) due to all the crap I do on there, between Pcdmis, Excel, Excel Chart editing, and the programmable keypad, and the use of MOUSE KEYS, I have to reboot after doing a bunch of that, and every time once done using MOUSE KEYS. If it is just running programs, it can go forever.

                        • mbatten
                          mbatten commented
                          Editing a comment
                          Exactly, Matt - that's what ours has been like until now.

                      • #13
                        So PC-DMIS gave the memory error yesterday and then again this morning, and was restarted both times. Looking at it now (17:30) it's consuming 5 gigs with nothing open. This is getting out of control - any more ideas?

                        I've still heard squat from the support people (beyond them acknowledging that we do pay them $$$$$$ for the privilege of waiting days and days for them to do anything...)

                        Comment


                        • #14
                          How much RAM is installed?
                          PC-DMIS CAD++ 2o19 R1 SP11

                          Comment


                          • mbatten
                            mbatten commented
                            Editing a comment
                            16 gigs. It's never come close to using all of it, but PC-DMIS seems to get grumpy when it's using about 4.

                        • #15
                          Tech support finally got back to me, and had me update to a newer service pack. If the problem goes away, then I guess we'll be ok...

                          Comment

                          Related Topics

                          Collapse

                          Working...
                          X