2015 CAD++ Six Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2015 CAD++ Six Issues

    I have a question for you guys I've searched around didn't really find exact answers, so my current workplace has 2015 cad++ pcdmis, I came from a workplace where I used 2018R2, then 2019R1, so it's been a struggle for me on some things, feels like a time warp, I think the previous people here had no clue what they were doing because even the probe setups/files had no master probe, and the incorrect sphere size so I have a plethora of issues I can't figure out. I'm using CAD for programming

    1) In the edit F5 window what boxes should all be checked if I'm checking sheet metal parts, obviously I have show extended sheet metal options checked, but what others generally?

    2) For some reason my nominal keeps changing and I cant figure out why, never had to mess with the cad to part function before is that it?

    3) I am Having some discrepancies in exact measure when it comes to true position or profile, or my nominal's changing in there for some reason, also for some reason it wont let me uncheck the fit to datum's, to try that, it's greyed out and not select-able.

    4) As far as planes go I'm used to using the primary datum constructed plane function for the primary datum if it's planar, but in the older version I'm stuck with till they update not sure what to go with other than least squared.

    5) I noticed I get varied results depending if I import a step or an iges weird?

    6) Some programs I sifted through I noticed they were on complicated parts using the base plate of the cmm as their leveling plane but with no cad, so I'm guessing this was done by manually probing vectors, not sure if that's common practice, I've only gone off of cad or assemblies.

    Any help would be greatly appreciated to make sure I have everything correct figured I'd ask your guy's advice I've only been in the game 3 years.

  • #2
    2) Try setting the registry flag UseTheosForCADToPartLevelAlignment in the settings editor to TRUE and restart PC-DMIS.

    3) The above registry setting *might* help with the nominals changing, other than that check that your alignments are correct. For unselecting the "fit to datums" select "custom" instead of ASME/ISO in the standard choice listbox. This should enable the checkbox for fit to datums.

    6) There really isn't an issue using the table as level, perhaps a datum surface is lying flat on (against) the table and the table is used as tangent plane?
    PC-DMIS CAD++ 2o19 R1 SP9

    Comment


    • #3
      Okay, sounds good, yes the alignment is correct, and I picked custom but for some reason it's still greyed out?

      Comment


      • vpt.se
        vpt.se commented
        Editing a comment
        That's weird. Are there MMC on the datums?

    • #4
      Originally posted by vpt.se View Post
      2) Try setting the registry flag UseTheosForCADToPartLevelAlignment in the settings editor to TRUE and restart PC-DMIS.

      3) The above registry setting *might* help with the nominals changing, other than that check that your alignments are correct. For unselecting the "fit to datums" select "custom" instead of ASME/ISO in the standard choice listbox. This should enable the checkbox for fit to datums.

      6) There really isn't an issue using the table as level, perhaps a datum surface is lying flat on (against) the table and the table is used as tangent plane?
      For the registry setting in the editor I tried searching for UseTheos as you described and can't find it in there? The only thing I could find was alignment dependencies and that's set to false?

      Comment


      • vpt.se
        vpt.se commented
        Editing a comment
        Correct, add the boolean key yourself and try again.

    Related Topics

    Collapse

    Working...
    X