2020R1 continuous increasing memory usage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2020R1 continuous increasing memory usage

    I'm having issues with using 2020R1 where if i just open PCDMIS everything is ok, But once i open any program my memory usage continues to go up until it's super laggy and will eventually start freezing. Does anyone have any suggestions on things i can look at or do?

  • #2
    PCD has been like this for me since 2019 - Reset User seems to work for a little bit in the Settings Editor. But you may lose custom toolbar settings and stuff.

    Comment


    • #3
      Try these two steps to see where it leads us -


      Disable the Preview Summary Mode, using the Settings Editor, in the Edit Window section
      Set EnableWpfSummaryView to 0

      Disable the Home Page, using the Settings Editor, in the Option section
      Set SHowHomePage to False

      Comment


      • #4
        Originally posted by Don Ruggieri View Post
        Try these two steps to see where it leads us -


        Disable the Preview Summary Mode, using the Settings Editor, in the Edit Window section
        Set EnableWpfSummaryView to 0 <---------- Changing this seemed to fix the issue

        Disable the Home Page, using the Settings Editor, in the Option section
        Set SHowHomePage to False
        Not sure what caused this, but seems to be fixed now. I have another install on a different PC with no issues with it.
        Thanks Don!

        Comment


        • Jimbaggins1972
          Jimbaggins1972 commented
          Editing a comment
          from another post

          Originally posted by Jimbaggins1972 View Post
          f5 options.png

          Another possible fix is setting PC-DMIS to not use the home screen. There is a thread (or threads) covering this issue, I don't recall the specific one but a search can find it fairly quickly. we use 2020 R2 SP10 and had issues with crashing until we stopped using the home screen.
          • Go to F5 - Setup options
          • General Tab
          • Scroll all the way to the bottom of the checkbox options list
          • Deselect "Show Home Page"

      • #5
        Don Ruggieri Turns out turning those off in settings editor did not fix the issue. After turning those off it appeared to be fixed but later in the day it went right back to hogging the memory again.

        Comment


        • #6
          OK, first, double check those same two settings to make sure they stuck. Aside from that, here are a couple more things you can try.

          Remove the EventModules folder, delete the entire folder itself. -
          C:\Program Files\Hexagon\PC-DMIS 2020 R1 64-bit\EventModules

          Purge the temp folder
          C:\Users\ < user name > \AppData\Local\Temp

          With any of these, try one at a time, in the order I've listed them. Let me know if anything works. . . .

          Comment


          • #7
            After opening the program. What else are you doing? execution, alignment etc Does this happen just sitting "idle"?

            Comment


            • #8
              Don Ruggieri I doubled checked the EnableWpfSummaryView and sure enough this was turned back on. Turning this back off the issue stops. I have 2020R1 installed on 4 different PCs all offline license. Turns out they all have the same issue turning this off fixed them all. We will have to keep on eye on them to make sure they stay off.

              rjurca Just opening a program doing nothing else "sitting Idle" the memory issue was occurring. This was happening the moment you would open any program.

              Comment


              • #9
                Does the home page really eat up that many resources? We can run a few programs and the software will cause DataPage to say there isn't enough memory, Adobe reader to crash, reporting to stop printing, program freezes. Unless there is something else that is causing the software to bug out.

                I have two different CMMs this does it on. It will start off using ~235MB then jump up to ~600MB in the task manager and that's when it freaks out. I have 16GB of ram on each computer. Not sure the reasoning.

                Any thoughts?

                Don Ruggieri
                .
                rjurca

                Comment


                • #10
                  I think the problem is that your software has saved too much-cached data. In computational data processing, a cache is a high–speed storage layer at which the required data set is usually temporary. Access to data at this level is much faster than at the main storage location. With the help of caching, it becomes possible to reuse previously obtained data efficiently. But of course, all this information takes up a large amount of your device's memory. You need to clear the cache, and if that doesn't work, I recommend contacting raid recovery since this can be quite a serious problem with the hard drive.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X