CAD Being snapped to certain spot on graphics window

  • Filter
  • Time
  • Show
Clear All
new posts

  • CAD Being snapped to certain spot on graphics window

    The CAD model is being snapped to a certain position in the graphics display window. If i try to zoom in on the screen. The CAD will run off out of view. I'm Not sure how this happened i'm using 2020R1 and this happened in the middle of writing the Program. Has anyone run into this issue?

  • #2
    Do you have any features that are a long distance from the part? What happens if you do a scale to fit?


    • #3
      If you don'tr want it to 'zoom' to fit window; go to setup options, General tab and 'un-check' Scale to Fit. then it won't keep zooming in to window.
      As rjurca said: Make sure you don't have any features off into 'space' somewhere that will cause this to happen.


      • #4
        rjurca If i scale to fit it zooms in really close to where the cad is no longer visible

        brian.freeman i have the option turned off

        If i bring up the rotate box "cntrl+R" and try to rotate around Z axis instead of rotating about the Tryhedron in the center of the part its rotating about something off in space i can't find anything lingering. Even then if something was off in space it should not cause the Cad to snap to a position if i translate it across the screen it will snap back to the other side.


        • #5
          If the cad disappears. There most likely is something way of in space. Scale to fit takes into account the entire graphics display. If you do a save as and remove all your features from the backup copy. Do the results change?


          • #6
            rjurca I saved this as copy and deleted everything all features there's only a load probe statement left & i'm still having the same issue.


            • #7
              Please contact me directly. [email protected] I would need to load your program and cad. I'm out of ideas at the moment


              • Jakep379
                Jakep379 commented
                Editing a comment
                Sent it thanks!

            • #8
              If anyone comes across this issue it is on option under "operation>Graphics display>Center Probe" this was turned on

              Thanks again rjurca for finding this.


              • brian.freeman
                brian.freeman commented
                Editing a comment
                I can see why this would be quite annoying----------Never thought about "center probe".

              • Don Ruggieri
                Don Ruggieri commented
                Editing a comment
                Great job @Jurca, and thank you Jakep379 for sharing the solution

            Related Topics