Clear plane and basic scan / cylinder issue (2019 R2 SP2)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Clear plane and basic scan / cylinder issue (2019 R2 SP2)

    Not the first time that this problem is present, the move to clear plane on basic scan cylinder goes at the right height on the cylinder axis, then goes to the first hit.
    On a outter cylinder, the crash is sure ...
    This bug appears on different versions, is fixed on some SP, and re-appears...

  • #2
    Hi JEFMAN as a quick test, can you please check that you don't accidentally have the auto move active as well as clear plane. They may be conflicting with each other and this could be the reason you see the behaviour you describe. I suspect it will probably work correctly with either of the options individually selected but would be grateful if you could confirm - I can then log it as a bug if necessary.
    Neil Challinor
    PC-DMIS Product Owner

    T: +44 870 446 2667 (Hexagon UK office)
    E: [email protected]

    Comment


    • davehocum
      davehocum commented
      Editing a comment
      Neil, knowing of the issue that if both settings being selected, then the settings should be change that only one of these settings could be selected.

    • neil.challinor
      neil.challinor commented
      Editing a comment
      I agree, but it's just a suspicion at the moment as I am not in a position to test it myself right now - just waiting for Jefman to confirm and then I can try to get it looked at.

  • #3
    Originally posted by neil.challinor View Post
    Hi JEFMAN as a quick test, can you please check that you don't accidentally have the auto move active as well as clear plane. They may be conflicting with each other and this could be the reason you see the behaviour you describe. I suspect it will probably work correctly with either of the options individually selected but would be grateful if you could confirm - I can then log it as a bug if necessary.
    Hi Neil,
    I'm not sure to find where "automove" is...
    In Operation/graphic display/ there's no active auto move.

    If I select "show path", it seems correct, but the cmm doesn't follow the path !!!!!
    For a basic scan / circle, it works well, so I believe it's a bug, but I'm not sure of this.

    Sorry for the translation of functions, I'm not at the cmm.

    Comment


    • #4
      The automove is a tick box on the the general tab of the basic cylinder scan dialogue. It's just below the clearplane tick box - see image below
      basic scan.JPG
      Neil Challinor
      PC-DMIS Product Owner

      T: +44 870 446 2667 (Hexagon UK office)
      E: [email protected]

      Comment


      • #5
        Ok !
        You know, I only use PC-DMIS since 2001, I don't know enough !
        No, it's not selected, and it's not "auto move" in french !!!!! (D├ępl auto in french, I'd never used it !)
        Clearance plane is selected.

        While we are on your screen shot, do you know how unselect "by default" "measure" and show hits" ?
        I always begin by unselect them, to avoid the cmm to start when I click on "create"...
        Last edited by JEFMAN; 01-02-2020, 09:24 AM.

        Comment


        • neil.challinor
          neil.challinor commented
          Editing a comment
          They are probably registry settings but I'm not sure if you will be able to make them default - they may automatically reset when you restart PC-Dmis. I'll try to do some tests and post my findings.

        • neil.challinor
          neil.challinor commented
          Editing a comment
          I found ScanDialogShowHits, ScanDialogShowAll & ScanMeasure (all under the SCAN section in settings editor) but these only appear to work for the advanced scans (linear open, liner closed etc). It also looks like they re-set when you re-start PC-Dmis.

        • JEFMAN
          JEFMAN commented
          Editing a comment
          neil.challinor : I saw them some years ago, but, you're right, they don't work on basic scans !
          Thanks for searching !
          Jef

      • #6
        Hi JEFMAN I've just logged the basic cylinder scan bug - PCD-183867 for future reference.
        Neil Challinor
        PC-DMIS Product Owner

        T: +44 870 446 2667 (Hexagon UK office)
        E: [email protected]

        Comment


        • JEFMAN
          JEFMAN commented
          Editing a comment
          Thanks Neil !

      • #7
        I tested the difference between basic scan circle (scn1) and basic scan cylinder (scn2)
        If you assign V1=SCN1.TSXYZ, you obtain the coordinates of first hit coordinates + ball radius + prehit distance.
        SCN1.HIT[1].TXYZ +(PROBEDATA("diam")/2)*SCN1.HIT[1].TIJK + GETSETTING("prehit")*SCN1.HIT[1].TIJK.
        In the tested case, it gives<29,0,10> for a theo circle at <0,0,10>, diameter 47, prehit 3 and ball 5.
        For the cylinder, it gives <0,0,9.5> for a scan which should start at the same point than the circle above. (why 9.5 ???????? it's the same on 2014...)
        Maybe the problem stays here ?

        neil.challinor
        Last edited by JEFMAN; 01-03-2020, 06:16 AM.

        Comment

        Related Topics

        Collapse

        Working...
        X