Enabling Clearance Cube Causes Limit Error With Probe Rack Stylus Change

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Enabling Clearance Cube Causes Limit Error With Probe Rack Stylus Change

    Hello All,

    After a day and a half, I've finally been able to pinpoint the cause of my problem, now the question is why there's a problem. I created an inspection program yesterday which includes two stylus changes on a probe rack. After I completed the program I ran it through one time without any issues. I then made some refinements to the program and then ran it a second time. The second time I ran the program, I encountered a limit error (On the Z-axis) when it came time to perform the stylus change on the probe rack. I turned on the path lines and could see that the program was calling for the probe to drop through the granite for the stylus change at the probe rack. After a lot of head scratching, and unsuccessfully searching on this forum for a similar issue, I decided to start over and create a new program. I should mention though that one thing I did find on the forum was several mentions of properly relating various probes back to the master probe, so I re-calibrated all of my probe angles and styli, ensuring they were all related back to the master probe which did not help. After re-creating the program, it once again ran without issues the second time. Again, I made some refinements but this time I was watching the path lines more closely as I made refinements. All of a sudden I could see the path lines going down through the granite for the stylus change at the probe rack. I thought it was when I enabled the clearance cube so I disabled it but the path line for the stylus change step did not revert back. I then created the program a 3rd time, this time I saved the file after I programmed all of the moves and then re-saved the file with a different name. It ran without issues the first time and then I was able to definitely determine that enabling the clearance cube was the cause of the issue. I went back to previously saved 3rd program (Before I enabled the clearance cube) and made all of my refinements without enabling the clearance cube. I was able to run the program 3 times successfully. I used clearance moves before and after each feature along with move points to accomplish the same as what the clearance cube would give. So a day and a half later, I have my program created which should have been completed in 90 minutes.Talk about frustrating!!

    Why would the clearance cube cause this issue? I've used the clearance cube in previous programs without an issue. The CAD file is an .stp which I've used previously as well without issues.

  • #2
    When you have clearance cube turned on, did you look to see whether or not you’re using Tip Vectors? Go to the Clearance Cube advance Settings and you can change the direction the probe is going. Sounds like the the probe is moving in Z- in the feature before the probe change and after the change. I would set it to Use Tip Vectors or simply add a move point.
    Darroll
    2018R2

    Comment

    Related Topics

    Collapse

    Working...
    X