Autocalibration is crashing probe into sphere

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Autocalibration is crashing probe into sphere

    Good afternoon, all;
    Question about the Calibrate function and Auto-Calibrate function. There are two issues here, but are related.

    tl;dr: the head changes angles while very low, and almost hits the qual. sphere during calibration. During Autocalibration, the head will index into the qual. sphere at the end.



    Long version with explanation:

    When qualifying a probe (all active tips), when the head indexes, it does so very low. It then travels very near to the qualification sphere to get to the next point to measure the sphere. If the order of tip angles is bad, it could crash into the qualification sphere. When qualifying the tips, we haven't had it crash yet, but it may just be that we have gotten lucky in the order of the tip angles, and what ones we use. When it indexes from say A90 to say A15 or something, the probe actually gets very close to the plate, and the head on level to the CMM is maybe 2" above the sphere. The thumbnail has the Probe Setup Settings that were set up when we got the machine. I have tried increasing some of these numbers, but it doesn't really improve the height that it goes to, when changing tip angles, which is low.

    For example, if it calibrates the tip A105B180, it will then move the head about just over the sphere, then change to the next angle. If this was a User-defined order, it would definitely crash if the next angle was, say, A0B0.
    It then doesn't move like it would for a Clearplane to the next area, but then moves directly to the side of the sphere. Is this normal? In the case if the probe went to even A105B0 from A105B180, it would move down at an angle to put the probe right in front of the sphere, and barely misses the sphere with the head.
    Changing some of the numbers in the attached Settings seem to expand the movements a bit. Also keep in mind, that the qual. sphere shank is at a 45 degree angle

    This hasn't caused a crash yet using the Ctrl-Alt-P calibration.

    However...
    We run an autocalibrate program to qualify our active tips on the rack.
    In the Autocalibrate function, when it finishes a probe, it goes back to A0B0 automagically at the end. (I mean, even if you just Ctrl-E the single line, it does this, without having a Loadprobe after it, and clearplane lines would not execute until after it goes to A0B0.
    See the pictures for reference. That is where a calibration ends without using AutoCalibrate. If that calibration had run in Autocalibrate, it would have gone to A0B0 with the head 2" above the qual. sphere, and crashed into it. (on our other machine, the Autocalibrate also acts like this, but almost hits the tool changer as it finishes due to being so low in the Z axis. (The settings between both machines are the same, but one finishes on a different tip angle due to some not being added on the other, so the placement at the plate is different.)

    So. We could make a user-defined order for the auto-calibrate, but as explained up top, this can be dangerous, as the machine may try to drive through the sphere to get to the other side if ordered incorrectly.
    We can just calibrate each probe one at a time, but we like to run the autocalibrate overnight, as this takes the length of a shift to do all of our probes.
    We can't do the non-user-defined order, though, either, as the last angle to be calibrated is generally like an A105B180 or something, and then would index into the qual. sphere at the end of an autocalibrate line. Adding in move/clearp, or move/inc/0,0,300 or whatever wouldn't execute until after it crashed at the end of the autocalibrate line.

    Is there a way to fix this or a setting I am missing? A simple change in a setting value?
    Thank you in advance!
    We are using PC-DMIS 2018 R1 on our machines.
    Both machines exhibit this behavior, but one is a Hexagon 7-10-7 Global, and the other is a Brown and Sharpe 7-10-7.

    IMG_4755.jpgIMG_4756.jpgIMG_4757.jpgIMG_4758.jpgIMG_4776.jpg
    Attached Files

  • #2
    Maybe change the order of the of the angles calibrated or split the parameter sets into 2 or more parameter sets with move points in between.

    Comment


    • #3
      U need to calibrate that angle to sphere facing that direction?

      Comment


      • #4
        There are some clearance settings in the probe utilities box. (control+alt+P) Find the button on the right that says "Setup." I am not at the machine right now so I do not know the name of the setting located there, but it's pretty clear once you find it. Increase the clearance distance and save the value. The probe will move above the sphere higher before a tip angle change. These are global so it applies to all probes. I had to do that because out longest probe wanted to pass through the sphere for a tip change.

        Comment


        • #5
          from core manual (3.7)
          · Clearance distance along the qualification tool shank vector: x
          Where x is the clearance distance
          · Clearance distance along the qualification tool shank vector for
          continuous wrist probes: x
          Where x is the clearance distance
          · Clearance distance in Z when qualification tool shank is perpendicular
          to the Z axis: x
          Where x is the clearance distance

          probe setup.JPG

          Comment


          • #6
            https://youtu.be/HOx8bXxvIAE Seemed to work.

            Comment


            • #7
              I had a similar issue. I just changed the angle after the loadprobe to the last angle qualified in the autocalibrate sequence. Then when the autocalibrate finishes it move as per the clearance distances mentioned above, and remains at that angle. You can then use the normal move/point and/or load another tip.

              Comment

              Related Topics

              Collapse

              Working...
              X