Windows 10 Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 10 Issues

    Quick story: IT forced our hand to update our CMMs to Windows 10 PCs. We use PCDMIS 2011mr1, on two machines, 2019r1 on the third. We are having intermittent episodes where the PC will lose connection with the controller. Jogbox blinks, and only fix is a re-boot of both the controller and PC to re-establish connection. We got a 30 day trial to see if upgrading to latest software would help, it did not.

    We firmly believe it's an IT / Permissions issue. IT swears up and down it isn't them.

    Any thoughts or musings would be appreciated. Thanks.

  • #2
    Antivirus/firewall maybe?
    PC-DMIS CAD++ 2o19 R1 SP11

    Comment


    • #3
      Maybe check the Windows 10 serial driver, both to see if it's up-to-date and if it's playing nice with PC-DMIS? Is it on all the machines, or just the ones with 2011? That's pretty old - the closest we have to that is on a PC running Windows XP.

      Comment


      • #4
        Turn off all energy saving options for the network card and/or USB port(s). Preferably also turn off CPU and disk energy saving options.
        AndersI
        SW support - Hexagon Metrology Nordic AB

        Comment


        • #5
          I have never seen PC-DMIS or Windows throw the controller into an error state, not that it couldn't happen but I just can't picture a scenario where it could happen. While I don't recommend disabling CPU energy savings since this is directlytied to thermal throttling and can damage a CPU that doesn't have an effective cooling solution. I do recommend disabling the hard drive timeout, PCI Express link state power management, and USB selective suspend. Also verify that sleep and hibernate are also completely disabled.

          Not likely a permission issue but if you're using TCP/IP communications they may have reset the drivers for the network card, I would suggest that if you're using TCP/IP communications on a B3 Leitz Protocol controller that you set the speed and duplex of the communication speed to 10Mb/Full in the device manager.

          Since I'm not sure which type of controller you're running I have to assume you're using serial communications. If this is the case I would suggest disabling the FIFO buffers for the related comm port too.

          These are not my instructions but

          1.Click on the Start button
          2.Search for "Device Manager" (Once you've clicked on the start button you can just start typing, the search interface will immediately begin, no need to find the search or click on the search options)
          3.Wait for Windows to find the device manager application
          4.Click on Device Manager in the left pane
          5.Click on the pointer next to Ports (COM & LPT) to expand it
          6.Right-click on the Serial Comm Port
          7.Click Properties
          8.Click on the Port Settings tab at the top of the dialog
          9.Click on the Advanced button
          10.You should see the above dialog.
          11.Click and hold the Receive Buffer slider and move it all the way to the left
          12.Repeat for the Transmit Buffer
          13.Uncheck the Use FIFO buffers check box.
          14.Click OK to accept the changes and close the Advanced Settings dialog
          15.Click OK to close the Properties dialog
          16.Repeat with all serial devices in device manager

          The bad news is that you're not going to have a lot of fun with 2011 and Windows 10. Since some of the major protected memory exploits a lot of the original VB code from the old installer packages have been rendered unusable in Windows 10 (and possibly some earlier versions) So you're not going to be able to reinstall on a W10 box and it's likely this won't be the only issue you run into either.
          Systems Integrator
          Hexagon Manufacturing Intelligence

          Comment


          • #6
            Originally posted by Peter Fuller View Post
            I have never seen PC-DMIS or Windows throw the controller into an error state, not that it couldn't happen but I just can't picture a scenario where it could happen. While I don't recommend disabling CPU energy savings since this is directlytied to thermal throttling and can damage a CPU that doesn't have an effective cooling solution. I do recommend disabling the hard drive timeout, PCI Express link state power management, and USB selective suspend. Also verify that sleep and hibernate are also completely disabled.

            Not likely a permission issue but if you're using TCP/IP communications they may have reset the drivers for the network card, I would suggest that if you're using TCP/IP communications on a B3 Leitz Protocol controller that you set the speed and duplex of the communication speed to 10Mb/Full in the device manager.

            Since I'm not sure which type of controller you're running I have to assume you're using serial communications. If this is the case I would suggest disabling the FIFO buffers for the related comm port too.
            We are using TCP/IP communications, device manager is set correctly at 10mb/Full. Thanks to our local Hexagon tech, he made sure we were aware of these settings.


            Comment


            • #7
              One other thing that may be related. We currently do a lot of scanning. We have a Renishaw SP25 so we scan a LOT. Our 2011mr1 programs run fine with our probe density set at 0.5, but in 2019r1, it's a no go. Program just freezes. If I change it to 2, and re-run, no issues.

              Any thoughts to this??

              Comment

              Related Topics

              Collapse

              Working...
              X