PC DMIS autocalibration, wrong angles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PC DMIS autocalibration, wrong angles

    Hello all
    Last night we had a crash in our CMM resulting in the probe breaking and us having to replace it.
    We mounted the new probe (tp-200) and started calibrating our tips (we have probe changer).

    But whenever we run our autocalibration program, instead of starting in A0B0-angle, it starts in A0B5. (which makes no sense since there isnt even any a0b5 angle to start with).
    I go into the calibration dialog, and see it has automatically added A0B5, so i remove it and run the program again. Then it adds the A0B5 angle in the beginning of the program again. (the calibration dialog opens for 1 second and then closes when the starting the program).

    Anyone have any idea what might be causing this?

    edit: after localizing the calibrationsphere with a manual point (in the A0B5-angle) it starts the calibrationprogram as usual, and procceeds to calibrate a0b5 and then it overgoes to a0b0 and it goes as normal)

    sorry for bad english
    Last edited by pcdmisstudent; 08-22-2019, 07:29 AM.

  • #2
    Are you setting your Parameter Set?

    When I do an autocalibration, I have a parameter set that is the probe name and I reset it for each program that I run setting A0B0 first. Here is my process:

    1. F9 the probe to open the Probe Utilities window.
    2. Select "Mark Used"
    3. Holding CTRL, deselect A0B0 then reselect it telling it to calibrate A0B0 first (Looks like this when done correctly: "1 T1A0B0") then DMIS can decide the order to run the rest, I just want A0B0 to run first.
    4. Select "Measure..." button. That should take you to the Measure Probe dialog box.
    5. In the "Parameter Sets" section, select or type a name for the parameter set for the selected probe/program/ect... (most common for me is 2MM80) then select save. When you select save, DMIS will set the order of the remaining tips in the probe utilities window and you will see it happen as soon as you hit save and a box saying "Existing set: (whatever your parameter set name is) has been updated. Select "OK" in that window to close it out.
    6. Select "Cancel" to exit out of the Measure Probe dialog box.
    7. Select OK to exit out of the Probe Utilities dialog box.
    8. Making sure your Autocalibrate command line is below the Loadprobe line of the probe to be calibrated, confirm that the PARAMETER_SET= is set to the parameter set you just saved. If not, F9 the Autocalibrate line (F9 will bring up the calibrate probe dialog box for autocalibration) and select the parameter set from the dropdown at the bottom of the dialog box.
    9. Select OK to exit that dialog box then execute the program.

    Something I like to do is have the autocalibration show me the summary of the calibration so I can confirm the proper tips were calibrated.

    Sorry for the long post and telling you some things you probably already knew. It's just easier for me to do it that way and make sure I'm not leaving anything out.
    Remembering my beautiful wife Taz who's life was lost on 6-13-2020. I love you and I miss you.

    Comment


    • #3
      Did the crash turn the whole head? I recently came in after a crash overnight and notice that the probe angle looked crooked, I rotated to A-90B0 to look along Y-axis and could see that the rotation wasn't correct (approx. A-90B5) and I had to manually turn to align.
      I have never had this happen before and luckily calibration for machine was the next day.
      I was told it crashed during rotation while calibrating (operator defined the order....)

      Comment


      • #4
        Any luck yet? this is almost exactly what I encountered and posted not so long ago, except there was no crash(at least that I was told of)

        I ended up basically tricking it into A0B0 position then closing pcdmis. Then I deleted all probe files completely and started up again.
        The problem never recurred after deleting and rebuilding the probe files and that was 5 weeks ago.
        I was nearly certain the wrist was pooched before I tried probe files as a last resort.

        it was doing the same thing to me, trying to add A0B5 angle, and the software was not always properly keeping track of where the wrist was either, wrist would be in A0B0 and pcdmis would be telling me the active probe was A0B5

        https://www.pcdmisforum.com/forum/pc...eally-did-this
        Last edited by Douglas; 08-26-2019, 02:52 PM.

        Comment


        • #5
          When there's a crash, the probe is disable. When you press "start", the probe takes its place at the closest angle.
          If this one doesn't exist in the list, PC-DMIS automatically add it.

          Comment


          • Douglas
            Douglas commented
            Editing a comment
            that would explain what I saw when I had similar issue... except 'nobody' crashed the machine that day.

            Mr. Nobody Not Me strikes again I'm starting to dislike that guy he gets into everything

        Related Topics

        Collapse

        Working...
        X