Operator mode opening in online mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Operator mode opening in online mode

    We have a couple CMM's that typically only the CMM staff run. They utilize multiple tips and modules so we just try and keep production operators out of there so there's less stuff they can break. Recently I've been asked to open those machines up to more operator use, which is fine the company has needs and i get that. However, we usually run those machines in Protected Mode to prevent meddling but that also prevents them from qualifying probe tips as well. I tried to set up operator mode for these machines so operators would be able to qualify angles used in the programs for their parts, but oddly enough, when i open Operator mode, it just opens in Online mode. Has anyone else experienced this? we are running 2013MR1 CAD++ on all four of our machines. Two of which run exclusively in Operator mode.

  • #2
    IMO (and in the opinion of most of the people I've talked to) Operator Mode is garbage.

    At my company, the machinists run the CMMs. All of the machines are in Protected Mode (unless being used be me) and autocalibration commands with some YES/NO "flow control" are being used tpo give them the option to calibrate or not.


    Code:
    QUAL_QUESTION   =COMMENT/YESNO,NO,FULL SCREEN=NO,AUTO-CONTINUE=NO,
                  Has the CMM been calibrated??
                  IF_GOTO/QUAL_QUESTION.INPUT=="YES",GOTO = LABEL_END_CALGROUP
    QUAL_ACTION   =COMMENT/INPUT,NO,FULL SCREEN=NO,
                  1--> Let's calibrate the CMM now.
    
                  2--> Just run the program. I
                  don't need to calibrate.
    
                  3--> I need help.
    
                  IF_GOTO/LEN(QUAL_ACTION.INPUT)<>1,GOTO = QUAL_ACTION
                  ASSIGN/VAR_1=ARRAY(1,2,3)
                  ASSIGN/VAR_2=MIN(ABS(VAR_1-QUAL_ACTION.INPUT))
                  IF_GOTO/VAR_2<>0,GOTO = QUAL_ACTION
                  SELECT/QUAL_ACTION.INPUT
                    CASE/1
                      DISPLAYPRECISION/7
                      COMMENT/OPER,NO,FULL SCREEN=NO,AUTO-CONTINUE=NO,
                      Screw sphere into calibration hole. Ball facing CMM's Y+ (if applicable). Press okay when complete.
                      AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=YES_DCC,
                                    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=NO
                      COMMENT/OPER,NO,FULL SCREEN=NO,AUTO-CONTINUE=NO,
                      MOVE PROBE FAR OUT OF THE WAY.
    
                      Once probe is out of the way, remove
                      the sphere & put in safe place.
                      DISPLAYPRECISION/4
                      GOTO/LABEL_END
                    END_CASE/
                    CASE/2
                      GOTO/LABEL_END_CALGROUP
                    END_CASE/
                    CASE/3
                      GOTO/LABEL_END
                    END_CASE/
                    DEFAULT_CASE/
                      GOTO/LABEL_END
                    END_DEFAULTCASE/
                  END_SELECT/
    LABEL_END_CALGROUP  =LABEL/
    The stuff in bold was just me being extra. You could erase that stuff and the code would still work fine
    Last edited by DAN_M; 08-15-2019, 09:20 AM.

    Comment


    • #3
      Check and make sure that the link in the shortcut has the /o command line option - example "C:\Program Files\Hexagon\PC-DMIS\2016\pcdlrn.exe" /o
      AndersI
      SW support - Hexagon Metrology Nordic AB

      Comment


      • jtrofatter
        jtrofatter commented
        Editing a comment
        spot on sir! its looking like this is the issue. now to go bother our IT department

    Related Topics

    Collapse

    Working...
    X