Printing Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Printing Issue

    I have been assisting our sister plant with creating new CMM programs in PCDMIS. I and the programmer there are using 2019r1, build #406 to create said programs. No issues until now.
    He has starting to encounter issues with creating the reports. We print and save them as .PDF files. Code is below:

    Create the PDF:

    Code:
    ASSIGN/PDFNAME="C:\Users\kuglejd\Desktop\Current_CMM_Programs\\Test789123.pdf"
    Print the PDF:

    Code:
    $$ NO,
                -------------------------
                PRINT/REPORT,EXEC MODE=END,$
                  TO_FILE=ON,AUTO=1,AUTO OPEN=ON,$
                  TO_PRINTER=OFF,COPIES=1,$
                  TO_DMIS_REPORT=OFF,FILE_OPTION=INDEX,FILENAME=,$
                  REPORT_THEORETICALS=NONE,REPORT_FEATURE_WITH_DIMENSIONS=NO,$
                  TO_EXCEL=OFF,$
                  PREVIOUS_RUNS=DELETE_INSTANCES
    $$ NO,
                -------------------------

    So the issue is when the program is done running, PCDMIS asks where to put the report. Everytime. Offline, Online, doesn't matter.

    The weird thing is, when I run the exact program, it works just fine for me. Runs the program, puts the report where it is supposed to go,
    doesn't ask anything.

    I personally think its a setting somewhere. Not sure where.

    Any and all help would be appreciated.

    Thanks,
    John


  • #2
    First thing I'd check...maybe he has "prompt" selected on his end and you have the box for "auto" checked off..?pic.PNG
    Last edited by DAN_M; 07-16-2019, 10:23 AM.
    Beep beep beep..

    Comment


    • #3
      Put the cursor on "Auto" and press F7 to change it to "Overwrite". This will show the path. Change the path to the variable PDFNAME you created. When it asks if you mean the variable say yes. Then put the cursor on "Overwrite" and press F8 to change back to "Auto".
      PC-DMIS 2016.0 SP8

      Jeff

      Comment


      • #4
        Well your code says you're printing to your desktop (This is user specific). If your co-worker is trying to print to your desktop and he is logged in as him on another computer completely, this will never happen.

        Change this location to a share location or a public documents folder where the folder exist and the user has read/write access and as a general rule never print to user specific locations or protected sections of the hard drive.
        Systems Integrator
        Hexagon Manufacturing Intelligence

        Comment


        • John Kugler
          John Kugler commented
          Editing a comment
          Yes. I understand that. No matter where they say to put it. Network, local desktop, etc, etc... it still does it. I can do the exact same thing and it works like it should.

      • #5
        Quoting Andersl

        Originally posted by AndersI View Post
        The double dialog when using "Prompt" is because you don't have enough access rights to the Registry key HKEY_CURRENT_CONFIG\Software\PC-DMIS 50 Converter

        The "Output File name" even in "Auto" mode indicates you don't have enough access rights to the folder you're trying to write in.
        This happens with improperly configured computers since HKCC shouldn't be restricted. Have your IT department give "users" or "everyone" full control of HKCC\Software\ and see if that solves it.
        Systems Integrator
        Hexagon Manufacturing Intelligence

        Comment


        • #6
          Peter Fuller, that worked, thank you

          Comment


          • Peter Fuller
            Peter Fuller commented
            Editing a comment
            Glad this solves your problem! Hopefully John gets this solved too!

          • John Kugler
            John Kugler commented
            Editing a comment
            FYI - My issue was his issue....

            Seriously, thanks for the help.

          • Peter Fuller
            Peter Fuller commented
            Editing a comment
            Thank you for the update John, glad we could resolve this so easily.

        Related Topics

        Collapse

        Working...
        X