Slow offline editting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slow offline editting

    Looking for some assistance with getting my offline seat to be a bit faster when editing programs.

    Currently I am running Win 10 and PC-DMIS V2015.1 Build 1265 (Service Pack 10)
    (64 bit, intel core i7(8th gen) @ 2.20GHz 2.21 GHz, 16GB ram (15.9 avail))

    I have already removed the undo/redo functionality in settings editor to pick up some speed.

    Issue I'm seeing regularly with a program file(13,66 KB) cad (83,144 KB) is when I even edit the NAME of a feature, the pc-dmis environment goes to a 'Not Responding' status and lags for 10-40 seconds. Depending on the amount of influence a feature has (used in alignments, feature builds, outputs etc...) the lag will vary. When watching the Task Manager 'CPU' typically tends to spike from a usable 5% to between 11 and 12% when it triggers the 'Not Responding' in the Applications task ribbon.

    I do not see any other settings that are different from previously used as far as when in the application but...? Can anyone help to shed some light on how to help smooth this issue out?

  • #2
    Are you working from a company server or local drive?

    Comment


    • #3
      SSD, More RAM, and not sure what Video Card you're using. Get yourself a Cloning Device from Amazon about $30 or so, Clone your existing harddrive so you don't have to go through releasing the PC-DMIS seat and reassigning it and all that. That way you don't have to back anything up either.
      (In Memory of my Loving wife, "Ronda" who I lost March 7, 2016. I love you baby.)
      They say "Nobody's Perfect." I must be Nobody.

      Comment


      • #4
        Originally posted by FMC.QC View Post
        Are you working from a company server or local drive?
        Any file I edit is being done locally then I copy it from my local to a server for back up once completed. (All probing is copied to my local as well.)

        Originally posted by KIRBSTER269 View Post
        SSD, More RAM, and not sure what Video Card you're using. Get yourself a Cloning Device from Amazon about $30 or so, Clone your existing harddrive so you don't have to go through releasing the PC-DMIS seat and reassigning it and all that. That way you don't have to back anything up either.
        Kirbster - NVIDIA Quadro P600? As for the other options I will need to verify that the IT dept will allow for them. While I recognize that SSD is faster than HDD, my win 7 PC had HDD and it was not offering the challenges I have today.

        Comment


        • #5
          Have you Shelled the program yet?
          PcDmis 2015.1 SP10 CAD++
          Global 7-10-7 DC800S

          Comment


          • #6
            Do you have a lot of graphical analysis on the cad model?

            Comment


            • #7
              Yeah I have a P620 quadro it struggles. I would say the Ram is the most important.
              (In Memory of my Loving wife, "Ronda" who I lost March 7, 2016. I love you baby.)
              They say "Nobody's Perfect." I must be Nobody.

              Comment


              • #8
                Does it persist if you switch off the solid model? at least then you know that it's graphics/processor speed related and not something crazy like corrupt hasp drivers (if you are using a dongle and not lms at least).

                Comment


                • louisd
                  louisd commented
                  Editing a comment
                  Operation-> graphic display window -> graphic items -> Show cad (or for 2015 the blue sapphire looking button)

              • #9
                Okay so that's a pretty decent spec PC. Decent amount of RAM, okay on GPU, good processor.


                Your program is large but not obscenely so. That's quite a large CAD file but again not ridiculous.


                It shouldn't be lagging like that really. How many lines of code do you have? How many features? Is there a lot of Xact /FCF in the program?


                louisd makles a good suggestion. Eliminate CAD/Graphics as the issue first. (I assume you've checked that PC-Dmis is actually using the Quadro card?)

                Rename the .CAD file and see how it behaves.

                If still the same actually hide the graphics window (View > untick Graphics Window) and see how it is.

                What are your open GL settings? (Edit > Graphics Window > Open GL)
                Automettech - Automated Metrology Technology

                Comment


                • #10
                  As NinjaBadger pointed out, check your openGL settings. More specifically, try increasing your tessellation multiplier. It'll spend less memory on CAD facets.

                  Comment


                  • #11
                    Thank you all for your responses:

                    I removed the cad file all together and was still having significant lag. (Restarted the PC after removing the cad to give the freshest start to the software)

                    Something not mentioned here was related to probefile, I swapped out the workstation version and made a fake offline one that has 0 parameter sets and NO additional angles than what is used in the program. (This just made a significant impact on the lag I have been experiencing.) <-Bothersome as I've never had an issue with this in the past (OHH well!!)

                    Hope this information helps someone someday (or me next time IT upgrades my PC)

                    Comment


                    • #12
                      Stop visiting p o r n websites, just saying. Anti virus software can slow it down too

                      Comment


                      • KIRBSTER269
                        KIRBSTER269 commented
                        Editing a comment
                        talking from experience

                      • R2ah1ze1l
                        R2ah1ze1l commented
                        Editing a comment
                        PFFFF... this is 2019, no one is searching that from the work computer now, you do it on the company phone....

                    • #13

                      Comment


                      • #14
                        I would really start looking into drivers and configuration. I ran larger models offline with built in graphics and a terribly slow mechanical laptop drive with relatively few issues for years with versions up to 2017.1 before I replaced my laptop with a beast. It wasn't perfect but 10-40 seconds indicates to me a driver is either not installed, not installed correctly, or no recent enough.

                        I would also check the Nvidia control panel and make sure that the PC-DMIS application isn't using integrated graphics to render. Less likely but possible.
                        Systems Integrator
                        Hexagon Manufacturing Intelligence

                        Comment


                        • #15
                          Hello guys,

                          I'm new on this forum and i don't sure is this topic good for my question.
                          I alredy install new version of software PC DMIS 2019 R2 before that i has version 2013 MR1,
                          When i start to measure some part in 2019 version with CAD model i have very big lags with all PC and software, also machine stop to measure. When i measure first part when i starting machine and software they work perfectly after that with second measuring i have big lags.
                          Is it problem with my PC configuration or some problem with software.
                          My PC configuration is:

                          Operating system: Windows 7
                          Processor: Intel(R) Core(TM) i3-2120 CPU @ 3.30 GHz 3.30 GHz
                          Installed memory (RAM) 4.00 GB
                          System Type: 64-bit Operating System
                          Graphic Card: NVIDIA Quadro 600 - 3GB memory

                          Thank you for your answers.

                          Regards.

                          Comment


                          • RanDawgg
                            RanDawgg commented
                            Editing a comment
                            With that configuration, I'm pretty confident that it is your PC. Open up task manager, and select the performance tab. Open up PC-DMIS and play around with it, all while looking at the task manager. Look to see if your CPU, RAM, or GPU are bottlenecking your performance.

                        Related Topics

                        Collapse

                        Working...
                        X