Scan jumps around corners

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Scan jumps around corners

    G'day folks,

    I am having an issue with linear open scanning. As you can see on the screenshot, the probe does not follow the profile around corners, it rather jumps, jerks then carries on.

    Any suggestions to make it follow the profile?

    Running PC-DMIS CAD++ 2018 R2 on Hexagon Global S, Leitz LSP-X1S probe with 1by35mm tip

    SCANSPEED/5
    OPTIONPROBE/MAXFORCE=0.072,LOWFORCE=0.0096,UPPERFORCE=0.048,TR IGGERFORCE=0.015,
    PROBEACCURACY=0.1,POSACCURACY=0.1,#RETURNDATA=7,
    RETURNSPEED=0.4,SCANPNTDENSITY=10,
    SCANACCELERATION=10,SCANOFFSETFORCE=0.036,
    PROBINGMODE=DFL,MANFINEPROBING=NO
    SCN15 =FEAT/SCAN,LINEAROPEN,NUMBER OF HITS=1364,SHOW HITS=NO,SHOWALLPARAMS=YES
    EXEC MODE=DEFINED, NOMS MODE=FIND NOMS,CLEARPLANE=NO,SINGLE POINT=NO,THICKNESS=0
    FINDNOMS=10,SELECTEDONLY=NO,USEBESTFIT=NO,PROBECOM P=YES,AVOIDANCE MOVE=NO,DISTANCE=0,CAD Compensation=YES,4-axis scan=NO
    DIR1=NULLFILTER,
    HITTYPE=VECTOR
    INITVEC=-0.9961947,-0.0000043,0.0871557
    DIRVEC=-0.0062794,0.9999802,0.0005494
    CUTVEC=0.0871557,0,0.9961947
    POINT1=44.1496,-0.0002,3.9731
    MEAS/SCAN
    BASICSCAN/LINE,NUMBER OF HITS=1364,SHOW HITS=NO,SHOWALLPARAMS=YES
    <44.1496,-0.0002,3.9731>,<0,0,0>,CutVec=0.0871557,0,0.996194 7,DirVec=-0.0063034,0.9999801,0
    InitVec=-1,-0.0000043,0,EndVec=0,0,0,THICKNESS=0
    FILTER/NULLFILTER,
    EXEC MODE=DEFINED
    BOUNDARY/PLANE,<0,0,0>,PlaneVec=0,0,1,Crossings=1
    HITTYPE/VECTOR
    NOMS MODE=FINDNOMS,10
    ENDSCAN
    ENDMEAS/


    Picture1.jpg



    scanning jumpy2.JPG

  • #2
    Personally, I do not scan over sharp corners. I separate the scans. I was told once that probe compensation can become inaccurate at these points.
    Also, I see that your scan speed is set to 5 and acceleration set to 10. I have had great luck changing both values instead of just the scan speed. Try lowering the acceleration and test it out again.
    Have you double checked the analog option probe hexagon spreadsheet to make sure your settings are correct? They do not look correct to me. I am not at my desk, so I cannot confirm this. Maybe a search on here can yield this document?
    Is your Find Noms tolerance set to 10mm? It is my understanding that the tolerance should be set to the tolerance of the feature being probed, plus the probe radius, and add 10% for out of tolerance conditions. My tolerances are fairly tight so I default to the probe diameter and it works 100% of the time. (In this case 1mm.)

    Comment


    • #3
      Originally posted by SingularitY View Post
      Personally, I do not scan over sharp corners. I separate the scans. I was told once that probe compensation can become inaccurate at these points.
      Also, I see that your scan speed is set to 5 and acceleration set to 10. I have had great luck changing both values instead of just the scan speed. Try lowering the acceleration and test it out again.
      Have you double checked the analog option probe hexagon spreadsheet to make sure your settings are correct? They do not look correct to me. I am not at my desk, so I cannot confirm this. Maybe a search on here can yield this document?
      Is your Find Noms tolerance set to 10mm? It is my understanding that the tolerance should be set to the tolerance of the feature being probed, plus the probe radius, and add 10% for out of tolerance conditions. My tolerances are fairly tight so I default to the probe diameter and it works 100% of the time. (In this case 1mm.)
      Thanks SingularitY, I had the same thought so first thing i checked was the probe force settings which are correct to the handbook that the install technician left for us. I have tried to play around with them, as in the past I had good outcome doing that, no luck this time though. Also has slowed down the speed to prozac slug mode, no better...

      I'll try your suggestions, thanks for the input!

      Comment


      • #4
        Have the same problem, you'd think the software would add control points at corners to slow itself down to scan them properly.
        PC-DMIS CAD++ 2o19 R1 SP4

        Comment


        • #5
          Change your SCANOFFSETFORCE to .076 and slow down SCANSPEED to 1 or 2
          Last edited by gszpot; 07-09-2019, 11:45 AM.

          Comment

          Related Topics

          Collapse

          Working...
          X