"Auto" command for printing .pdf report is not working.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Auto" command for printing .pdf report is not working.

    Hello everyone..new to the forum.

    I am trying to setup our report printing to auto, and from class/reading other posts it seems as though this should work smoothly. However I have the output set to auto, I run the program, and nothing happens. The report doesn't seem to save in the specified folder, let alone seem to save anywhere. If I set it to "Prompt", the window pops up twice, only saving on the second time there. Not really sure why this has been happening. We've done software updates since then and the issue still happens. Currently on 2018 R1.

  • #2
    The checkbox for the filename needs to be checked, make sure it is.
    PC-DMIS CAD++ 2o19 R1 SP10

    Comment


    • #3
      Should be right?

      Capture.JPG

      Comment


      • KIRBSTER269
        KIRBSTER269 commented
        Editing a comment
        and you said it was popping up twice? Do you have a PRINT COMMAND in your program also?

      • stkenitz
        stkenitz commented
        Editing a comment
        It is on the network, not a drive. And there is no print command either. I did contact Hexagon about this, and they said it is most likely a bug,

      • KIRBSTER269
        KIRBSTER269 commented
        Editing a comment
        I'm sorry the drives I was referring to, was network drives. That's why I mentioned what I did.

    • #4
      Try assigning the network drive to a device letter and use that as path.
      PC-DMIS CAD++ 2o19 R1 SP10

      Comment


      • stkenitz
        stkenitz commented
        Editing a comment
        I think it is working...however on auto, there is still an "Output File Name" that pops up.

      • KIRBSTER269
        KIRBSTER269 commented
        Editing a comment
        stkenitz check the other tabs, DMIS or Excel, make sure you don't have one of those checked also.

      • stkenitz
        stkenitz commented
        Editing a comment
        KIRBSTER269 Neither are checked.

    • #5
      In 2015.1 I have to point the file drop-down to a "dummy file" and every single routine is pointed to that file "dummy". Only after I do that - that the print commands work as advertised local or networked.

      Another test to run is to make sure the file path is correct. One of the first things I ran into when I first started my adventure with print commands. I used the hover over assignment feature along with poor-man's debugger called operator comments.
      PcDmis 2015.1 SP10 CAD++
      Global 7-10-7 DC800S

      Comment


      • #6
        The double dialog when using "Prompt" is because you don't have enough access rights to the Registry key HKEY_CURRENT_CONFIG\Software\PC-DMIS 50 Converter

        The "Output File name" even in "Auto" mode indicates you don't have enough access rights to the folder you're trying to write in.
        AndersI
        SW support - Hexagon Metrology Nordic AB

        Comment


        • derrickcoyne
          derrickcoyne commented
          Editing a comment
          This was also my solution. Although my cmm user account should have all the correct privileges, it would not work properly until I started pc-dmis specifically using Run As Administrator.

        • AndersI
          AndersI commented
          Editing a comment
          That's not really the solution - by changing access rights only for parts where you *need* access you can continue running as normal user, and don't have to brute force as admin. There are also other problems in some networks when running as admin. Every computer should be correctly configured for the job at hand.

      • #7
        As Anders said this is likely a permissions issue - as atest try create a text file in that location and you'll probable find you can't.

        Ask IT to give you access.

        Automettech - Automated Metrology Technology

        Comment


        • #8
          If pcdmis does not think it can create the file it will prompt the user.

          Comment

          Related Topics

          Collapse

          Working...
          X