Linear closed scan not snapping to part

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linear closed scan not snapping to part

    Resolved:

    PCDMIS CAD++ 2013 MR1

    Hi All,

    I am at a new job and getting to work with some new things!

    I have created a linear closed scan from my IGES model and it looks like it generates the scan path where I want it - wrapping around the OD of a rectangular boss with rounded corners.

    However, when I perform Collision Detection, I can see the probe is trying to scan around the inside of the part - like the whole dimension is smaller than the features I clicked on to make the scan.

    If I try to run on the actual part, I get the same results/ the CMM errors out with a 'maximum probe deflection' emergency error.

    I've tried recreating the scans. I've tried shelling the program and doing only the alignment, then the scan. Same results.

    This scan did work in a previous program that was written before any of us who currently work here. We are trying to re-write it because we'd like it to be in inches when we loop the program.

    Thanks in advance!

    EDIT: Could post #5 here be causing this type of problem? Tesselation from the model?

    https://www.pcdmisforum.com/forum/pc...profile-oddity
    Last edited by EmilySue; 05-13-2019, 08:30 AM.

  • #2
    Check you CAD vectors.
    EDIT\GRAHICS DISPLAY\ CAD VECTORS\
    click the surfaces and see if vector arrows are pointing out of part.
    You can also go to CAD LIGHTING, uncheck 2 sided lighting ( under the lighting tab).
    Surfaces with the wrong vectors will turn a darker color, showing reversed vectors.

    Comment


    • EmilySue
      EmilySue commented
      Editing a comment
      Ok. All my scan surfaces show reverse vectors. Is there a way I can fix this?

    • EmilySue
      EmilySue commented
      Editing a comment
      Figured out I could flip them from EDIT\GRAPHICS DISPLAY\CAD VECTORS

      and it appears I can run my scans! Thank you!!!

  • #3
    Originally posted by BKulpa View Post
    Check you CAD vectors.
    EDIT\GRAHICS DISPLAY\ CAD VECTORS\
    click the surfaces and see if vector arrows are pointing out of part.
    You can also go to CAD LIGHTING, uncheck 2 sided lighting ( under the lighting tab).
    Surfaces with the wrong vectors will turn a darker color, showing reversed vectors.
    Yes
    when you pick a surface in the CAD vectors you will see a counter populate
    Check the arrows and then hit reverse or FLIP SURFACE VECTORS vectors to change them
    there is also a fix vectors by doing a screen grab to select all CAD surfaces and then hit FIX Surface Vectors

    Comment


    • #4
      There have been some occasions where just some of my CAD models were goofy,(not the hole thing)
      I would just click on this and it would go from an inside to an outside, or vice versa.

      Capture.PNG

      Of course generate your points first
      (In Memory of my Loving wife, "Ronda" who I lost March 7, 2016. I love you baby.)
      They say "Nobody's Perfect." I must be Nobody.

      Comment


      • #5
        IMNSHO If you are going to use scans use a STEP model instead of an IGES then select the entire CAD model and go to EDIT >GRAHICS DISPLAY > CAD VECTORS > Fix Surface Vectors. If that does not take care of the issue then try flipping just that surface.
        Xcel & MicroVal Pfx & Global 37mr4 thru 2012mr1sp3
        Contura Calypso 5.4

        Lord, keep Your arm around my shoulder and Your hand over my mouth. Amen.

        Comment


        • #6
          Because I like to torture myself... we need to loop this program. I tried RELEARN and FIND NOMS in Execution Tab, but it crashed on the second part. After doing a little reading, I want to try DEFINED and NOMINALS. But if anyone sees this and can let me know how it should work, that would help a TON!

          Comment


          • KIRBSTER269
            KIRBSTER269 commented
            Editing a comment
            DEFINED, FIND NOMINALS, Check Best Fit. At the Top I use Nullfilter before I generate my Points or scan, I set my points at the right height, I click on Settings Tab. Probably overkill but 6 or 7 Points per mm acceleration 10, scan 10, force .120 hit Apply, Go to Graphics, highlight my surfaces, Path definitions Tab. Generate my Points

          • KIRBSTER269
            KIRBSTER269 commented
            Editing a comment
            If you have a legit DCC alignment before each part starts measuring then this will be fine.

          • EmilySue
            EmilySue commented
            Editing a comment
            That is very close to what I've done. My boss talked with our local support people (independent company) and they confirmed that we'll need to import the model multiple times in order to make this loop work. We need to report profile, so it needs the model to compare to for each loop position. Trying that this morning; hoping I can get multiple models in there and it will still run. *fingers crossed*

        Related Topics

        Collapse

        Working...
        X