CMM losing its position

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CMM losing its position

    I came in this morning and began to do my daily routine and was met with the CMM attempting to put a tool up in the toolholder but in the wrong position.

    I immediately thought dang 2nd shift took one out and had put it back in a different holder.
    Wasn't the case.

    So I closed the program and re-opened it and re-played it so I could see which probe it thought it had.
    You know the little awesome box that tells you your currently loaded probe.
    It displayed the probe that was currently attached to the head.
    So that was also ruled out...

    So I allowed it to go to the rack and almost load the probe, Then stopped it right next to the holder it was going to load from.
    I noticed it was aligned perfect with the wrong holder along the x axis but was atleast a 1/2 lower in z than it should be.

    Well our rack has 2 height levels and it was at the height of the lower level but at the x position of an upper level holder.
    So i went into my rack settings to see what was what and its showed my tools to be right and the positions too
    but the CMM was not going to the right x,z locations.

    I then re-calibrated the tool changer and it fixed it, temporarily...

    A few hours later the guys came and got me and said it was off again.

    So I guess my question here is why is it changing positions?
    We've had this CMM for over 5 years and its never had an issue like this before.

    ADDED: Night shift said the lights in the shop flickered last night and the CMM threw some alarms.
    so they turned it off/on and re-calibrated the A0B0 on all the tools.
    which is routine.

    I just re-calibrated the tool changer again and its fixed but it was earlier too.
    Why is this happening?

    Thanks guys!
    and said everything was fine all night.
    Last edited by [email protected]; 05-06-2019, 09:27 AM.

  • #2
    That's ironic, I just had a similar issue.
    Make sure your C:\ProgramData\ (wai or hexagon)\PC-DMIS\(your version)\ToolC.dat and Tool.dat files aren't admin locked or read-only to your user profile while you are re-calibrating the racks. Your probe(rack) cal won't stick until this file can be modified.
    Last edited by louisd; 05-01-2019, 04:34 PM.

    Comment


    • #3
      I will check this out.
      I'm guessing that was your issue?

      If so did yours work for a while then revert too
      prior to routing the c:/?

      Comment


      • #4
        I've seen an improper A0B0 cal throw the rack position off...not sure why but i've seen it before.
        Ex-Hex

        Comment


        • #5
          could have been an issue?
          Night shift did an A0B0 after the flicker in the power. (It's been stormy here)
          And I always do one in the mornings when I fire it up.

          But... why would it for no reason 3 hours later after running wide open all morning revert back to another position?

          Comment


          • anthony.alfaro
            anthony.alfaro commented
            Editing a comment
            Maybe i misunderstood. This just happened randomly? NOT immediately after the calibration?

        • #6
          Happened randomly this morning.

          I came in and went to do my morning A0B0 calibration like I do every morning
          and it tried to crash as shown in the pics.

          I thought either the tool had been switched in the holder or I had missed the little box that
          ask's you which tool was loaded and accidentally sent it.

          But after examining everything
          all was correct.

          Leaving me to scratch my head..

          Only thing that helped was re-calibrating the tool changer.
          But later in the day it reverted back oddly.

          So I just re-calibrated the tool changer again.
          It's working now but for how long?
          I cant keep calibrating the rack ever hour lol.

          Comment


          • anthony.alfaro
            anthony.alfaro commented
            Editing a comment
            yeah, that's not normal.

            did you recently upgrade computer? change permissions? get a new operator login? any changes at all? If it persists, i would contact hexagon to make them aware.

        • #7
          We've done absolutely nothing new.
          Same thing every day proven processes.

          Comment


          • #8
            i've had the tool changer file randomly get corrupted had to delete it and recal the changer
            sigpic

            Comment


          • #9
            Thank you

            Comment

            Related Topics

            Collapse

            Working...
            X