Create Perp Plane BUG

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Create Perp Plane BUG

    Here is my scenario:

    I have a Plane A
    I have two points for B
    I create a line between the two points
    I project the line to Plane A (Not always necessary but a good practice)
    I now want to create Plane B perpendicular to Plane A through my projected line

    Every time I do this there is no checkbox to create my perp plane coplanar to the line. I would guess it would be a default? NOT SO!!!
    Instead, PC DMIS creates a plane at the midpoint of the line at some (always different) random angle to the line. ???? WHY?
    If I edit with F9 or look at the code, there is a coplanar checkbox in the panel (for F9) and a coplanar line in the code... Defaulted to NO. again WHY?
    Where was the checkbox when I created the plane? Why is the default NO? When, in my 30+ years doing this, have I ever created a perp plane through a line and not wanted it to be coplanar? NEVER!
    I call it a BUG!
    Oh yeah, and if for some strange reason I did want a non-coplanar mid plane, where would I input the angle??? it doesn't make sense.

    I don't know... maybe it's just me...
    Anybody care to chime in and correct my obviously erred ways? or, is this something that should be fixed?
    Last edited by Cheborneck; 04-19-2019, 10:32 AM.

  • #2
    Create a generic plane !
    ASSIGN/V1=CROSS(PLA.IJK,LINB.IJK)

    Now, it depends on the direction that you want to give to the plane :
    If B is external from A : (from plane centroid to line)
    ASSIGN/V2=DOT(LINB.XYZ-PLA.XYZ,V1)
    IF/V2<0
    ASSIGN/V1=-V1
    END IF
    and the opposite if it's internal

    Then create a generic plane :

    PLB =GENERIC/PLANE,DEPENDENT,CARTESIAN,$
    NOM/XYZ,<LINB.X,LINB.Y,LINB.Z>,$
    MEAS/XYZ,<LINB.X,LINB.Y,LINB.Z>,$
    NOM/IJK,<V1.I,V1.J,V1.K>,$
    MEAS/IJK,<V1.I,V1.J,V1.K>

    Comment


    • #3
      JEFMAN, thanks. That explains the random (or so I thought random) mid plane angle. the vector is pointing to the centroid of my Plane A.
      Still, I would like the Perp Plane default to be Coplanar, or at least give me the box to check it.

      Comment


      • #4


        OK... Tail between my legs...

        I went back and was trying different things within the function. Turns out that if you pick your plane and then your line... and THEN pick Perpendicular from the drop down list, it will give you the coplanar checkbox.
        facepalm

        Comment


        • #5
          Thank you for posting the "solution", it will help others.
          PC-DMIS CAD++ 2o19 R1 SP10

          Comment

          Related Topics

          Collapse

          Working...
          X