2019 R1 (SPx) issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2019 R1 (SPx) issues

    Starting a new thread listing issues found in PC-DMIS 2019 R1 (SPx).

    Each issue will be listed per post, not several in one post.

    I will not be hiding issues that is caused by user error either.


    Idea is to revisit my 2018 thread and move through the issues reported there - if and when I can find the time:
    https://www.pcdmisforum.com/forum/pc...18-r2-released

    General thoughts on 2019 R1 SP1:

    - Seems more volatile (prone to crashing) than 2019 R1
    - Needs quite a bit more time to "think" when a scan has been completed


    "Major" issues (calculation errors, etc.):

    - Impossible to use UPR filter above 1000:
    https://www.pcdmisforum.com/forum/pc...213#post449213

    - Outlier removal filter in autofeatures does not work, filtering not performed:
    https://www.pcdmisforum.com/forum/pc...318#post449318
    Last edited by vpt.se; 05-14-2019, 04:57 AM.
    PC-DMIS CAD++ 2o19 R1 SP2

  • #2
    PC-DMIS 2019 R1 SP1

    Feature sets are not selectable in datum definition dialog
    PCD-163766

    Feature sets does not display in the list of selectable features.

    Workaround: Do a DATDEF directly in the command (text mode) window.


    EDIT: Verified fixed as advertised in build 375 (SP2 release).
    Last edited by vpt.se; 05-07-2019, 08:56 AM.
    PC-DMIS CAD++ 2o19 R1 SP2

    Comment


    • Don Ruggieri
      Don Ruggieri commented
      Editing a comment
      This is fixed in 2019 R1 SP2 with build #375

  • #3
    PC-DMIS 2019 R1 SP1

    Analysis view with grid=on shows wrong values and grid labels cannot be moved? PCD-157107

    Just made an analysis view of a profile of any line (form) and enabled the grid:
    analysis profileform.JPG

    - I haven't been able to figure out how to move the axis labels, seems to me they cannot be positioned
    - The left axis shows a max of 3.8 and a min of -3.6, but of what? My max and min are 0.0407 and -0.0328...
    - Changing to manual axis values does not help, actually nothing changes at all...
    Last edited by vpt.se; 04-30-2019, 04:59 AM.
    PC-DMIS CAD++ 2o19 R1 SP2

    Comment


    • AndersI
      AndersI commented
      Editing a comment
      Did you have an arrow multiplier of 100? If so, the 3.8 and -3.6 seem [almost] consistent with the *displayed length* of the arrows (snapped to the grid?)...
      Last edited by AndersI; 04-17-2019, 10:28 AM.

    • vpt.se
      vpt.se commented
      Editing a comment
      Yes, the multiplier might have been set at 100, however the multiplier isn't displayed in the grid view or is hidden behind the other labels, so it would be an essential thing to display...

    • Don Ruggieri
      Don Ruggieri commented
      Editing a comment
      This is fixed in 2019 R2

  • #4
    PC-DMIS 2019 R1 SP1

    Point cloud selection does not show up in the feature selection list for Xact Measure profile

    I have two scans and two point cloud selections. When doing an Xact Measure profile evaluation, the point cloud selections does not show up in the feature list:

    Capture1.JPG

    However, if I click on SCN3, the point cloud selections show up:

    Capture2.JPG

    And are selectable:

    Capture3.JPG

    - If this is by design, I'd really like to have a [+] sign next to the parent feature so I know that the feature contains subitems.
    PC-DMIS CAD++ 2o19 R1 SP2

    Comment


    • #5
      PC-DMIS 2019 R1 SP1

      Deleting a defined datum marks the datum red in FCF's but cannot be removed through the XactMeasure FCF dialog


      I defined three datums for this test (three machine coordinate system planes) and made sure I had some circles to do a TP on:

      fcf1.JPG

      Nothing strange here. Command shows the same datums as the FCF.
      Click OK to close the dialog.
      Now, remove the DATDEF for datum Z, PC-DMIS will complain that there are evaluations using this datum. I chose to remove the datum regardless.
      The command should display Z in red.
      F9 the FCF:

      fcf2.JPG

      The command lists Z in red, the FCF does not display datum Z. Even if I click OK here, datum Z will not be removed from the command.
      I can even remove datum Y through the FCF dialog (not the actual DATDEF) and datum Z will still be in the command:

      fcf3.JPG

      Removed datum Y from the FCF through the dailog, but Z remains in the command.
      There is no way to remove a deleted datum from FCF's that have already been created through the XactMeasure dialog.

      Workaround: Simply delete the datum from the FCF command in text/command mode.

      fcf4.JPG
      PC-DMIS CAD++ 2o19 R1 SP2

      Comment


      • #6
        PC-DMIS 2019 R1 SP1

        Dimension colors does not display correctly when using "display lower tolerance as negative" is enabled PCD-162876


        When using GRAPH=ON this can display deviation arrows that are within tolerance to actually display the color for out of tolerance and deviation arrows that are out of tolerance can be displayed as the color for within tolerance.
        PC-DMIS CAD++ 2o19 R1 SP2

        Comment


        • #7
          PC-DMIS 2019 R1 SP1

          Graphics display window does not update immediately as it has in previous versions


          Rightclick a label in the graphics display window and choose "hide". The label does not hide until you manually refreshes the graphics display window or zoom/pans it.


          EDIT: Updating the graphics drivers fixed it.

          EDIT2: Not quite fixed, however this occurs only on one of our installations so I will flag this as a local issue...
          Last edited by vpt.se; 05-03-2019, 10:20 AM.
          PC-DMIS CAD++ 2o19 R1 SP2

          Comment


          • cvelisetty
            cvelisetty commented
            Editing a comment
            Hi vpt.se,

            I tried to reproduce the above issue and I was unable to reproduce the same. The label hides off immediately once after I do the operation. Tested in PC-DMIS 2019 R1 Service Pack 1.

          • vpt.se
            vpt.se commented
            Editing a comment
            Thanks cvelisetty, I'll try and update the graphics drivers to see if that remedies the problem.

            Updated graphics drivers + post.
            Last edited by vpt.se; 05-02-2019, 04:10 AM.

        • #8
          PC-DMIS 2019 R1 SP1

          Audio cues/sound cues for "feature complete/ended" plays when a wrist/angle change is placed directly after a feature PCD-164331


          - Manual mode
          - Measure a feature
          - Make a wrist/angle change
          - Measure a feature

          When executing the program above, the execution is like below:

          - Feature to measured
          - Dialog for wrist change
          - Confirm wrist/angle change
          - Audio cue for "feature complete" is played (?)
          - Wrist/angle changes
          - Feature to measure

          Tested a program that just had wrist/angle changes (no features) and the sound cue did not play after wrist change, so it seems connected to feature+wrist change.
          Last edited by vpt.se; 04-30-2019, 04:58 AM.
          PC-DMIS CAD++ 2o19 R1 SP2

          Comment


          • AndersI
            AndersI commented
            Editing a comment
            If you don't have any features, I doubt the wrist changes are executed - I believe they are postponed until that tip is actually needed (MOVE or MEAS).

          • vpt.se
            vpt.se commented
            Editing a comment
            Yes, that is correct, it just changed the previous (first) wrist change to whatever I chose, no new wrist change were added to the program. I mitigated that by putting MOVE points between each wrist change. I used this method to test the thesis above (in MAN mode).

        • #9
          PC-DMIS 2019 R1 SP1

          CMM live execution does not match graphical indicators for start/stop angle in autofeatures PCD-164332


          - Adaptive helix spiral scanning of internal diameter
          - I adjust my start/stop angles until the graphical indicators (arrows) are placed as I want (see picture)
          - Execute the scan

          Capture.JPG

          CMM should start at the purple arrow and scan clockwise up until the yellow arrow.
          However, the CMM stops prematurely, at the grey circle (probe stem from above) not completing the full scan as indicated by the arrows.
          Last edited by vpt.se; 04-30-2019, 04:58 AM.
          PC-DMIS CAD++ 2o19 R1 SP2

          Comment


          • #10
            PC-DMIS 2019 R1 SP1

            Selected scanning strategy doesn't always display in the graphic window, instead the default strategy is shown (wrong)


            - Autocircle/cylinder with any adaptive scanning strategy than the default
            - Make sure you see the correct adaptive strategy is displayed in the graphics window
            - Click OK to create the feature
            - F9 it and the default strategy is displayed instead of the selected adaptive one

            There may be a difference in how/when the default strategy is displayed. I tested with an autocylinder without measured data and the default strategy was shown on F9. After the feature was measured, I F9'd it again and the selected adaptive scanning strategy was displayed correctly in the graphics window.
            PC-DMIS CAD++ 2o19 R1 SP2

            Comment


            • Don Ruggieri
              Don Ruggieri commented
              Editing a comment
              We are not able to reproduce this one: We've created measurement routines with all the strategies and followed the instructions, Please provide more details such as any specific measurement strategy

            • vpt.se
              vpt.se commented
              Editing a comment
              Tried to trigger it but it worked as expected.

              Will add info next time it occurs.

          • #11
            PC-DMIS 2019 R1 SP1

            When an autofeature dialog is opened, the graphic display does not show the probes true position neither does it update the position of the probe if you run the machine manually (positioning the probe) PCD-164330


            Sometimes, I like to position the probe where I want the autofeature to be measured and then position the depth, offset etc. in the autofeature dialog to match the probe position. This no longer works and haven't done so since a couple of versions back. This is a real QoL setback.
            Last edited by vpt.se; 04-30-2019, 04:58 AM.
            PC-DMIS CAD++ 2o19 R1 SP2

            Comment


            • #12
              My custom header won't work in 2019 r1. I have a custom "FILE_HEADER.LBL" that I copy into the Reporting folder and this has worked every time I update to a new version. But, this time, it did not work. Any suggestions?

              Comment


              • vpt.se
                vpt.se commented
                Editing a comment
                I do this too, worked fine here. If you replace the FILE_HEADER.LBL while PC-DMIS is open, you will need to refresh the report or restart PC-DMIS.

            • #13
              Originally posted by Orizon-STL View Post
              My custom header won't work in 2019 r1. I have a custom "FILE_HEADER.LBL" that I copy into the Reporting folder and this has worked every time I update to a new version. But, this time, it did not work. Any suggestions?
              Try opening your file header label in 2019 and save over your original with 2019 schema.

              Comment


              • #14
                PC-DMIS 2019 R1 SP2

                Checking the checkbox for "RN" when evaluating position in XactMeasure does not display the "RN" on the report PCD-165692.


                Created a TP with holes in an already existing program, checked the "RN" box in the "Nominals" tab and added tolerance. "RN" does not display in the report.

                EDIT: Added screenshots.

                Edit window (tried English language to see if that made any difference):

                editwin.JPG

                Report window:
                reportwin.JPG
                Last edited by Don Ruggieri; 05-09-2019, 08:27 AM.
                PC-DMIS CAD++ 2o19 R1 SP2

                Comment


                • Don Ruggieri
                  Don Ruggieri commented
                  Editing a comment
                  I know this sounds simple but our first tests did not expose this issue. Can you prove a screen capture of the edit window and the report showing these areas please?

                • vpt.se
                  vpt.se commented
                  Editing a comment
                  Uploaded screenshots.

              • #15
                PC-DMIS 2019 R1 SP2

                Command missing a comma separating the options for TP FCF - possible future serialization errors when fixed? PCD-165335


                - Running swedish language
                - Noticed a comma was missing in the TP FCF separating the options

                Capture.JPG

                It should say

                Code:
                TOLERANSREKTANGEL/VISANOM=NEJ, VISA PARAMETRAR=JA
                but says

                Code:
                TOLERANSREKTANGEL/VISANOM=NEJVISA PARAMETRAR=JA
                Last edited by vpt.se; 05-03-2019, 02:03 AM.
                PC-DMIS CAD++ 2o19 R1 SP2

                Comment


                • SABarber
                  SABarber commented
                  Editing a comment
                  This should not be a serialization issue. This is a visual text for humans.
                  Just a note that I think this happens in all languages.
                  Last edited by SABarber; 05-02-2019, 04:19 PM.

                • Don Ruggieri
                  Don Ruggieri commented
                  Editing a comment
                  checking on both of these. . . .

                • vpt.se
                  vpt.se commented
                  Editing a comment
                  Thanks, guys!
              widgetinstance 190 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X