XMLSTATS/ON Command Without Adding Lines to Report

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • XMLSTATS/ON Command Without Adding Lines to Report

    Yello,

    I've been experimenting with using this for various SPC-ish endeavors, but I am rather annoyed that it feels the need to alert the person reading the printed report that it has been turned on and off. now my carefully arranged page breaks are all janky (and they would like this to be added to all existing programs).

    Is there a way to turn this off? I see no mention in the 'Edit Object' of stats to show or not ( like comments, alignments, etc). I took a gander in the settings editor, but found no joy...

    'Thanks anyway' in advance... :P

  • #2
    maybe somewhere in the report template itself ?

    Comment


    • #3
      I guess it needs a modification in the Rule Tree of the report template you're using:

      No_XML_in_report.PNG
      AndersI
      SW support - Hexagon Metrology Nordic AB

      Comment


      • Kp61dude!
        Kp61dude! commented
        Editing a comment
        More details on this would be great, I too wish to get rid of those pesky page break destroyer.

      • AndersI
        AndersI commented
        Editing a comment
        File -> Reporting -> Edit -> Report template, right click in the report window, click Rules in the property list, the rest is in the above picture.

      • Kp61dude!
        Kp61dude! commented
        Editing a comment
        You're the man AndersI!!!

    • #4
      Thank you, AndersI! I knew there must be some way!

      Comment


      • #5
        Okay, apparently that 'Use nothing' Checkbox became available somewhere between 2013 MR1, and 2017, as our one CMM that has 2017 is the only one with that option. that seems to be the only difference as far as that dialog box goes.

        I decided to get creative to see if I could trick it into cooperating, but not quite yet.

        With no rules applied, it seems 'Use text expression for report' is the default when you try to add a rule. I tried "" (empty quotes), but that just replaced the XMLSTATS/ON and XMLSTATS/OFF with blank lines, it's gone, but the report still gets displaced the same. I also tried deleting the "", but that didn't change anything.

        I then tried the 'Use label template for report' option by fudging an empty label file (created a new text file and renamed it "nothing.lbl"). At first I thought I was all set, as the XMLSTATS/ON line was gone and looked normal, but the XMLSTATS/OFF line seemed to be replaced with a page break (...?). There was a good three inches or so of blank space on the last page, but there was still a blank page after that. Ugh.

        So, AndersI, do you think I may have another way of doing this (other than upgrading the rest of the CMM's to current)?

        And not fernuthin, but why in the world is that the default mode for XMLSTATS commands? How is that useful to the report reader? I can see it being handy perhaps if you're troubleshooting something using XMLSTATS, and you want to see what dimensions it is/isn't grabbing - but that's if you're turning it on and off throughout the program for some reason (which I was, trying to output only Dimensions, and not the entirety of the program details, or dimensions that have no output/get skipped)

        Comment


        • Kp61dude!
          Kp61dude! commented
          Editing a comment
          Can't get this to work on 2015.1, no matter what I try it still appears on report.

      • #6
        You could write a WORD macro to find and delete this text onOpen (or trigger it automatically somehow) assuming you're using RTF output.
        PcDmis 2015.1 SP10 CAD++
        Global 7-10-7 DC800S

        Comment

        Related Topics

        Collapse

        Working...
        X