CMM won't finish booting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • CMM won't finish booting

    Our Browne & Sharp Micro Xcel PFX 454 does not seem to fully "boot-up". We had an air system loss in the facility which resulted in an air fault/error on PC-DMIS. After air pressure was restored, we were still unable to perform a machine start and operate the machine. (At this point, the jogbox & LEDs were functioning, just no response from the cmm). We shutdown both the computer and CMM for the night. We turned them on this morning and ran into an issue where all of the hand control jogbox lights turned on as well as the probe head light, however the machine start button on the hand control kept flashing and all the LEDs on the hand control remained on. The PC-DMIS software displays a "CMM not responding" message. Typically, all of the jogbox lights come on momentarily, but then some of them go off indicating the machine is ready to go. At which point, a machine start and the homing process can be started.

    Does anyone have any suggestions? The CMM power cord is plugged into a UPS with battery backup and surge protection so I don't think it is a power issue. I tried pressing the e-stop, powering down, restarting and disengaging the e-stop to no avail. I checked all of the connections, and tried unplugging & reconnecting the serial connector for the jogbox but that didn't work either. The error message is too general for me too fully understand what the issue is.

    We are running PC-DMIS 2001 for Window (ver 3.2) on Windows XP. Any help would be greatly appreciated. Thanks-

  • #2
    Do you have a tcpip link between the PC and the controller, or just a serial wiring ?
    On XP, you can try to communicate with the controller with hyper terminal (with tcpip adress or just with the com port).
    In this case, maybe CTRL+E+C+B would allow typing "status", which could help finding the problem ?
    You can also check all the wiring.
    Another problem can be also the e-stop button, inside the jogbox, which can be unplugged.

    You can also call your Hexagon local tech.

    Comment


    • #3
      Yeah definitely a communication error between controller and PC if you are getting the "CMM Not responding" message.
      If you machine isn't getting air to bearings, I would double check your air pressure sensor and solenoid valve that opens to supply air to the bearings.

      Comment


      • #4
        We have serial wiring. I haven't used hyper terminal very much but after seeing your post, I gave it a shot. I opened a connection via COM1 and tried CTRL+E+C+B, but nothing happened. I do know that the bearings are getting air because I can flip the toggles on the side of the gantry to the manual/knob adjustment option or even the hand adjustment option and the head can move freely.

        One of the first things I did was call Hexagon to get a support case going. Unfortunately due to the age of the machine, controller, and software they are currently thinking that it is a controller issue and are recommending upgrading the controller and software (which I'm assuming won't be cheap) or look into upgrading machines entirely (not easy on the pocketbook either).

        I am a bit skeptical that is the right course of action, but I could be wrong. In my opinion, losing air pressure shouldn't mean that we need to change anything, especially since it was working correctly before we lost air. The machine wasn't even in use when we lost air (it was still on though). I'm hoping there is a simple fix to the issue.

        Comment


        • #5
          On some old controllers, there are outlets for plugging a screen and a keyboard (on a sharp 32 for example).
          If it's the case, you could check if the boot works well.
          You could also try changing the com port, if the problem comes from the PC and not from the controller.

          Comment


          • louisd
            louisd commented
            Editing a comment
            If you can get away with what jeffman said, you might come to find out the controller motehrboard's silly little coin-cell clock battery is dead. That would prevent PC's of that age from booting all the time. Replace the clock battery either way, it's like a $3 test.

        • #6
          https://support.hexagonmi.com/s/arti...-1527312017152

          Details

          https://support.hexagonmi.com/servle...EMD0000000dWy0
          This is a general PC-DMIS message indicating that it has tried to communicate to the equipment it is being told to connect to, and it is not receiving a response. The first step should always be to make sure the equipment is actually on and that no connections have been severed.

          There are a number of different types of connections that Hexagon Equipment can use:
          • Network Cable (RJ-45, TCPIP)
          • Wifi
          • USB (Universal serial bus)
          • Serial Cable


          Troubleshooting steps for all connection types (except wifi):
          1. Has anything changed recently? Always start there. Otherwise:
          2. There are always two ends to any communications cord. Always check both.
          3. Turn off the computer and the machine.
          4. Check the cable for damage. Sometimes excessive bending can break wires, if you suspect this, replace the cable.
          5. Disconnect cable on one end and look at the pins. Are they straight? Clean?
          6. Check the receptacle on that end. Is it clean? Do the pins look straight?
          7. Do you have a known working replacement cable? If so, use it. If you're not sure if it works or not (came from a discard pile) DON'T try it.
          8. Reconnect the cable, and restart all devices.

          For Arms

          Typically a USB connection, try using a new USB port. This forces Windows to reinstall the drivers, and might isolate a faulty port.

          For Laser Trackers

          Typically this is caused by an incorrect network connection IP configuration. Also, check that the network cable is plugged in correctly. PC-DMIS errors with a "Machine not responding" message. How do I connect my Leica Laser Tracker?

          For CMM's

          Almost all Hexagon CMM's require serial communication as a backup to TCPIP communication. This error is usually an indication that serial communication has failed for some reason.

          If you receive a "Machine Not Responding message", you will need to verify "COM Port" settings in Windows and/or PC-DMIS. If the PC does not have any onboard Serial ports, a Serial to USB adapter cable will be needed for communications with the CMM. Verify the cable is connected and the appropriate driver for the adapter is installed. If you are using an adapter cable, you will need to go into the Windows Device Manager and verify which COM Port Windows has assigned to the adapter. PC-DMIS defaults to COM Port 1, if windows assigned a different number, you will have to go into PC-DMIS, then goto Edit, then Machine Interface Setup and change the port number. Also, depending on the CMM interface, you may need to change the Baud Rate also.

          If you still receive Machine "Not Responding" messages, go back to "Machine Interface Setup" and verify there are no conflicts in COM Ports. If there are Rotary Table tabs or OIT tabs, verify the COM Port settings for those devices are set to none or a different port then the main PC-DMIS setting for communication.



          If all else fails, please take a screenshot and submit a case with the screenshot attached.

          Comment


          • #7
            Thanks for the suggestions gentlemen. I still can't get it to finish booting. I did find that support page earlier and went through those steps. I also tried a USB-Serial adapter and have tested the serial ports on the computer using a loopback device and hyper terminal. Everything checks out on the computer side.

            As for the controller, we have an FBPC controller. I opened the enclosure door, and checked the connections in there. There are two led lights lit up on the controller board, one labeled D500 DIAG and the other D101 PWR. Both are on solid. When I put a serial cable tester on the cables running from the controller to the PC, I get lights indicating there is power/signal to the pins, but no data being transferred.

            All signs seem to indicate the something is causing the controller to lock up and prevent it from fully booting. I'm beginning to wonder if there is something wrong with the sensor that monitors air pressure. Maybe it's sending (or not sending) some sort signal the controller is expecting during startup.

            I'll post updates as things develop for anyone who may have a similar issue.

            Comment


            • #8
              I've had some additional suggestions saying that it is a controller issue. Apparently a solid diagnostics light is not normal, it should blink. However since the distribution board has a solid green power light and gets its power from the 24V power supply, I'm thinking/hoping that it is okay. I'm wondering if it may be the CPU power supply or the CPU board. The controller is all apart and it does seem to be the CPU power supply. Voltage readings from the power supply don't seem right. I was expecting 5v and 12v. There is one capacitor that partially blew out and another that is pretty swollen. Hopefully replacing the caps will solve the issue. If not, the next step might be to wire up an external power supply, if I can find a reliable pinout source. I've seen some conflicting information (one states +12.5v while another lists -12V).

              Comment


              • #9
                Final update: It was the CPU power supply. We had it replaced and works like a charm now. Thanks for everyone's input.

                Comment

                Related Topics

                Collapse

                • scanner
                  Dead in the Water
                  by scanner
                  Yesterday a co-worker was programming offline on our B&S Global and the CMM kicked out. Tried machine start button but it will not restart. Did...
                  06-30-2008, 08:13 AM
                • boximus
                  Machine Start Issue
                  by boximus
                  I'm having some trouble getting the CMM to perform a machine start. After shutting down the system and power, and restarting everything (Computer, CMM,...
                  10-24-2014, 10:17 AM
                • jtrofatter
                  PHC10-3 wont power on
                  by jtrofatter
                  Earlier today we had our maintenance team replace the air lines connected from the X axis to the Z axis on our very old Brown and Sharpe MicroVal. After...
                  07-11-2018, 01:00 PM
                • Corsair
                  CMM not responding.
                  by Corsair
                  We just downloaded 3.5MR2 (follow Matt advise).
                  Now, it seems that the air do not wants to kick in,we have a PCH9 MK 2 controller.Any suggestions...
                  10-04-2006, 12:09 PM
                • Ben1989
                  Machine Motor Won't Enable
                  by Ben1989
                  Hi guys,

                  Sorry to come on here with mechanical/machine issues but I'm going crazy as to why our CMM's motor won't enable. You'll have to...
                  02-21-2017, 08:47 AM
                Working...
                X