2018 R2 released!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I have not seen anything like this, no. I am not saying the software is perfect, and I am sorry you are having such problems. I will be glad to investigate if you would start by sorting it out. Pick one such issue and make a short video so I can try it here. Add some detailed instructions, send me your PRG and PRB, whatever is required for me to see the same issue. If I can repeat it I will certainly try to find out what is wrong and enter it into our tracking system.

    Comment


  • Don Ruggieri I want to make a note, the two comments I posted above only seem to be affecting my offline seat. Auto Features and MSE work great online.

    Comment


    • thank you, let me see if I can make any sense of it

      Comment


      • bfire85 What SP are you running when this happens? I have an offline station here that I can try on.
        PC-DMIS CAD++ 2o18 R2 SP4

        Comment


        • Originally posted by vpt.se View Post
          bfire85 What SP are you running when this happens? I have an offline station here that I can try on.
          Latest...SP4

          Comment


          • vpt.se
            vpt.se commented
            Editing a comment
            Tested opening, closing MSE, no crash. Tested autofeatures, opened and closed both with close button and the [x], tried all autofeatures - no crash.

            Tested on x64 Win10 Enterprise version 1709, build 16299.75, 32gb RAM, nVidia Quadro M3000M (Dell Precision 7710).

            PC-DMIS CAD++ 2018 R2 SP4 build 293.

          • bfire85
            bfire85 commented
            Editing a comment
            I'll uninstall the software and reinstall it and see if that makes a difference.

        • Don Ruggieri vpt.se OK. I got MSE to work. What I did was copied "my MSE defaults".MSExml file from 2018 R1 ProgramData folder into the 2018 R2 ProgramData folder. Obviously, PC-DMIS did not like that all too well. I did the same for 2019 R1 and MSE opened, but when I went to save my defaults, that is when it crashed. Now I have a question, do I need to edit the MSE defaults to my liking for every release or is that something that should transfer with the Settings Editor?

          Comment


          • vpt.se
            vpt.se commented
            Editing a comment
            From a users perspective, you should not have to edit the XML for each release (just like you shouldn't have to redo the window layouts each time), but this should be one of the files that the Settings Editor should transfer (the window layout files as well).

            If these by any chance should differ, then the errorhandling in the code that does the XML-parsing must (should) take care of this and prevent a possible software crash. Now, if you have both the original MSE defaults.XML and the one with your settings, it would be interesting to see WHAT differs between them and if that could be the culprit making PC-DMIS crash.

            Doublecheck your XML so it isn't read-only or similar first, preventing PC-DMIS from saving to it.

          • bfire85
            bfire85 commented
            Editing a comment
            vpt.se My customized MSE file is not Read Only. I manually transfer it to the 2018 R2 folder and MSE crashes. I remove it, and MSE works great.
            Don Ruggieri Are we supposed to be able to automatically/manually transfer our customized MSE file between versions or are we supposed to recreate all our presets everytime?

          • vpt.se
            vpt.se commented
            Editing a comment
            Can you make both XML-files available here for download?

        • Might as well hijack this thread for a minute..

          How is SP4? We have 2018 R2 release and I wanted to update.

          Specifically I'm looking at this issue from SP4:
          Code:
          PCD-152124 - The Insert rotary table move has to be able to insert the angle unconditionally. The ending angle of the previous 4-axis scan differs from the theoretical.
          I would like to know what this translates to, because I have a rotary.

          As well as this issue from SP3:
          Code:
          PCD-135514 - Ring light intensity migration will now only be attempted for features where the top and bottom lights are not in use.

          Comment


          • Another one to add....what the heck is this? I create a new circle and it links my previous one to it? Large bore was created, then I create another circle (smaller one), but it shows the hits from the previous circle along with a path line to the new one! If I play with the sample hit toggle, it goes away, but adds move points before the feature in my edit window. If I close the auto feature (without creating it) and re-open a circle, it's back to normal. Holy time waster Hexagon! Running 2018 R2 SP4 Offline Mode.

            2018R2_WTF.PNG

            Comment


            • Added a copied autofeature with manually changed THEO's and TARG's still uses the copied (source) features THEO's/TARG's for graphical representation AND execution!

              Updated
              https://www.pcdmisforum.com/forum/pc...917#post436917 with another occurence of the "adaptive-autoplane-freeform-scanpath-generation-doesn't-generate" problem.
              Last edited by vpt.se; 01-11-2019, 08:52 AM.
              PC-DMIS CAD++ 2o18 R2 SP4

              Comment


              • Originally posted by vpt.se View Post
                Toolbars does not save changes. Dammit. At least the layout bar is gone.
                I was told that this is officially going to be fixed in SP5, which should be released in a couple of weeks.

                Comment


                • Originally posted by bfire85 View Post
                  Another one to add....what the heck is this? I create a new circle and it links my previous one to it? Large bore was created, then I create another circle (smaller one), but it shows the hits from the previous circle along with a path line to the new one! If I play with the sample hit toggle, it goes away, but adds move points before the feature in my edit window. If I close the auto feature (without creating it) and re-open a circle, it's back to normal. Holy time waster Hexagon! Running 2018 R2 SP4 Offline Mode.

                  2018R2_WTF.PNG
                  I would verify the following menus and make sure they are all unchecked. Most likely you have "with feature creation" selected. The first thing I would check is if "quick path" has been enabled. If it is disable it.

                  qp.jpg


                  If it is not go to the menu and verify none of the options are selected.




                  moves.jpg

                  Comment


                  • 2018 R2 SP4 issues...

                    *
                    After installation of the 2018 R2 SP4 update, the "tolerance limits" and "lines between points" option is activated in the analysis window - although they never were activated in the programs. This affects the graphical display of profile evaluations. Another irritating issue, that was fine and now isn't. Again. It can't be deactivated through any other way than going through the analysis window. [s]Could we please get some extended internal bug-hunting prior to the releases?[/s] Not an issue in SP3, started with SP4.
                    Last edited by vpt.se; 01-14-2019, 10:48 AM.
                    PC-DMIS CAD++ 2o18 R2 SP4

                    Comment


                    • Originally posted by rjurca View Post

                      I would verify the following menus and make sure they are all unchecked. Most likely you have "with feature creation" selected. The first thing I would check is if "quick path" has been enabled. If it is disable it.

                      qp.jpg


                      If it is not go to the menu and verify none of the options are selected.




                      moves.jpg
                      Thanks. That has seemed to stop the issue I was seeing. Why is this even a default if it has never been on before? I understand the benefit of Quick Path for the users that use Quick Features, but that just confused me because I never use the feature.
                      Last edited by bfire85; 01-14-2019, 12:18 PM.

                      Comment


                      • It is not supposed to be on by default. I reset my computer and check on my end.

                        Comment


                        • Updated https://www.pcdmisforum.com/forum/pc...917#post436917 with more info regarding no scanpath generation.
                          Last edited by vpt.se; 01-18-2019, 07:19 AM.
                          PC-DMIS CAD++ 2o18 R2 SP4

                          Comment


                          • davehocum
                            davehocum commented
                            Editing a comment
                            There definitely is a problem with a software when the posts are about tracking and following the posted issues.

                          • bfire85
                            bfire85 commented
                            Editing a comment
                            There's definitely a problem when a release has a thread that is 8 pages and counting.

                          • vpt.se
                            vpt.se commented
                            Editing a comment
                            We all know there are problems. I am just waiting for the fixes within a reasonable amount of time - and the fixes shall NOT break anything needing additional fixes.
                            There are much work to be done in that area.

                        Related Topics

                        Collapse

                        Working...
                        X