Datum Shift

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Datum Shift

    Wondering if there is a way to turn off the Datum Shift in XactMeasure reporting? Or better way to put it is to just remove it from the report.

    DatumShift.jpg

    I know what it is, just want to take it off the report to clean it up and avoid confusion.

    Thanks

  • #2
    I think the only way to do this is to edit the position lbl template, which gets into the whole nightmare that is report customization since the great fourhead break with hyperreporting. The stinkiest part IMNSHFO is no good easy way to turn it on/off except via changing the template, which means you can't have some in the report that show the shift and others that don't. Maybe there is a better way with some of the newfangled versions.

    sigpic"Hated by Many, Loved by Few" _ A.B. - Stone brewery

    Comment


    • #3
      If you are looking to remove the label on a one by one basis, you can right click and "Hide Selected Label". This type of report modification gets saved with the program and is pretty easy to do. You'll have to refresh the report after hiding so that everything shifts up in the empty space.

      If you want something more global, its a single line edit to the report template. In File | Reporting | Edit | Report Template, select TextOnly. Right Click on the page, and choose Rule Tree from the properties bar that shows up.

      Delete the selected line, and you'll never see Datum Shift again (or at least until you update, and we overwrite your edited TextOnly.rtp file)

      DatumShiftRule.png

      Edit: I wanted to note that this doesn't change the result. Datum Shift is still applied, by removing the rule you are just telling the report not to display it.
      Last edited by mkopesky_; 03-28-2018, 05:17 PM.

      Comment


      • #4
        Originally posted by mkopesky_ View Post
        If you are looking to remove the label on a one by one basis, you can right click and "Hide Selected Label". This type of report modification gets saved with the program and is pretty easy to do. You'll have to refresh the report after hiding so that everything shifts up in the empty space.

        If you want something more global, its a single line edit to the report template. In File | Reporting | Edit | Report Template, select TextOnly. Right Click on the page, and choose Rule Tree from the properties bar that shows up.

        Delete the selected line, and you'll never see Datum Shift again (or at least until you update, and we overwrite your edited TextOnly.rtp file)

        DatumShiftRule.png

        Edit: I wanted to note that this doesn't change the result. Datum Shift is still applied, by removing the rule you are just telling the report not to display it.

        That looks like just what I need. Thanks!

        Comment


        • #5
          Originally posted by John Kugler View Post
          Wondering if there is a way to turn off the Datum Shift in XactMeasure reporting? Or better way to put it is to just remove it from the report.

          DatumShift.jpg

          I know what it is, just want to take it off the report to clean it up and avoid confusion.

          Thanks
          Hi John,
          I don't use XactMeasure but I wonder if you turn FIT TO DATUMS=OFF? (Since no modifiers on your datums)
          Will Datum shift still showing?
          sigpicIt's corona time!
          737 Xcel Cad++ v2009MR1....SE HABLA ESPAƑOL

          Comment


          • tking
            tking commented
            Editing a comment
            Nice!

        • #6
          Originally posted by Roberto View Post

          Hi John,
          I don't use XactMeasure but I wonder if you turn FIT TO DATUMS=OFF? (Since no modifiers on your datums)
          Will Datum shift still showing?
          That works as well. I think you are right, since no modifiers on the datums, turning this off will give me what I want without messing anything up.

          Thank you for the assist.

          Comment


          • #7
            Thanks Mkopesky! If I ever knew I could right click in the report and hide things, I had forgotten. Great Tip!

            Originally posted by Roberto View Post
            Hi John,
            I don't use XactMeasure but I wonder if you turn FIT TO DATUMS=OFF? (Since no modifiers on your datums)
            Will Datum shift still showing?
            Howdy Roberto,

            One of the ways XactMeasure aims to be an improvement over legacy is assuring compliance to the standard, or at least notifying an alert pc-demon-jockey that they have chosen to go off the reservation with the approach they are using. In the version I am currently running, (2015.0 (Release) SP5), you must change the standard from ASME Y14.5 to custom in the Feature Control Frame tab or else the FIT TO DATUMS tick box is grayed out in the Advanced tab and you do not have the option to turn it off. This is because by turning it off you may no longer be interpreting the FCF per the standard.

            HTH
            sigpic"Hated by Many, Loved by Few" _ A.B. - Stone brewery

            Comment

            Related Topics

            Collapse

            Working...
            X