V3.7 MR3 bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • V3.7 MR3 bug

    Here is a new bug for ya.....

    When using CAD=PART alignments, if you have to change an offset, or anything else in the alignment, you have to go and click on CAD=PART twice to get it to accept the change and 'update' the alignment and cad relationship. This includes slight adjustments for the offsets for balancing alignments to fixtures or parts or what ever. You have to do CAD=APRT twice, it has NO effect the first time you click on it. This only applies to changes made to an alignment after it is done. This could really bite your rump, so anyone who used regular alignments and has had the need to tweak those alignments, watch it.

    Gee, I wonder what got changed in the software to make this bug pop up? In all my years working with Pcdmis, this has never before been a problem, so why now? I guess some new programmer didn't like the flavor of Pcdmis too well, so he had to take a leak in it himself to make it to his liking.
    sigpic
    Originally posted by AndersI
    I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

  • #2
    Hello Everyone,
    I have accepted a programming position at another company and they are running 3.7. The evening programmer doesn't know of any mr's added. So, my question to everyone is:
    Is 3.7 stable without the mr's added. He said that he does not have any problems.
    I will be out there in 2 weeks and don't care for any pc dmis surprizes.

    A.Gore
    sigpicA.Gore

    Comment


    • #3
      Matt

      Is this issue/bug just in 3.7 mr3 or all 3.7's?

      How did you catch it? It must have been a large enough offset or you just checked it to be sure right after the c=p command?

      I have in the past been successfull with 3.5mr2 doing alignment changes and doing another cad=part just once
      sigpiccall me "Plum Crazy"....but you only go around once!

      Comment


      • #4
        This could be a major problem for folks that tweak Fixture alignemtns (TB's, and such).
        Glad you caught that one Matt.
        And thanks again for letting us know.
        I really don't want to get on another BnS rant...
        <soapbox> start
        GRRRRR
        <soapbox> end

        Kev
        RFS Means Really Fussy Stuff

        When all you have is a hammer - everything looks like a nail....
        sigpic

        Comment


        • #5
          I do not know about 3.7, MR1, or MR2, I never even downloaded them. I caught it because I had 2 holes for the rotation datum that were NOT square to an axis, but at a 0.5 degree angle. When I did my alignment,

          LEVEL
          ROTATE
          ORIGINS
          ROTATE-OFFSET 0.5 degrees
          OFFSET ORIGINS

          I used the wrong angle, I used positive not negative, so the 2-way hole didn't line up, and with them being about 1500mm apart, it was quite obvious. When I chaged the rotation offset to -0.5, then did the CAD=PART, nothing changed. I did it again, and it updated to the correct position.
          Yes, I know I could have done an iterative alignment, I prefer not to use them as long as I have a flat datum plane. I can easily enough rotate the rotate to get them in line. And yes, there are other ways of doing it NOT using the iterative alignment, but I still prefer my way, just like ALL OF US do. And, my way found a BUG that might bite one of YOU at some time. I still do things OLD SCHOOL, like from back in the DOS days of Pcdmis, way back when you had to have a PLANE and a LINE and a POINT to make an alignment, none of these fancy-schmancy new-fangled options that all you whipper-snappers like to use!
          sigpic
          Originally posted by AndersI
          I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

          Comment


          • #6
            Originally posted by Matthew D. Hoedeman
            fancy-schmancy new-fangled options that all you whipper-snappers like to use!
            man, Are you retiring soon? (j/K)

            Kev-Whipper
            RFS Means Really Fussy Stuff

            When all you have is a hammer - everything looks like a nail....
            sigpic

            Comment


            • #7
              LOL..... I hope I can soon!!!
              sigpic

              Comment


              • #8
                Man, that would be a sorry day for all you schlubs out there! Whose jokes would you read on Friday and who would give you all those nice little tips and hints, etc., etc., etc.

                Heck, with the way the gov't is messing up OUR so-so-security, unless you are within 5 to 10 years of retiring, you ain't gonna see none of it anyway, so all y'all be here 'til ya die anyway so why worry, have a beer (or 2 or 3 or 4 or 5 or 50).
                sigpic
                Originally posted by AndersI
                I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

                Comment


                • #9
                  One kid thru college one left (2 more years) with no loans, guess who's pay'in. I'll be work'in till the reaper "retires" me. Stick around for a while, Matt.

                  Let me know if you ever make it over to the GR area, I could probably have a homebrew wait'in for ya.

                  TK
                  sigpicHave a homebrew

                  Comment


                  • #10
                    Heck, with the way things are going in Lansing, I may be looking for a job somewhere else, like GR. One day, I may be in looking for work!
                    sigpic
                    Originally posted by AndersI
                    I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

                    Comment

                    Related Topics

                    Collapse

                    • Craig H
                      3.7 MR3 bug?
                      by Craig H
                      Hello,
                      I think I found another bug, I am doing a manual alignment and I am using the quick start 3-2-1 alignment with the preview window open and...
                      07-24-2006, 10:50 AM
                    • Mark Farren
                      CAD=PART
                      by Mark Farren
                      Anyone had any problems using CAD=PART in ver. 3.7 mr2? I did it the other day and it changed all my move points and rendered the program useless...
                      03-28-2006, 02:18 PM
                    • MichiganMan
                      3.7 or 4.2MR1
                      by MichiganMan
                      Currently running 4.2 MR1 and do not have any real problems that bother my programming. I talk to (many) other companies and they say they will not run...
                      03-31-2008, 06:58 AM
                    • richs20a
                      Iter Align Q and Also Cad = Part
                      by richs20a
                      Fellas, I apologise for an earlier post. Working long hrs and frustration I could not really put pen to paper properly, Here's my questions with beter...
                      08-10-2008, 06:49 AM
                    • AuRules
                      3.7 n.i.s.t.
                      by AuRules
                      Boss ask me this morning was 3.7 MR3 N.I.S.T or PTB certified. Does anyone know?

                      We was hit on a internal audit....
                      05-15-2012, 06:25 AM
                    Working...
                    X