Mirror Programs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mirror Programs

    Good day all. New problem here for me. It's been many years since I've used mirroring to create a left hand part from a right hand one. I use read point but not that this should matter. This is all off line CAD programming with 2014.1 CAD++. I did the mirror in X and ran the program offline. All is well as it should be. When I take it on line at the CMM it doesn't follow the path it should but goes off to the right rather than the left. Any ideas anyone? Am I missing something here? Any help or suggestions would be most appreciated.

  • #2
    Are you sure you have the mirrored program @ the CMM? I don't recall any issues with mirroring, except for the fact that most probe angles don't mirror and need to be edited to reflect the opposite hand.

    Comment


    • VinniUSMC
      VinniUSMC commented
      Editing a comment
      Newer versions of PC-DMIS do this better. 2017 still gets confused by car body if you don't use the F5 Part/Machine settings, but after an alignment, it seems to get it right most of the time.

  • #3
    sealevel,
    yes i do have it mirrorred at the cmm, it just wants to go in the wrong direction .

    Comment


    • #4
      Do you use the F5 Part/Machine axis settings?

      What version of PC-DMIS? Did you have to select CAD axis and Machine axis to mirror over?
      "This is my word... and as such is beyond contestation."

      Comment


      • #5
        Originally posted by VinniUSMC View Post
        Do you use the F5 Part/Machine axis settings?

        What version of PC-DMIS? Did you have to select CAD axis and Machine axis to mirror over?
        I am using 2014. 1 CAD++.

        I do not use F5 and when I check the part/machine settings it states that CAD X+=machine X-. Y+=Y-, and Z+=Z+ This should only be a mirror in X not Y but when I try to change Y- to Y+ I get an axis error message and all jumps back to + on all axes.

        Comment


        • #6
          Originally posted by Jim Poehler View Post

          I am using 2014. 1 CAD++.

          I do not use F5 and when I check the part/machine settings it states that CAD X+=machine X-. Y+=Y-, and Z+=Z+ This should only be a mirror in X not Y but when I try to change Y- to Y+ I get an axis error message and all jumps back to + on all axes.
          PC-DMIS has to abide by the right hand rule, it won't let you break that. Are the axes correct in the original program? (Meaning X+=X+, Y+=Y+ and Z+=Z+?) I rarely use the F5 settings, so most of my mirrored programs the F5 axes don't change. That tells me something funky happened.

          I skipped 2014, so I'm not sure if it has any weird stuff going on.

          Does 2014 have the 3 axis selection questions for mirroring? (Part mirror axis, reporting mirror option, and machine mirror axis)
          "This is my word... and as such is beyond contestation."

          Comment


          • bigtallanddopey
            bigtallanddopey commented
            Editing a comment
            I was just about to ask about that with the 3 axis selection.

            I know that with my parts which are automotive I mirror the part in Y. However because of they way they sit on the CMM I have to mirror the machine in X could well be a problem there.

        • #7
          Yes Vinni, I do have those 3 options. I just noticed in the original right hand part that the mirror option for machine axis is defaulted to mirror in y. I guess I only looked in ;the part mirror axis and changed that to x. Perhaps I need to try changing the machine mirror axis to x rather than y. Can't hurt if I test it out REAL SLOW. Will update when I get a chance to try this.

          Comment


          • VinniUSMC
            VinniUSMC commented
            Editing a comment
            Yes, you have to mirror CAD in the appropriate axis, and mirror it on the machine in the appropriate axis.

            If you mirror the part setup on the machine left to right, then X. If you mirror it front to back then Y.

        • #8
          I do not use F5 and when I check the part/machine settings it states that CAD X+=machine X-. Y+=Y-, and Z+=Z+ This should only be a mirror in X not Y but when I try to change Y- to Y+ I get an axis error message and all jumps back to + on all axes.

          Problem has been solved. I just went into F5 and reset all the machine parameters to where they normally are X+,Y+,Z+. Works like a charm now. Thanks all for the help.
          Last edited by Jim Poehler; 10-16-2017, 02:40 PM. Reason: wasn't done with my comments and the window closed on me.

          Comment

          Related Topics

          Collapse

          Working...
          X