Moving away in the z-axis first instead of x-axis

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Moving away in the z-axis first instead of x-axis

    Hey guys!

    Whenever I move to a clearplane at the end of a program and then move to a point, for example x0 y200 z200, my machine always moves away in the x/y-axis first.
    But I want it to move away in the z-axis first. I could do it with an increment move but I don´t want to insert that every time.
    Is there a setting, maybe in the settings-editor (thats what it´s called in german, I don´t know the exact english translation but I hope you know what I mean) where I can change that?

    Thanks in advance!
    Last edited by Stbasser91; 09-15-2017, 03:09 AM.

  • #2
    Have tried cancelling the clear plane before the move point ?

    Comment


    • #3
      You can change clearplane from Zplus to Xplus.

      Move points are generally much more efficient ways to get the CMM to where you want it.
      "This is my word... and as such is beyond contestation."

      Comment


      • #4
        The move in X and Y first doesn't sound like a clearplane move - if you have your clearplane set to XPLUS/MINUS or YPLUS/MINUS, it should only move in that single axis, not both.

        Sounds to me like the last feature measured is an auto feature using an avoidance move either AFTER or BOTH.

        Comment


        • #5
          I mean the movepoint AFTER a clearplane.

          CLEARP/ ZPLUS,10,ZPLUS,0,ON --> Clearplane is set to Z+
          MOVE/ CLEARPLANE --> Machine is moving from the last feature to the clearplane in Z+
          MOVE/POINT, NORMAL, <0.000,200.000,200.000> --> Machine is first moving to x0 and y200 at the same time. Then it moves up to z200.

          I want to change the order the machine moves the axis after i moved to the clearplane. First z-axis, then x/y-axis.

          Comment


          • VinniUSMC
            VinniUSMC commented
            Editing a comment
            I've never seen this sort of action. A move/point should move directly to the move point, in a straight line from the current position. You're saying that this is not happening?

            What CMM and Controller do you have? That might be the problem.

          • Stbasser91
            Stbasser91 commented
            Editing a comment
            It only moves straight to the move point under certain circumstances. For example when I don´t have a clearplane command between a feature and a movepoint.
            I have a DEA Global 05-07-05.
            What exactly do you mean with the controller? If you were german I would probably know what you mean

          • VinniUSMC
            VinniUSMC commented
            Editing a comment
            The controller is the big electrical box that the CMM connects to. It might be a big box on the floor, or a box hooked to the back of your desk. It will have a big bundle of wires and hoses running out of it to the CMM and to the Probe Head Controller and PC.

        • #6
          Originally posted by Stbasser91 View Post
          I mean the movepoint AFTER a clearplane.

          CLEARP/ ZPLUS,10,ZPLUS,0,ON --> Clearplane is set to Z+
          MOVE/ CLEARPLANE --> Machine is moving from the last feature to the clearplane in Z+
          MOVE/POINT, NORMAL, <0.000,200.000,200.000> --> Machine is first moving to x0 and y200 at the same time. Then it moves up to z200.

          I want to change the order the machine moves the axis after i moved to the clearplane. First z-axis, then x/y-axis.
          It shouldn't be doing this, you have something else going on.

          Are you in command mode? If so, switch to summary mode, then switch back and see if there's a move in there. Sometimes they're hidden, this will make it visible again.

          Otherwise, a workaround (this shouldn't need to be done, as I said, something else is going on) is to simply change your CLEARP line immediately before the last MOVE/CLEARPLANE to ZPLUS,200

          As an aside, I've never trusted the CLEARP command to properly differentiate between a clear plane and a pass through plane, many years ago I had this screw up on me once, but that was all it took. However, to get to the point, I always set my clearplane and pass through planes to the exact same value, i.e. CLEARP/ ZPLUS,10,ZPLUS,10,ON. However, I've been accused of being old fashioned since I almost never use clearplane moves anyway, so take that FWIW.

          Comment


          • Stbasser91
            Stbasser91 commented
            Editing a comment
            I couldn´t find any hidden moves by switching back and forth.

            I told the problem my PC-Dmis "guy". He also had never seen that kind of behaviour from a machine before.

            I mean, I can work with it, but don´t we all want it to work as smooooothly and easy as possible?

        • #7
          What is the last feature being measured in this program? Can you post the code?

          If it's an outside diameter with an avoidance move set close to the clearplane value, it will move almost exactly as you're describing.

          Comment


          • #8
            It happens with every feature.With and without avoidance moves. It doesn´t matter if it´s a point,diameter outside/inside, auto-feature or whatever. So it doesn´t has anything to do with the code.
            It must be a general problem that is hidden in the setting editor.
            I only noticed the flaw because the machines at other companies don´t behave like that.

            Comment


            • RandomJerk
              RandomJerk commented
              Editing a comment
              There are no flaws, only undocumented enhancements.

          • #9
            Originally posted by Stbasser91 View Post
            I mean the movepoint AFTER a clearplane.

            CLEARP/ ZPLUS,10,ZPLUS,0,ON --> Clearplane is set to Z+
            MOVE/ CLEARPLANE --> Machine is moving from the last feature to the clearplane in Z+
            MOVE/POINT, NORMAL, <0.000,200.000,200.000> --> Machine is first moving to x0 and y200 at the same time. Then it moves up to z200.

            I want to change the order the machine moves the axis after i moved to the clearplane. First z-axis, then x/y-axis.
            Stbasser91,
            The behavior you are seeing is normal because there is no feature between the MOVE/CLEARPLANE and the MOVE/POINT.
            Unless this behavior has changed in newer versions (I tested it with v2009).

            If you want to try this, make the probe to go up in Z+ before the Move/point (Go slow).

            Code:
                        CLEARP/ZPLUS,200,ZPLUS,200,ON
                        MOVE/CLEARPLANE
                        MOVE/POINT,NORMAL,<0,200,200>
            sigpicIt's corona time!
            737 Xcel Cad++ v2009MR1....SE HABLA ESPAÑOL

            Comment


            • RandomJerk
              RandomJerk commented
              Editing a comment
              Happy to see someone else sets clear and pass through to the same values, thought it was just my quirk.

          • #10
            A thought just popped into my head. The experience is rare enough that it startled me, but once I calmed down...

            This is supposed to work. I've had mixed success with it.

            MOVE/POINT,NORMAL,<,,200>

            there are no typos there. The idea is if you leave the values blank (not zero), PC-DMIS is supposed to recognize that no move is to occur in that axis.

            Try at your own risk.
            Last edited by RandomJerk; 09-15-2017, 12:40 PM. Reason: It was too easy

            Comment


            • DJAMS
              DJAMS commented
              Editing a comment
              ^^ This makes me believe that suggested command is still not understood. It means:
              Stay where you are in X
              Stay where you are in Y
              Move to z=200 in the acctive alignment.

              It is completely different from an incremental move. I use it all the time. It's a time saver.

            • Stbasser91
              Stbasser91 commented
              Editing a comment
              So I tried your way and you´re totally right. It is a time saver.
              Thats what I needed!

            • DJAMS
              DJAMS commented
              Editing a comment
              Great! It sounded to me like this is what you needed. And we had a really hard time explaining to the Hexagon that it was different from an incremental move when we made the request for this capability.

          • #11
            Hope you're still looking at this thread, I found something today that may or may not be a cause.

            Edit...Preferences...Parameters. One of the tabs says Clear Point. What's yours set to?

            ClearPoint.png

            Comment


            • DJAMS
              DJAMS commented
              Editing a comment
              This only applies to the MOVE/CLEARPOINT command. You can use this to define a "park position" - like a common place to move at the end of a program. Nice, because it's defined in machine coordinates. Same spot no matter where you setup the part on the table. At the same time, it's awful because it is a user based setting, which means it isn't the same for all users that log onto the computer. An inexcusable error in the design.

              We"ve cobbled together a way around the design flaw, and use it at the end of programs to move machine to spot that allows hoist acces to load/unload parts.

          • #12
            Originally posted by RandomJerk View Post
            A thought just popped into my head. The experience is rare enough that it startled me, but once I calmed down...

            This is supposed to work. I've had mixed success with it.

            MOVE/POINT,NORMAL,<,,200>

            there are no typos there. The idea is if you leave the values blank (not zero), PC-DMIS is supposed to recognize that no move is to occur in that axis.

            Try at your own risk.
            I've also had mixed success. It seems that when you have to edit the program and change the reference frame or maybe a feature used in a reference frame, PCDmis thinks its being helpful to ADD
            0's (zero's)
            to the blank spots!
            I'd like to variabilize them to lock them down but that would have to be like an NA or Null value... are there any such that would work?
            "It ain't those parts of the Bible that I can't understand that bother me, it is the parts that I do understand." Mark Twain

            Comment


            • RandomJerk
              RandomJerk commented
              Editing a comment
              I hadn't thought about it, but I'm wondering if creating a null sring may work, i.e.

              ASSIGN/NULLSTRING==""

              MOVE\POINT,NORMAL,<NULLSTRING,NULLSTRING,200>

            • Kevo_cmm
              Kevo_cmm commented
              Editing a comment
              RandomJerk :-) good idea, I'll look for a chance to give it a try.

          Related Topics

          Collapse

          Working...
          X