Error when qualifying

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when qualifying

    So here's the error I get:

    ERROR PI ,S%1 ,TR_PI , 0x1200001a Command argument has an invalid value
    .

    This is happening when trying to qualify a very long probe (see attached) extProbe1.png



    The probe without the extension qualifies with no issue, but this won't even start, I get the above error. I was concerned it was the distance along shank vector, reduced that, but that did nothing.

    Anyone seen this? Any ideas? This is a probe for an older program, I don't use the long extension.

    Thanks

  • #2
    Do you even have enough Z clearance for this to qualify on the sphere? What version did you last run it on?
    (In Memory of my Loving wife, "Ronda" who I lost March 7, 2016. I love you baby.)
    They say "Nobody's Perfect." I must be Nobody.

    Comment


    • #3
      It seems that the probe is about 600 mm long + about 200 mm of shank qual tool + some mm for the tesa star sm...
      There is not much left for the safety distance along the shank (if you're measuring on the Global or the Sheffield).

      Comment


      • #4
        Look at this :
        http://www.pcdmisforum.com/forum/pc-...rror-on-global
        and this file :
        Attached Files

        Comment


        • RandomJerk
          RandomJerk commented
          Editing a comment
          Interesting... TTBOMK, this is the original computer, original software install, so there's been no change there, and it qualifies PROBE_1 no issue. Gonna have to go down there, again, to look at the manretract issue.... It should never have been changed, but stranger things have happened.

      • #5
        I have 9'' between top of sphere and EOT in Z, so that's not the issue.

        Comment


        • #6
          I was getting a similar error when calibrating tips much shorter than that, but it seemed to correlate with a few particular angles. First they would fail because an air hit or two would be taken while doing the first DCC 'find hits', throwing the calculated center position out of whack, so the first equator hit would collide. I would then have to recaibrate that (or those angle(s) afterward separately, and do the manual hit with 'No, the tool hasn't moved' for it to successfully calibrate. But then, it would give the 'command argument...' error as it took a few of the hits, but seemed to continue normally. I noticed that I often had to reset the offending angles for them to work normally. I was inclined to scrap and rebuild the probe file, but selecting 'reset tips to Theo at start of calibration' seemed to make the issue disappear completely...

          Not sure if any of that applies to you, is this a probe you just built, file and all, or one already in use?

          Comment


          • #7
            What version is this? Service pack" What type of controller?

            If this is an FDC controller, I have a suspicion it is related to an issue already fixed in versions 2017 R1, 2016 SP5, 2015.1 SP8.

            Comment


            • #8
              Update - turns out this is actually an old problem I had already worked through. These probe files hadn't been worked with since I got here, the move speed in the probe file was 254mm, which I learned must be changed to 250mm. I had completely forgotten about it until modifying MANRETRACT didn't work.

              Thanks for the help, though

              Comment


              • #9
                That's a mighty long probe, probably exceeds the recommended manufacturers specs but I won't act like I've never dishonored them before.
                PcDmis 2015.1 SP10 CAD++
                Global 7-10-7 DC800S

                Comment


                • RandomJerk
                  RandomJerk commented
                  Editing a comment
                  I double checked myself, it's within range. The probe extension fits to the head, then the probe itself to that, and the stylus is within range. I'm not a fan of it, but I haven't tested it, either.

                • Kp61dude!
                  Kp61dude! commented
                  Editing a comment
                  Vertical: Up to 225mm
                  Horizontal: Up to 50mm
                  Max Stylus weight: 33 g (incl. stylus clamping)
              widgetinstance 190 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X