move/point and graphic window problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • move/point and graphic window problem


    Hello everybody.

    I was used to use MOVE/POINT in program mode with PC-DMIS 2016 to see where my probe was in the graphic window.
    With program mode activated I had to click F9 on MOVE/POINT than ESC or OKAY from the 'MOVE' window and the probe was positioned right at the coordinate x,y,z wrote in the program.

    Now I've update to PC-DMIS 2017 and this function doesn't work any more.
    Have Somebody a solution for this problem?

  • #2
    Put an operator comment just after the move to pause the execution to get the visual.
    sigpicHave a homebrew

    Comment


    • #3
      If I use that method every time to insert a move/point and looking if I put it right, I spend too many time to make a program.

      I know my method is not so used, but when I program I'm used to check the position of the probe every time I insert a move/point. Since I use this trick I am 99% sure to not collide the probe against the measured piece.
      I find it very useful, and now without it I'm going to loose my brain every time I make a program.

      Comment


      • tking
        tking commented
        Editing a comment
        Put it at the end of the code you're generating, it's always there to halt the execution, if you're good to go keep adding code just above the "halt". Works for me so whatever ...................................

    • #4
      CTRL+E on the move point. you'll see it blink.
      ----------------------------------

      Ex Hex

      Comment


      • #5
        I know about CTRL+E ...
        If I am in Off-line mode it can be useful.
        But in On-line mode it could be a disaster

        Comment


        • #6
          That is a bummer. I do the exact same thing to track moves, I also set up an Autohotkey to do "ctrl+F4" to open program mode, then it pauses and types "n" because NO I DON'T EVER WANT YOU TO MOVE ME TO THE END OF THE PROGRAM! WHY ISN'T THERE A "DON'T ANNOY ME WITH THIS AGAIN" BOX TO TICK!?!?

          OK, sorry for yelling. I guess the other solution is to go back to what I used to do, which was execute the move, and then select program mode (part of the reason for making that hotkey)... But then there is the annoyance of having to re-select Program Mode every single time you execute anything. Apparently the only way around that is to have an actual CMM loaded in Hardware Definitions (or so I have read here somewhere...)?

          Comment


          • #7
            Maybe you could open up an auto vector point & type in the coordinates of your move point into that feature. This will put your probe there and give you an accurate view of where that move point would be. Once you're done, delete the point.
            SF7107(PCD), SF454(PCD), 152614(Quindos), 9159(Quindos), 7107(Quindos), B&S Manual, M&M Gear Checker

            Comment


            • #8
              Alt + P shows path lines including move points...

              Comment


              • #9
                Tomorrow morning I will try what can I do with both methods but I think that these procedures are longer than mine.

                Comment


                • #10
                  There a checkbox in setup options (F5) for "animate probe in program mode" (or something close to that).

                  I'm just throwing this out here. I've never programmed pcdmis online, so I have no idea if it will help.

                  Comment


                  • #11
                    CTRL-P is a way but I have probes with long stylus (500mm). So I want to know where is the tip but most of all I want to know where is the head, particularly when the probe come from his slot.

                    Also every time I use CTRL-P it send you at the bottom of the program. It's annoying.

                    I already searched in the F5 options and I didn't find nothing about my problem.

                    Comment


                    • #12
                      Have there been any updates on this issue? I just now updated to 2017 R1 and was used to doing the same thing as Leonida.
                      Slightly disappointing!

                      Comment


                      • #13
                        On the "graphic items" toolbar is a show probe button. Check if it is selected. If it is not the probe will be hidden. I am offline but if I select "show probe" then go into program mode. The move point dialog works as expected. The probe is visible and will be shown at the xyz values.

                        Comment


                        • #14
                          Thank you for the response rjurca.
                          Yes, it is selected and the probe is shown on the screen.
                          My issue is that I use F9 to open the Move Point dialog box and the location shown in the probe readout does not match the code.
                          In the previous version that I was using the probe would move to the correct location if I clicked in one of the XYZ boxes.
                          In 2017 R1 it is not working. If I click in one of the XYZ boxes and change the number slightly it will move to the correct location.
                          If I then open another Move Point the probe is still shown at the same location.
                          Again if I change one of the numbers in the XYZ boxes it will then move to the correct location.

                          Thank you again for your suggestion.

                          Brian

                          Comment


                          • #15
                            rjurca This seems to be the same thing I reported in JIRA in the beginning of June - PCD-144198. As I wrote there:

                            Originally posted by AndersI in JIRA
                            Procedure in 2016 and older to see the probe at the correct place in the GW:
                            • F9 on the MOVE command
                            • press TAB
                            Procedure in 2017 and later:
                            • F9 on the MOVE command
                            • click with the mouse in the X coordinate field
                            • change the X coordinate (at least one digit must be different!)
                            • press TAB
                            The problem still remains in 2018 R2.
                            Last edited by AndersI; 08-03-2018, 08:42 AM.
                            AndersI
                            SW support - Hexagon Metrology Nordic AB

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X