Avoidance moves

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Avoidance moves

    A Little help please.

    I've just tried to measure a standard CIR on auto feature, with "No avoidance move", but it keeps adding avoidance moves?

    PC-DMIS 2014.1

  • #2
    Hi Terry (Brompton ? )


    Can you describe the behaviour a bit more - is it definitely an avoidance move? Is it doing it before and/or after? Is it on every circle? Is it a new program in 2014.1 or and old program opened up in it?
    Automettech - Automated Metrology Technology

    Comment


    • #3
      Hi Ninja

      Its a new program; Its adding avoidance moves both before and after the feature. I've just tried a manual circle, which ran correctly, then it added a move not in the program!

      Comment


      • #4
        Originally posted by Terrybike View Post
        Hi Ninja

        Its a new program; Its adding avoidance moves both before and after the feature. I've just tried a manual circle, which ran correctly, then it added a move not in the program!
        Hi Terry (it's Jon Wood btw - if you are who I think you are!)

        When you have the auto feature dialog window open, so you can see the path lines of the feature in the graphics window, can you see the avoidance move path line shown there or not?


        Also does it show in the edit window code as being set to both? (can you copy/past the code from the edit window for the feature in question?)
        Automettech - Automated Metrology Technology

        Comment


        • #5
          Hi Jon
          So I learned PC-DIMS from a demi-Guru Badger!

          I trust all is well with you.

          When the auto features dialog is open I can see the avoidance path line before the feature, but not the one after the feature, however, it operates both ways.

          CIR1 =FEAT/CONTACT/CIRCLE/DEFAULT,CARTESIAN,OUT,LEAST_SQR
          THEO/<0,16.95,0>,<0,-1,0>,25.4,0
          ACTL/<0,16.95,0>,<0,-1,0>,25.4,0
          TARG/<0,16.95,0>,<0,-1,0>
          START ANG=-95,END ANG=95
          ANGLE VEC=<-0.0036069,0,0.9999935>
          DIRECTION=CCW
          SHOW FEATURE PARAMETERS=NO
          SHOW CONTACT PARAMETERS=YES
          NUMHITS=5,DEPTH=-5,PITCH=0
          SAMPLE METHOD=SAMPLE_HITS
          SAMPLE HITS=0,SPACER=1
          AVOIDANCE MOVE=NO,DISTANCE=10
          FIND HOLE=DISABLED,ONERROR=NO,READ POS=NO
          SHOW HITS=NO

          Comment


          • #6
            haha!

            Probably wasn't a demi-guru back then!


            Hmmm very odd - are you using clear planes or the clearance cube?

            If you adjust the DISTANCE=10 value does it change it's avoidance move accordingly?


            I'm not running 2014.1 so I can't see if I can emulate this - but it seems pretty peculiar
            Automettech - Automated Metrology Technology

            Comment


            • #7
              Have you tried changing the avoidance distance to 0? Just a shot.

              Comment


              • #8
                Is clearplane on?
                Jesse Krook

                Comment


                • #9
                  No clearance plain or cube in use. I changed the avoidance move to 0 and it still moved to avoid. So I've replaced the part program from scratch and the machine in working properly.If I go back into the old part program it has this error. Its been one of those days!

                  Comment


                  • #10
                    Originally posted by Terrybike View Post
                    No clearance plain or cube in use. I changed the avoidance move to 0 and it still moved to avoid. So I've replaced the part program from scratch and the machine in working properly.If I go back into the old part program it has this error. Its been one of those days!

                    In a change from that standard 'have you tried switching it off and back on again' - Have you tried switching it ON then back off again?
                    Automettech - Automated Metrology Technology

                    Comment


                    • #11
                      Yes, I even tried turning the CMM off.

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X