Probe Not showing correct location in graphics window

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Probe Not showing correct location in graphics window

    So I only received 4 days of training before getting thrown to the wolves with cmm and pcdmis...

    My probe is not showing the correct location in the graphics window when I set the probe to the angle of 60, 75, or 90. Ive calibrated all angles of the probe to the best of my knowledge. There has to be a reason why!

    Thanks for any help!

  • #2
    OFFLINE or ONLINE ? Starting NEW program or Existing proven program ? Are you working with a Cad Model ? Your probe "graphic" can and will change according to your current alignment.

    Comment


    • #3
      ...and does the machine axis' match the CAD axis'? (F5 settings)

      That can also affect the probe display for reasons listed by Schlag above.
      Last edited by vpt.se; 03-19-2015, 03:02 AM.
      PC-DMIS CAD++ 2o19 R1 SP11

      Comment


      • #4
        Schlag,

        Online, new program and existing proven program, and not sure about the cad model.

        Vpt.se,
        After pressing (F5) and checking the part/machine the machine axis and CAD axis do match.


        More back light on my situation, the guy who taught me created and used a certain probe tip for all his programs but some how it was deleted when I opened pcdmis 4.1. So I went back to 3.7 and to the best of my knowledge recreated the right probe and calibrated all the angles. I was able to create a program, touching off surface points and some trim edges. The trim edges were at and angle of 30,-150 but as soon as I tried to position the probe tip to 60, 75, or 90 the probe in my graphics window moves to a different point.

        Comment


        • #5
          Your not sure if you are using a CAD model ?

          IF you switch versions of DMIS and you found that the probe file was somehow "deleted" its not. When a new version came out it seemed like they continuously changed the location where dims looked for certain files. Go to EDIT / SET SEARCH PATH / PROBE DIRECTORY on the main dmis screen. ( not from an open program ) And change the path to where your probes are stored. Or, copy them, and place a copy of the 3.7 probes in the correct folder for your version 4.1. That way you will still be able to use the probe files for 3.7 if needed.

          Comment


          • #6
            Remember I've only had a 4 day crash course with this. So I guess Im not sure what you mean CAD model, would that be the step file I imported?

            I have all the probe tips that were in the files for 3.7 and 4.1 but there is one that the previous guy created "B89" and when I go to select said probe I get this message: "Reading or Writing is not allowed for probefile C:\Cmm Folder\Prob 3.7\B89.PRB because the version is not recognized. The file may be from a version of PC-DMIS newer than your current PC-DMIS version. If not, the file may have be corrupted"

            Comment


            • #7
              The step file is your model.

              The B89 probe file is probably one used by mfg / B&S service folks.

              TK
              sigpicHave a homebrew

              Comment


              • #8
                Sorry. I was looking at your Forum JOIN date of Sept 2011, I guess I was assuming that you had been doing this for 4.5 years. Where you using 3.7 when you saw that message ? I would say that probe file was used/opened with your version 4.1 and up has been "updated" to 4.1,, and will no longer be able to be used with 3.7. This is the issue I was trying to get at earlier. By having seperate ( but same ) probe files for the differrent versions, you will not have this issue. Back your issue of your probes not looking correct. When you import your step file ( cad model would just be generic term ) and the models orientation ( X-Y-Z ) does not match how it is actually sitting on the cmm, it will show your probe graphic in relation to the model all "wonky". You will need to "adjust" the model to match the cmm axis. There are multiple ways to do this and everyone really has their own preferences on how to go about doing it.

                Comment


                • #9
                  Sorry about the confusing I recovered this profile from whom ever had it back in 2011 (Ronald)

                  Its not that the parts are orientated differently from "on ccm" to the "graphics window", its when im writing a program and go to change the angle of the probe to 60, 70, or 90 it "jumps" from the part and thinks its somewhere else(its actually 1 inch from the part "on cmm" but in graphics window its now 6+ inches away). If that makes any sense.. Ill see about posting a picture of it, im probably not describing it correctly.. sorry.

                  Comment


                  • #10
                    Probe 0,0.jpgProbe 75,180.jpg

                    I believe I uploaded the two pictures, one being the probe at 0,0 and the other 75,180. In 0,0 the probe is where it actually is on the cmm and graphics window and the 75,180 shows you what happens when I try to change the angle. The blue circle is where it is actually on the cmm and where it should be in the graphics window.

                    Comment


                    • #11
                      Originally posted by RONALD VANDER WERFF View Post
                      [ATTACH=CONFIG]10190[/ATTACH][ATTACH=CONFIG]10191[/ATTACH]

                      I believe I uploaded the two pictures, one being the probe at 0,0 and the other 75,180. In 0,0 the probe is where it actually is on the cmm and graphics window and the 75,180 shows you what happens when I try to change the angle. The blue circle is where it is actually on the cmm and where it should be in the graphics window.
                      vpt.se meant to say that immediately right after you import the CAD model, does the trihedron on the graphics display matches machine axes? If it doesn’t, then you have to F5 and change machine axes to match CAD axes, it is essential when working with CAD and I believe you missed that step based on the pictures you posted. If you have done it correctly, the probe read out on first picture should be:

                      X -1972.530
                      Y -151.869
                      Z -67.917

                      Instead of:

                      X 1972.530
                      Y 151.869
                      Z 67.917
                      Last edited by DungT; 03-20-2015, 10:06 AM.

                      Comment


                      • #12
                        Well I believe I fixed my problem... When I was calibrating the probe one angle hit a boundary of the machine... And I moved the calibrating tool with out thinking about how it would throw off the machine... OOPS... Thanks for all the help

                        Comment

                        Related Topics

                        Collapse

                        Working...
                        X