Datapage/New style true position

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Datapage/New style true position

    Anyone have issues with trying to send the new style TP dimension results to Datapage.

    I wouldnt be asking but Im having troubles atm. My report looks "normal" but I get garbage/nonsense results within Datapage. (nonsense like dimensions being up to 200mm out of position or randomly missing all together)

    I created a new Database to send the results to.

    Datapage version 3.33
    PCDMIS version 4.1

    Thanks again all
    Mr. Comment
    SCIROCCO-NT 13-20-10
    B3C-LC Controller (Leitz Protocol), SP600M, TP200
    PCDMIS CAD++ v4.3 MR1(Build: 12/11/08)
    sigpic

  • #2
    What axis are the TP callouts? I recall a time when any TP outside of X,Y (Z workplane) was goofy. I can't say it was goofy in regards to Datapage but it was an odd issue but that was way back during 3.2. Just taking a stab at it. If it is outside X, Y axis can you realign to make it X and Y reporting and see what you get in Datapage?

    Craig
    <internet bumper sticker goes here>

    Comment


    • #3
      That was my first thought actually. However instead of recalling the alignment I placed the dimension command just after the measured features and before switching to a different alignment.

      Its almost like there isnt enough variables assigned to hold all the Data in Datapage for each dimension. The results for the TP dimension looks similar to the old school TP dimensions, but of course the new style dimensioning is totally different looking.

      The two attachments show an example of each output, PCDMIS and whats in Datapage as a result.
      Last edited by MrComment; 12-11-2006, 02:52 PM.
      Mr. Comment
      SCIROCCO-NT 13-20-10
      B3C-LC Controller (Leitz Protocol), SP600M, TP200
      PCDMIS CAD++ v4.3 MR1(Build: 12/11/08)
      sigpic

      Comment


      • #4
        PCDMIS may not be sending all the info to DP.
        What you would need to look at (or post) is the XSTATS11.TMP file just before PCDMIS updates the database. You can say "NO" to update the database now, copy the file, then Insert/Statistics Command/Statistics. When the dialog is displayed, press "Update the database now" button to send the current data to the database. There was a bug in pcdmis which did not sent the correct information when using the new style feature control frames.

        Comment


        • #5
          This is a little late but we had to give the features differnt names for each alignment you wanted to use because Data page will only keep the last info
          for the feature it checks and will destory the previous data that was checked

          Comment


          • #6
            It will keep the data IF you are saving the data BY DIM ID's instead of Feature ID's. If using Feature ID's, yes, it can ONLY remember the LAST dimension for that feature, but since you CAN NOT USE duplicate ID's for dimensions, each dimension WILL be a unique entity when sent to Datapage.
            sigpic
            Originally posted by AndersI
            I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

            Comment


            • #7
              That is probably it. I was looking at those numbers and it made no sense. I myself send dimension info to Datapage so those numbers blew me away. It is possible you are sending feature info perhaps, I don't know I never do that. What does feature info go over as in Datapage name wise? I see his Datapage report is all dimension names. I also see you are using the pound (sharp) character in your naming convention. It might be a long shot but does that have an ill effect. Last I knew it does not effect Datapage but I am afraid at this point I do not have much to offer.

              Craig
              <internet bumper sticker goes here>

              Comment


              • #8
                Here's my xstats11.TMP results just after running a part.

                I selected "NO" to update Datapage when prompted as you described, but after copying the file I used the "Update Database now" button inside the statistics command. (Inserting a new stat command, didnt prompt me for an update) The resulting data in TestPartDataInDatapage is what ended up in Datapage however.

                036.pdf is just the report generated by PCDMIS for this part for reference.

                After looking at these results should I assume the data is not getting formatted correctly to get put into Datapage in the first place? From the xstats11.tmp data I appears that the "set" data for the TP features is whats being sent, which may explain the numbers that are out in outer space, but what or why is it choosing the nominals it did, and I guess more importantly how do I get the rest of the results.

                I removed the "#" symbols from my Dimension names to make sure that it wasnt a illegal or misdirecting character or something like that. (Good thought)

                One more thing I've noticed and that I'm 99.9% sure of is that for some reason on DIM597 the MMC modifier for Datum C is disappearing (unchecking itself)randomly? I was hoping someone else might be able to confirm this is also a known bug, this way I can stop thinking Im going crazyier then I already am.

                Thanks again everyone
                Last edited by MrComment; 12-11-2006, 02:52 PM.
                Mr. Comment
                SCIROCCO-NT 13-20-10
                B3C-LC Controller (Leitz Protocol), SP600M, TP200
                PCDMIS CAD++ v4.3 MR1(Build: 12/11/08)
                sigpic

                Comment


                • #9
                  The data in the XSTATS pdf does not look correct. Any chance of getting the actual file (or copy of it) instead of the pdf output?

                  Comment


                  • #10
                    Attached, but had to ZIP to make it a valid file extension.
                    Last edited by MrComment; 12-11-2006, 02:52 PM.
                    Mr. Comment
                    SCIROCCO-NT 13-20-10
                    B3C-LC Controller (Leitz Protocol), SP600M, TP200
                    PCDMIS CAD++ v4.3 MR1(Build: 12/11/08)
                    sigpic

                    Comment


                    • #11
                      Yes - the results in the stats file seem wrong.
                      Just as one example:
                      DIM312 SetDIM312 Y 158.500000 0.000000 0.000000 317.178152
                      Looks like the NOMINAL (158.50) for this is using the value from SET.Y but the actual measured value (317.178152) is from CIR2.Y

                      Comment


                      • #12
                        Ya, I agree too. Its nonsense. Any idea how to fix it?

                        Thx
                        Mr. Comment
                        SCIROCCO-NT 13-20-10
                        B3C-LC Controller (Leitz Protocol), SP600M, TP200
                        PCDMIS CAD++ v4.3 MR1(Build: 12/11/08)
                        sigpic

                        Comment


                        • #13
                          Also been noticing another problem, not sure if its related or not.

                          Randomly? Maybe. I noticed I get measurement on my cylinders which was way too big. Bad hit maybe? Oddly though the position of the cylinder is relatively close to where it should be, but looking at the screen it appears extremely tipped? If I remeasure the part 7 out of 10 times its measures correctly.

                          Only work around I know is shown below:
                          $$ NO,Check Hole size for general correctness
                          ,Exit Program otherwise
                          IF/CIR3.D>9
                          COMMENT/OPER,NO,CIR3 Diameter, nonsense value error, ErrorTrap2
                          PROGRAM/END
                          END_IF/
                          IF/CIR4.D>9
                          COMMENT/OPER,NO,CIR4 Diameter, nonsense value error, ErrorTrap2
                          PROGRAM/END
                          END_IF/
                          IF/CIR5.D>9
                          COMMENT/OPER,NO,CIR5 Diameter, nonsense value error, ErrorTrap2
                          PROGRAM/END
                          END_IF/
                          IF/CIR6.D>9
                          COMMENT/OPER,NO,CIR6 Diameter, nonsense value error, ErrorTrap2
                          PROGRAM/END
                          END_IF/

                          Any ideas on this error as well?

                          Thxs again
                          Last edited by MrComment; 12-11-2006, 02:52 PM.
                          Mr. Comment
                          SCIROCCO-NT 13-20-10
                          B3C-LC Controller (Leitz Protocol), SP600M, TP200
                          PCDMIS CAD++ v4.3 MR1(Build: 12/11/08)
                          sigpic

                          Comment


                          • #14
                            No ideas on that one. Probably would need to generate a debug file and contact B&S tech support. Probably should anyway to allow them to file a report to make sure both items are corrected.

                            Comment


                            • #15
                              In regards to the second problem. See the attached pdf.

                              All the hits look to be pretty close to where they should be dont they?
                              Last edited by MrComment; 12-11-2006, 02:52 PM.
                              Mr. Comment
                              SCIROCCO-NT 13-20-10
                              B3C-LC Controller (Leitz Protocol), SP600M, TP200
                              PCDMIS CAD++ v4.3 MR1(Build: 12/11/08)
                              sigpic

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X