Probe autocalibrate question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Probe autocalibrate question

    When I have an autocalibrate routine in my program...:
    AUTOCALIBRATE/PROBE, PARAMETER_SET=963.30126, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=NO

    ...the report prints information about the calibration:
    BEGIN AUTOCALIBRATE RESULTS FOR DISC 14MM BY 2MM BY 5MM USING SET 963.30126
    etc.
    etc.

    How do I prevent the calibration results from being included in the result?
    edit: figured this one out. One Dee One Zero Tee error

    If I set OVERWRITE_RESULTSFILE to YES, will it function the same as if I did the probe calibration "manually"
    Last edited by Erikir; 01-09-2013, 06:02 PM.
    2012 CAD++ MR1
    Brown & Sharpe ONE
    PH10T

  • #2
    i believe at normal circumstances, we would want the result file to be overwritten~ and yes, should be the same as manual probe calibration.

    Comment


    • #3
      Originally posted by Vinson View Post
      i believe at normal circumstances, we would want the result file to be overwritten~ and yes, should be the same as manual probe calibration.
      Whenever you run a calibration routine the software updates its internal results file with the new calibration.
      The results file you can see is only a text file of the calibration results, not what the software actually uses.
      You can delete this file and it wont affect your cmm.
      If you leave the "overwrite_resultsfile" set to "no" all that means is you keep a record of every time the calibration file was altered.
      Its very useful if you want to find out if operators have been changing anything in the calibration files.
      Roses are red
      Violets are glorious
      Don't try to sneak up
      On Oscar Pistorius.

      MIL-TFP-41C

      3.7mr3, 2012mr1, 2013mr1

      Comment


      • #4
        Originally posted by pwhitsa View Post
        If you leave the "overwrite_resultsfile" set to "no" all that means is you keep a record of every time the calibration file was altered.
        Its very useful if you want to find out if operators have been changing anything in the calibration files.
        +1 on that! I can't count how many support cases have come down to calibration errors, which would have been immediately obvious if the calibration history had been available.
        AndersI
        SW support - Hexagon Metrology Nordic AB

        Comment


        • #5
          Originally posted by pwhitsa View Post
          Whenever you run a calibration routine the software updates its internal results file with the new calibration.
          The results file you can see is only a text file of the calibration results, not what the software actually uses.
          You can delete this file and it wont affect your cmm.
          If you leave the "overwrite_resultsfile" set to "no" all that means is you keep a record of every time the calibration file was altered.
          Its very useful if you want to find out if operators have been changing anything in the calibration files.
          That's what I suspected. Thanks!
          2012 CAD++ MR1
          Brown & Sharpe ONE
          PH10T

          Comment


          • #6
            What do you do if when you calibrate, the results file is blank? how do I fix that?
            sigpicTAU ALPHA PI INDIANA DELTA CHAPTER
            "Due to the highly confidential nature of my job, I am not allowed to know what I am doing" - author unknown

            Comment


            • #7
              You should check some parameters (how PC-DMIS writes values (add,...)), check also if there's a warning (F5) about bad calibration (i'm not at the CMM, I don't remember the param...)

              Comment


              • #8
                It turns out the the permission to write to the .results file was being denied by WIN7, go figure..........
                sigpicTAU ALPHA PI INDIANA DELTA CHAPTER
                "Due to the highly confidential nature of my job, I am not allowed to know what I am doing" - author unknown

                Comment


                • #9
                  I think PC-DMIS is designed to run in admin mode only... There are to much info to write in the register, in files (...), and there are to much bans from IT department to work as you want !!!!!

                  Comment


                  • #10
                    I think PC-DMIS is designed to run in admin mode only... There are to much info to write in the register, in files (...), and there are to much bans from IT department to work as you want !!!!!
                    I think this changed with version 2012, or maybe 2013. I remember reading that they have changed where the shared info is saved so that running as admin is only required at install and first launch.
                    2013MR1 SP6
                    Global Frames, Tesastar-M Heads, LSP-X1M/H Probes

                    Comment


                    • #11
                      Starting with version 2010 MR2, PC-DMIS moved all data files to Windows 7 approved locations. Excepting some bugs - one from the Amuyni PDF driver install program, one from the Toolkit option.

                      You shouldn't run anything as Admin unless it is explicitly needed. A correctly installed PC-DMIS (later than 2010) does not need it.
                      AndersI
                      SW support - Hexagon Metrology Nordic AB

                      Comment


                      • #12
                        Originally posted by Erikir View Post
                        When I have an autocalibrate routine in my program...:
                        AUTOCALIBRATE/PROBE, PARAMETER_SET=963.30126, QUALTOOL_MOVED=NO,
                        SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=NO

                        ...the report prints information about the calibration:
                        BEGIN AUTOCALIBRATE RESULTS FOR DISC 14MM BY 2MM BY 5MM USING SET 963.30126
                        etc.
                        etc.

                        How do I prevent the calibration results from being included in the result?
                        edit: figured this one out. One Dee One Zero Tee error
                        Does anybody know the answer to this? I have the same question, and the OP didn't really elaborate here.


                        Error in best fit calculation

                        Comment


                        • #13
                          SHOW_SUMMARY=NO should to it if I recall correctly.
                          Systems Integrator
                          Hexagon Manufacturing Intelligence

                          Comment


                          • #14
                            I have SHOW SUMMARY unticked and it still prints calibration results at the top of the report.

                            Code:
                                        LOADPROBE/2X61
                                        TIP/T1A90B-90, SHANKIJK=1, -0.003, -0.003, ANGLE=-89.561
                            C1         =COMMENT/YESNO,NO,FULL SCREEN=NO,AUTO-CONTINUE=NO,
                            
                                        Has the probe stylus been unscrewed from the module?
                            
                                        IF_GOTO/C1.INPUT=="NO",GOTO = SKIP_CALIBRATION
                                        AUTOCALIBRATE/PROBE, PARAMETER_SET=Used in routine only, QUALTOOL_MOVED=NO, 
                                                      SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=NO
                            SKIP_CALIBRATION=LABEL/
                                        MOVESPEED/ 110
                            I found another possible solution in a really old thread but I don't know if it's viable because it relates to v3.5, whereas I'm using 2016. Also, I would think that there would be a simpler solution than using a big block of code.

                            http://www.pcdmisforum.com/forum/pc-...nt-cal-results

                            Error in best fit calculation

                            Comment


                            • Rondog
                              Rondog commented
                              Editing a comment
                              This is an old bug. The SHOW_SUMMARY/YES|NO should work but it doesn't. It hasn't worked from some time now.

                              One way around this is to modify the report template and add a rule for a probe autocalibrate command. You could add a conditional expression (so that the SHOW_SUMMARY actually works properly) or you can have it do something unconditionally like print a single space when this command is found. If you use an unconditional expression then duplicate the report template so you have the ability to print a report with or without the calibration summary (you will have two different report templates with different rules to handle this).

                              This is in the rules section of the report template (template editor - properties - rule tree). You have options to add expressions to pretty much every type of PC-DMIS command in your program in the rule tree. The one you are interested in is for the autocalibrate probe command.

                            • Numbers Game
                              Numbers Game commented
                              Editing a comment
                              Will have to give this a try later. Thanks for the input.

                            • Numbers Game
                              Numbers Game commented
                              Editing a comment
                              Just to follow up, this did the trick. Created a rule: IF autocalibrate probe>AND SHOW_SUMMARY=NO>THEN: use nothing

                              Thanks again.

                          • #15
                            Numbers Game...I have been trying to fix this problem for a while. I don't want my calibration results on my report. If you could be so kind, can I get the exact code to remove the results from you. I typed it as you had it but I did something wrong I guess...

                            Comment


                            • Numbers Game
                              Numbers Game commented
                              Editing a comment
                              I'm tied up right now but whenever I have a moment, I could take a screenshot of my rule tree. You have to go into the rules, find "autocalibrate" or "probe calibrate" or something like that (can't remember now) and create the rule there.

                          Related Topics

                          Collapse

                          Working...
                          X