New to CAD... what's wrong???

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New to CAD... what's wrong???

    I imported the bsblockm.igs into a file, then I've tried to offline program an alignment matching the alignment of the cad. after that, I run a dcc mode plane off the top surface, and it keeps crashing my probe, trying to find a point deeper than the top surface...

    the manual is not a lot of help with this... you guys are my best source... HELP!


    thanks


    kev


    here's the code in case anyone needs to see it... and fyi... when I did the clearplane, I was originally using zplus .5mm, but it would crash the side, so I had to finally set it at 5.0mm to get it to clear what should be zero... ???


    thanks again!




    Code:
    PART NAME  : cad_test_mm
    REV NUMBER : 
    SER NUMBER : 
    STATS COUNT : 1
     
    STARTUP    =ALIGNMENT/START,RECALL:, LIST= YES
                ALIGNMENT/END
                MODE/MANUAL
                PREHIT/ 0.05
                RETRACT/ 0.05
                LOADPROBE/3X40MM
                TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
                FORMAT/TEXT,OPTIONS,HEADINGS,SYMBOLS, ;NOM,TOL,MEAS,DEV,OUTTOL, , 
                WORKPLANE/ZPLUS
    PLN1       =FEAT/PLANE,RECT
                THEO/102.831,37.011,0,0,0,1
                ACTL/153.221,178.209,-504.631,0.0002112,0.0003389,0.9999999
                MEAS/PLANE,3
                HIT/BASIC,76.026,12.14,0,0,0,1,136.704,159.832,-504.621,USE THEO = YES
                HIT/BASIC,78.346,86.754,0,0,0,1,137.784,212.982,-504.639,USE THEO = YES
                HIT/BASIC,154.12,12.14,0,0,0,1,185.176,161.813,-504.632,USE THEO = YES
                ENDMEAS/
    LN1        =FEAT/LINE,RECT,UNBND
                THEO/27.94,0,-1.497,1,0,0
                ACTL/72.285,147.863,-507.669,0.9999854,-0.0054032,0
                MEAS/LINE,2,WORKPLANE
                HIT/BASIC,27.94,0,-1.497,0,-1,0,72.285,147.863,-507.669,USE THEO = YES
                HIT/BASIC,200.66,0,-1.497,0,-1,0,115.648,147.628,-507.671,USE THEO = YES
                ENDMEAS/
    LN2        =FEAT/LINE,RECT,UNBND
                THEO/0,8.703,-20.605,0,1,0
                ACTL/59.825,156.235,-525.125,0.0077581,0.9999699,0
                MEAS/LINE,2,WORKPLANE
                HIT/BASIC,0,8.703,-20.605,-1,0,0,59.825,156.235,-525.125,USE THEO = YES
                HIT/BASIC,0,78.33,-20.605,-1,0,0,60.066,187.265,-525.115,USE THEO = YES
                ENDMEAS/
    A1         =ALIGNMENT/START,RECALL:STARTUP, LIST= YES
                ALIGNMENT/LEVEL,ZPLUS,PLN1
                ALIGNMENT/ROTATE,XPLUS,TO,LN1,ABOUT,ZPLUS
                ALIGNMENT/TRANS,XAXIS,LN2
                ALIGNMENT/TRANS,YAXIS,LN1
                ALIGNMENT/TRANS,ZAXIS,PLN1
                ALIGNMENT/END
                CLEARP/ZPLUS,5,ZPLUS,0
                COMMENT/OPER,DCC Mode!
                MODE/DCC
    PLN2       =FEAT/PLANE,RECT
                THEO/118.939,44.228,0,0,0,1
                ACTL/59.572,-103.554,504.578,-0.0002094,-0.0003401,0.9999999
                MEAS/PLANE,4
                MOVE/CLEARPLANE
                HIT/BASIC,76.8,10.207,0,0,0,1,17.616,-137.803,504.558,USE THEO = YES
                HIT/BASIC,79.506,86.754,0,0,0,1,19.909,-61.242,504.584,USE THEO = YES
                HIT/BASIC,164.558,64.718,0,0,0,1,105.079,-82.818,504.595,USE THEO = YES
                HIT/BASIC,154.893,15.233,0,0,0,1,95.682,-132.355,504.576,USE THEO = YES
                ENDMEAS/
    Kevin N. Thompson - Thompson Digital Image
    Quality Manager - Rj Link International

  • #2
    Try increasing your prehit/retract to 4mm+. You only have .002" hit prehit/retract.
    Bristol Citysigpic
    Home of the Reds

    Comment


    • #3
      yeah... I just saw that... came in here to delete the post before anyone saw how dumb that was... hehehe... it's these 3rd shift hours... I forgot I was working in mm...


      thanks!



      Kevin
      Kevin N. Thompson - Thompson Digital Image
      Quality Manager - Rj Link International

      Comment

      Related Topics

      Collapse

      • gseith
        Yes No Comment Problem
        by gseith
        I am having a problem when entering a yes/no comment input step into my program.
        The program runs all the through with no problems when I click...
        12-28-2010, 12:17 PM
      • emurray
        Please take a look
        by emurray
        I am running a pre-existing program for one of our parts. The problem I am having (this time) is after I am prompted to take my manual measurments,...
        08-14-2007, 12:32 PM
      • zonionman
        Offline Code Alignment Issues
        by zonionman
        I have two different programs I wrote for two different impellers, but the manual alignment is the same for both, dimensions and all. The first one I...
        07-26-2013, 04:04 PM
      • Ken379128
        Nominals changing
        by Ken379128
        Why when I run thru a program do my nominals keep changing. I go in put them to what I want and when it runs it changes it right back????...
        02-03-2007, 10:29 AM
      • mr500
        Tell me why!
        by mr500
        When I execute my program, it always asks me to hit points on the first plane. Even when I DO NOT mark the man align it still asks. AND when I do hit...
        08-05-2008, 07:58 AM
      Working...
      X