AutoCalibrate Probe Changer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AutoCalibrate Probe Changer

    OK guy's. Here is an easy one(I hope).
    Can someone tell me an easy way of writing a program that will calibrate all the probes I have in my probe changer at one time.
    I want to be able to call up a program that will calibrate the probes so I do not have to do it manually.
    I am thinking I need something like this so when I get here first thing in the mornings I can just call up that program and while it is running I can finish my coffee and get ready for the day.
    Thanks ahead of time.
    3.5MR2
    B. Jacobs
    B&S Global 12.15.10
    2014.1

  • #2
    Bryan, I have 2 mcr20 tool racks and this is the way I do the auto cal on my machine.

    By the way, 3.5 MR2




    STARTUP =ALIGNMENT/START,RECALL:, LIST= YES
    ALIGNMENT/END MODE/MANUAL
    MOVESPEED/ 100
    FLY/ON,0.125
    FORMAT/TEXT,OPTIONS,HEADINGS,SYMBOLS, ;MEAS,NOM,DEV,TOL,OUTTOL, ,
    LOADPROBE/SLOT_1
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=YES,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_2
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_3
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_4
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_5
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_6
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_7
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_8
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_9
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_10
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    LOADPROBE/SLOT_11
    TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=90
    AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
    SHOW_SUMMARY=NO, OVERWRITE_RESULTSFILE=YES
    Last edited by Roger Kilpatrick; 09-07-2006, 04:46 PM.
    sigpic Eye Yam Sofa King We Todd It.

    Comment


    • #3
      This what we use running V3.7mr3.



      PART NAME : TIP CALIBRATION
      REV NUMBER :
      SER NUMBER :
      STATS COUNT : 1

      STARTUP =ALIGNMENT/START,RECALL:, LIST= YES
      ALIGNMENT/END
      MODE/DCC
      LOADPROBE/TIP5
      TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
      FORMAT/TEXT,OPTIONS, ,HEADINGS,SYMBOLS, ;NOM,TOL,MEAS,DEV,OUTTOL, ,
      C1 =COMMENT/INPUT,YES,'Employee Clock Number'
      C2 =COMMENT/INPUT,YES,'Shift'
      AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=YES,
      SHOW_SUMMARY=YES, OVERWRITE_RESULTSFILE=YES
      BEGIN AUTOCALIBRATE RESULTS FOR PROBE TIP5 USING SET ALL-TIPS-WITH-DEFAULTS
      ****************** your probe file will load and measure here *************************
      END AUTOCALIBRATE RESULTS FOR PROBE TIP5 USING SET ALL-TIPS-WITH-DEFAULTS
      MOVE/INCREMENT,0,0,2
      LOADPROBE/TIP1
      TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
      AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
      SHOW_SUMMARY=YES, OVERWRITE_RESULTSFILE=YES
      BEGIN AUTOCALIBRATE RESULTS FOR PROBE TIP1 USING SET ALL-TIPS-WITH-DEFAULTS
      ****************** your probe file will load and measure here *************************
      END AUTOCALIBRATE RESULTS FOR PROBE TIP1 USING SET ALL-TIPS-WITH-DEFAULTS
      LOADPROBE/TIP6
      TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
      AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
      SHOW_SUMMARY=YES, OVERWRITE_RESULTSFILE=YES
      BEGIN AUTOCALIBRATE RESULTS FOR PROBE TIP6 USING SET ALL-TIPS-WITH-DEFAULTS
      ****************** your probe file will load and measure here *************************
      END AUTOCALIBRATE RESULTS FOR PROBE TIP6 USING SET ALL-TIPS-WITH-DEFAULTS
      LOADPROBE/TIP6
      TIP/T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
      AUTOCALIBRATE/PROBE, PARAMETER_SET=ALL-TIPS-WITH-DEFAULTS, QUALTOOL_MOVED=NO,
      SHOW_SUMMARY=YES, OVERWRITE_RESULTSFILE=YES
      BEGIN AUTOCALIBRATE RESULTS FOR PROBE TIP6 USING SET ALL-TIPS-WITH-DEFAULTS
      ****************** your probe file will load and measure here *************************
      END AUTOCALIBRATE RESULTS FOR PROBE TIP6 USING SET ALL-TIPS-WITH-DEFAULTS
      Xcel & MicroVal Pfx & Global 37mr4 thru 2012mr1sp3
      Contura Calypso 5.4

      Lord, keep Your arm around my shoulder and Your hand over my mouth. Amen.

      Comment


      • #4
        The way I created this is to create a new program then go to "Insert" "Calibrate" "Auto Calibrate Probe". Should have mentioned that in my first post.
        sigpic Eye Yam Sofa King We Todd It.

        Comment


        • #5
          I have used the programs ya'll sent.
          I have one more question.
          When the calibration is done the wrist changes to A0B0. Is there a way to get the distance to change in the Z before it does this?
          I am worried that it might hit the table.
          Thanks
          B. Jacobs
          B&S Global 12.15.10
          2014.1

          Comment


          • #6
            NO, there is not, and I was forced to deal with this issue just recently.
            We ended up having to make a spacer block that we put under our cal sphere to get it up out of the way.
            Using the autocalibrate, and having probe calibration program that does all of our tips/probes (2 hours worth) was worth the time in the tool room for us.

            Although I had to learn the hard way, by having the probes hit the table many times before I figured out what was going on.

            Comment


            • #7
              Thanks Shelly,
              I tried all the clearance things in the probe set box but nothing was working.
              I don't have any tips that are hitting the table but some are pretty close.
              I will just let it go for now. If I get any longer probes I will need to do the Block thing. Thanks for that idea.
              B. Jacobs
              B&S Global 12.15.10
              2014.1

              Comment


              • #8
                I have sent this "issue" as they like to call them, to tech sup about 6months ago and heard back a couple days later with the answer...." just add a move point before the next tip command".....well let me tell you I used to always trust their answers in the past but not anymore.....IT STILL HIT THE TABLE.

                It ignored the move command because the motion it makes to A0,B0 is tied to the autocalibrate command internally and it will ALWAYS do it...period!

                I was given the advice on this forum to make a custom "parameter set" which would alow all the suspect positions to be cal'd first and work their way back up to A0,B0 as last position.

                give that a shot

                oh yeah 3.5 mr2 also
                sigpiccall me "Plum Crazy"....but you only go around once!

                Comment


                • #9
                  Originally posted by Mike N.
                  I have sent this "issue" as they like to call them, to tech sup about 6months ago and heard back a couple days later with the answer...." just add a move point before the next tip command".....well let me tell you I used to always trust their answers in the past but not anymore.....IT STILL HIT THE TABLE.

                  It ignored the move command because the motion it makes to A0,B0 is tied to the autocalibrate command internally and it will ALWAYS do it...period!

                  I was given the advice on this forum to make a custom "parameter set" which would alow all the suspect positions to be cal'd first and work their way back up to A0,B0 as last position.

                  give that a shot

                  oh yeah 3.5 mr2 also

                  I just cannot believe tech support could not help you. Pay all that money for what ????
                  sigpic.....Its called golf because all the other 4 letter words were taken

                  Comment


                  • #10
                    Originally posted by Mike N.
                    I have sent this "issue" as they like to call them, to tech sup about 6months ago and heard back a couple days later with the answer...." just add a move point before the next tip command".....well let me tell you I used to always trust their answers in the past but not anymore.....IT STILL HIT THE TABLE.

                    It ignored the move command because the motion it makes to A0,B0 is tied to the autocalibrate command internally and it will ALWAYS do it...period!
                    I tried the MOVE POINT also. It didn't work. I noticed it would make the tip change then go to the move point.
                    I don't have any probes long enough to hit just yet. It does give you the "Pucker Power" though.
                    B. Jacobs
                    B&S Global 12.15.10
                    2014.1

                    Comment


                    • #11
                      If i mention it correctly, the motion to A0B0 isn't neccessarily the 1st move after the autocalibrate;
                      -> instead it will go to the last active probe-rotation in front of the
                      autocalibrate line (but indeed that is mostly A0B0, see samples above ;>) )

                      But you're able to define it in an appropriate way, e.g.:
                      -A90B180 before Autocal (will also be the last rotation in the Autocal-routine)
                      - move point with clearance over the sphere
                      - Autocal-Line (here will A0B0 be the first position if you don't have defined
                      a "user defined calibration-order" !)
                      - A90B180
                      - move point up
                      - at least A0B0

                      Hope all is clear!

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X