Move all won't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Move all won't work

    Can someone please tell me why I can't get "move all" to work. I am using version 3.5MR2 on an Xcel machine with a PH10Q Renishaw probe head, I am not sure which controler. I don't care is it moves the machine and probe head in relation to each other as in sweep. I just want to be able to change probe angles during long drive moves. When I enter the command and try to execute it, I get the execution dialog box but nothing happens, it just sits there until I hit cancel.
    Last edited by Sean Steele; 08-29-2006, 11:22 PM.
    Thanks
    Sean Steele

  • #2
    Make sure you do not have another program open in the background.....or there could be another dialog box opened in the background.

    Doberman

    Comment


    • #3
      It could be your controller, not all controller support this option. Has it worked before on that machine?
      sigpic
      Originally posted by AndersI
      I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

      Comment


      • #4
        Matt, I asked the other operator, that has been here for a few years, if he has ever gotten it to work. He said "You mean that on the fly mode?" I took that as a no and proceeded to tell him what move all was. He said that he has never tried to use it. How can I tell what controller I have? If I have a controller that doesn't work with this command I will give up. Otherwise, I am going to send this problem to training along with our newest programmer.
        Thanks
        Sean Steele

        Comment


        • #5
          from F1

          Inserting a Move All Command
          The MOVE/ALL command
          will function with any
          motorized probe head -
          continuous or
          indexing - and any probe
          combination.
          The Insert | Move | Move All menu option inserts a MOVE/ALL command into
          the Edit window.
          A MOVE/ALL command is the same as a MOVE/POINT command combined with a
          TIP/ command. This command has the benefit of rotating the probe head together
          with machine movement.
          When using a wrist device (PHS, CW43L, or CW43) this movement is synchronized
          such that the wrist's AB movement will start and end its motion at the same time that
          the machine starts and ends the X,Y, and Z movement.
          When using this command with an indexable wrist such as a PH10M, this movement
          cannot be synchronized and will occur at an unspecified time during the machine
          movement (depending on time delays in the signal processing of the electronic
          hardware). Because of this, the AB wrist movement may not always complete by the
          time the machine performs the X, Y, and Z move.
          The MOVE/ALL Edit window command looks like this:
          MOVE/ALL,X,Y,Z,TIP=T1A0B0, SHANKIJK=0, 0, 1, ANGLE=0
          · X,Y,Z allow you to specify the X, Y, and Z coordinates to which to
          move the probe.
          · TIP= T1A0B0 shows the AB wrist movement to perform.
          · SHANKIJK = IJK allows you to specify the shank's vector.
          · ANGLE=0 specifies the theoretical angle.
          Note that the probe head angle will usually be a predefined TIP position.

          Comment


          • #6
            You should be able to get the controller type by looking at the installed modules. I think it is CUSTPROG.EXE and it should be in the install dorectory of Pcdmis. Run it and then you will see a drop-down window and in that you can find WHICH controller you have.
            sigpic
            Originally posted by AndersI
            I've got one from September 2006 (bug ticket) which has finally been fixed in 2013.

            Comment

            Related Topics

            Collapse

            • dwade
              MOVE/ALL not working
              by dwade
              Refurb PFx with new FB2 controller running V4.2mr1 and cannot get the MOVE/ALL command to rotate the probe head. If I take out the MOVE/ALL command and...
              12-07-2007, 06:22 AM
            • blewis
              Move All
              by blewis
              I am using PC-DMIS 4.1 on a Sheffield D-28 with a PHC 10-2 controller and a PH10T head and can not get a Move All command to work. It may be that I do...
              10-02-2007, 07:10 PM
            • Mark_MR1
              Manretract
              by Mark_MR1
              OK, I've done the search, and didn't really see what I need.

              MANRETRACT/2.54

              Apparently my CMM doesn't recognize this command....
              01-04-2016, 01:34 PM
            • lambo
              Move All
              by lambo
              Does 'Move All' command work on your machine?
              It does not work on Sheffield Endeavor 9.12.10 with PH10MQ probehead.

              Add on: I should...
              05-13-2008, 12:15 PM
            • rolsartom
              Probe Head Controller
              by rolsartom
              Fired up the cmm this morning all was fine, until a few minutes later, my controller box started making this loud humming noise, thoughts or ideas on...
              10-23-2008, 09:06 AM
            Working...
            X